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1. WorkZone Configuration Management

2021.1 Online Help
This Online Help describes how to configure WorkZone Content Server, WorkZone

Client, Captia Web Client, and WorkZone Explorer using WorkZone Configuration

Management.

The intended target audience for this guide is system administrators who configure and

maintain the basic data, which makes up the foundation for working with WorkZone

Content Server, WorkZone Client, Captia Web Client, and WorkZone Explorer.

WorkZone links

l
WorkZone documentation

l
WorkZone support

l
WorkZone website

l
WorkZone portal
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2. What's new
WorkZone Configuration Management 2021.1

No changes in this release.

WorkZone Configuration Management 2021.0

No changes in this release.

WorkZone Configuration Management 2020.3

No changes in this release.

WorkZone Configuration Management 2020.2

No changes in this release.

WorkZone Configuration Management 2020.1

No changes in this release.

WorkZone Configuration Management 2020.0

All Use Log functionality has been moved fromWorkZone Configuration Management to

WorkZone Configurator.

For more information, see The Use Log

USELOGADM and USERADM access code changes

The USERADM access code is now required to access, search and view the Use Log module

and the USELOGADM access code is required to start and stop the Use Log. This change

affects all methods of accessing the Use Log (either through WorkZone Configurator or the

ODATA interface.

WorkZone Content Server 2019.3
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USELOGADM and USERADM access code changes

The USERADM access code is required to see the Use Log menu in WorkZone

Configuration Management. Both the USERADM and the USELOGADM access code are

required for a user to access, search and view the Use Log module as well as start and

stop the Use Log.

The USELOGADM access code also grants access to the Use Log through the ODATA

interface.

WorkZone Configuration Management 2019.2

No changes in this release.

WorkZone Configuration Management 2019.1

No changes in this release.

WorkZone Configuration Management 2019.0

No changes in this release.

WorkZone Configuration Management 2018.2

No changes in this release.

WorkZone Configuration Management 2018.1

No changes in this release.

WorkZone Configuration Management 2018.0

l Topics that describe general WorkZone Process settings and settings that

apply to the SmartPost process have been revised. Dispatcher settings that

were previously part of the Process settings have been split in to specific

10



Online Help

dispatcher types (e-Boks, Straalfors, and local print) and moved to a new

Dispatchermodule. See The Process Dispatchers Module.

l The Lost and Foundmodule has been removed from the Diagnostics module

and replaced with new Dashboard lists (Hidden cases,Hidden documents and

Hidden contacts) in the WorkZone Client and a new Hidden Elements (da.

Skjulte Elementer)menu in the Captia Web Client. The new lists and menu

enable a user to find hidden WorkZone cases, documents and contacts. Only

users with the '*' System Access code can see hidden cases, documents or

contacts. A new WorkZone LOSTANDFOUND system access code has been

introduced which enables users to access to the Hidden Elements (da. Skjulte

Elementer)menu in the Captia Web Client.

WorkZone Configuration Management 2017

Operation module

l The Document Formats module has been removed and will be replaced by a new

Documents Formats module in the new WorkZone Configuration Management.

Classification Scheme module

l It is now possible to select@Unit in the Responsible OU and Executing OU

fields, which applies the unit of the current user who creates cases in the specific

case class. Likewise, you can now select@Me in the Case Handler field to apply

the current user who creates the case in the specific case class as case handler.

See Classification scheme meta data.

l @Unit is now applied by default to the Responsible OU field on the SJ-TEMP

class.

11
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Basic Data module

l You can now create corporate access codes from this module, which you can

then apply to file classes or contacts, see Create Corporate Access Codes.

WorkZone Configuration Management 2016 R2

l The format of the search criteria that is shown in the Search XML column in

the use log has been simplified, see .

WorkZone Configuration Management 2016

l Improvements to the Use Log module

l Two new sections have been added to the Use Log module. Info, which

displays information about the use log, see . Transfer job status, which

shows the status of the job that transfers the current use logs to the

monthly use log, see .

l The use log has been extended to show when users create, update, or

search for documents. This is indicated by I (insert) , U (update), or S

(search) in the Action column and #document in the Register column of

the log. See .

l The setup and maintenance of use log tables have been changed to

increase performance. See .

l A new system owned class SJ-AGENDA which is used by WorkZone Meeting has

been added. See Mandatory system owned classes.

WorkZone Configuration Management 2014 R2

No changes in this release.

WorkZone Configuration Management 2014
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l The Online Help for WorkZone Configuration Management is now available online

onWorkZone Documentation web site. You can also access it directly from

WorkZone Configuration Management.

l It is now possible to assign universal access codes to users from the Users

module, see Users meta data.

l A new section on parallel case creation has been added to the About case number

formats topic.

13
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3. Getting Started
WorkZone Configuration Management is a configuration tool that system administrators

use to configure and maintain basic data that makes up the foundation for working with

WorkZone Content Server and the various WorkZone clients.

WorkZone Configuration Management consists of several modules. Each module gives

access to a specific part of the basic data or configuration options.

Who is allowed to do what ?

To gain access to a specific module, you need adequate authorization, which means

that your user profile must contain the system access code corresponding to the access

code of the modules. See Access codes.

Configuring Configuration Management

You can configure WorkZone Configuration Management to handle either a single

language or several languages. See Language mode.

Modules in WorkZone Configuration Management

The table below displays the names of the modules and the data types, which are

maintained in them.

Basic data

Module Data Type

Countries and
postcodes

Countries and post codes

Custom label Labels

Custom domain Domains and their values

Filing periods Preservation and disposal codes

Contact Contact types
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Module Data Type

Stopwords Words to be disregarded in searches
The Terms
Module

Tool for the KMD technicians only

Categories

Module Data Type

Classification Scheme The classification scheme

Facet-based classification scheme Facets

Dictionary The dictionary containing keywords

Subnumbers Subnumbers

Security

Module Data Type

Register Security Security configuration for registers and tables

Diagnostic

Module Data Type

Diagnostic Module Read about:

l Trace Output

l Enable

sjDebug

Output

Operation

Module Data Type

Owner Owner specific information and configuration

Users Users

Preference Profiles Profiles

Restricting
Profiles

Profiles

Record Access Default configuration of record access

External Sources Configuration of external integrations (third party programs or services)

Service channels Configuration of data transfers (import of data from third parties or
services)
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Options

Settings Configuration of

Language Current language and language mode

Gridviews Default displayed items

Warnings Extend of warnings and the level of sensitivity

Custom Label Show all or only active items

Custom Domain Show all or only active items

16
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4. Prerequisites
This section describes the prerequisites for working with WorkZone Configuration

Management.

4.1 Prerequisites overview 17

4.2 Installation 17

4.3 Access codes 18

4.4 Profile 20

4.5 Language mode 20

4.1 Prerequisites overview

To work in WorkZone Configuration Management, the following conditions must be in

place:

l WorkZone Configuration Management must be installed , see Installation.

l You must have the necessary authorization to open the WorkZone Configuration

Management modules. This authorization consists of a set of system access

codes assigned to you in Active Directory, see Access codes.

l You must be set up to work in Captia Web Client without the limitations of a

profile, see Profile.

l You can choose to work in eithermulti or single language mode, see Language

mode.

4.2 Installation

After installing WorkZone Configuration Management on the server, you need to install the

new version locally on your PC. When you open WorkZone Configuration Management, you

are prompted to install the new version of WorkZone Configuration Management on your

PC. The program file is called Scanjour.Sysadm.exe.
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For more information, see Installation Guide for WorkZone Configuration Management.

4.3 Access codes

WorkZone Configuration Management contains a number of modules. To gain access to

a specific module (and/or sub functions), your user profile must contain the

corresponding access codes.

Allocation and management of access codes is done through Active Directory. Below is

a list of the specific access codes:

Basic Data Access code

Countries and Postcodes DATAADM

Custom Label DATAADM

Custom Domain DATAADM

Filing Period DATAADM

Contact DATAADM

Stopwords DATAADM

Terms TERMSADM

Categories Access code

Classification Scheme DATAADM

Facet DATAADM

Dictionary DATAADM

Subnumbers DATAADM

Security Access code

Register Security DATAADM

18

https://help.workzone.kmd.dk/2021_1/en-us/Content/WZ_InstallGuide/Install/CS_Config_Management/Install_Configuration_Management.htm


Online Help

Diagnostics Access code

Process Log PROCESSADM

Process State PROCESSADM

Trace Output DIAGADM

Enable sjDebug Output No access code is needed.

Operation Access code

Owner USERADM

Users USERADM

Restricting Profiles PROFILADM

Preference Profiles PROFILADM

Processes PROCESSADM

Service Workflows PROCESSADM

Process Settings PROCESSADM

Process Dispatcher PROCESSADM

e-Boks Material PROCESSADM

Remote Print Types PROCESSADM

Dispatch Types PROCESSADM

Record Access PROFILADM

External Sources DATAADM

Service Channels DATAADM

Options Access code

Language DATAADM

Gridviews DATAADM

Warnings DATAADM

Custom Label DATAADM

Custom Domain DATAADM
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4.4 Profile

An important precondition for working in WorkZone Configuration Management is that

your administration user has no profile limitations. Working on the basis of a profile may

mean that you only see a limited part of the data contained in some of the modules.

The purpose of the profiles is that you only see the data that you actually use working in

Captia Web Client. This, however, is not an efficient way of working in WorkZone

Configuration Management.

change your profile

You can find your profile in section 1 in Captia Web Client by selecting Functions >

Select profile. Section 1 is always visible on the Front page and your can change

your profile instantly.

Change your profile in Captia Web Client

1. Open Captia Web Client.

2. In section 1, click Functions > Select profile. A dialog box opens with a list

of profiles.

3. Click the profile named Standard No profile limitation. The dialog box

closes. You have chosen to work without the restrictions of a profile.

For more information on profiles, see Preference Profiles.

4.5 Language mode

You can choose to employ eithermulti language mode or single language mode in

your installation. The choice depends on how many language groups (that is English

speaking and/or Danish speaking employees) your organization needs to

accommodate.
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Single language mode

If your organization is multinational, you can either choose single language mode, for

example English as the only language, or choose multi language mode, for example

Danish as the default language but each employee has the option to switch to another

language in the clients (WorkZone Client or Captia Web Client).

Multi language mode

Inmulti language mode, the user interface will reflect the selected language and, for

example, labels, drop-down lists, and classification scheme will be displayed in that

language.

change the language mode

You can switch betweenmulti language mode or single language mode. See Select

user interface language.

change current language in WorkZone Configuration

Management

You can set the default language of WorkZone Configuration Management's user interface.

See Select user interface language.

change the default language of the Clients

Here you decide which language should be the default language (i.e. group language) of

WorkZone Client and Captia Web Client.

Note: If the language mode is set tomulti language mode, the user is able to

override the default language by selecting another language. See Configure group

Language.
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See also Configure date pattern.
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5. Important notes on usage
Before you begin working with WorkZone Configuration Management, it is important to

note the following

Not all information can be deleted

All information cannot be deleted!. If it is possible to delete information, the module

contains a Delete button. However, some types of information may only be terminated,

for example, an end date that will become inactive in the client user interface.

Example of deletion, see Delete a country.

Example of termination, see Terminate domain type.

Example of deletion and termination, see Delete/terminate a label.

Some changes only take effect after a service has been reset

Some changes only take effect after a service has been reset.

Example, see Using custom domain/label.

Example, see About register security.

Example, see Configure warnings.

The resetting may be a scheduled task that is performed at regular intervals, however it

can be done manually.

Logon to another database

WorkZone Configuration Management logs on to one specific database by default. When

you install WorkZone Configuration Management, the default database of the URL from

which you initiated the installation is shown. The default database is automatically opened

when you start. However, you can log on to another database than the default database.
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Note: Be aware that the Logon dialog box is sensitive to whether the site is http or

https.

Log on to another database

1. Click Database > Logon.

2. Enter the path of the database in the Database location field. Enter path:

<https://><host>

Note: You only need to enter <https://> if it is https. Http is standard

and can be omitted.

3. Click OK. The new default database is opened.

Tip: If you want to log on to another database but the default database

from the beginning, you can press the Esc key right after clicking

WorkZone Configuration Management in the Windows Start menu, which

opens the Logon dialog box.
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6. Working with the user interface
This section describes how to use WorkZone Configuration Management.

6.1 About the user interface 25

6.2 Shortcut keys 28

6.3 About cells and fields 29

6.4 Functions 33

6.1 About the user interface

The WorkZone Configuration Management user interface consists the following parts:

Interface Description

Menu bar Use the menu bar to find the module you want to work with.

Toolbar The toolbar contains buttons for different functionality, for example, Delete Row and

Text Cell Editor.

Display

panel

When you log on to WorkZone Configuration Management, the window is empty.

When you open a module from the menu bar, the panels of the module are displayed,

for example Categories > Dictionary.

Status

bar

The status bar displays messages, for example server name, the data, and so on.

Menu bar

The menu bar contains the following general items:

Menu item Description
File For example, import and export data.
Edit For example, copy and paste functions.
Database Log on to a database (change database), refresh, and save.

The menu items below gives access to the different modules of the program:
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Menu item Description
Basic data For example, Countries and Postcodes, Custom Label and Custom Domain.
Categories Modules containing data for classification cases and documents according to the

subject they are covering.
Security The Use log and the Table security modules.
Diagnostics For example tools for diagnosing errors.
Operation Tools for general configuration of Captia Web Client.
Options Tools for configuring WorkZone Configuration Management.

In the following, when directions are given in procedures, actions in the Functions

menu are referred to in the following way:

The Function bar is the topmost menu bar. It contains the following items:

l Click Basic Data > Stopwords (refers to the Function bar’s entry to the

module Basic Data where you are prompted to activate the submenu entry for

the Stopwords function)

l Click Database > Save (refers to the Function menu’s entry to the function

Database where you are prompted to activate the submenu entry Save – it

saves your recent action in you current module in the database).Toolbar

The toolbar contains the following buttons:

Refresh - Ctrl+R - reloads the data displayed in the panel.

Save - Ctrl+S - saves data in the database.

Export to Excel - exports data to Excel.

Cut - Ctrl+X - cuts out selected data.

Copy - Ctrl+C - copies selected data.

Paste - Ctrl+V - pastes selected data into the current position.

Delete Row - Ctrl+D - removes the current row.

Find - Ctrl+F - opens the Find window, where you can search based on the criteria entered.

Text Cell Editor - Ctrl+T - opens an Edit window. This is useful when a cell contains large

amounts of data.

Online help for WorkZone Configuration Management.
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The display panel is the central part of WorkZone Configuration Management. It is

displayed when you open WorkZone Configuration Management. From the display panel,

you can open the modules from the menubar. One or more panels display the data

registered in the modules. The design of the panels depends on the type of data displayed.

Hierarchy

panel

Data is shown in a hierarchy. Left of each main heading is a button with a plus,

indicating that the branch can be expanded.

As an example, panel 1 in the module Classification Scheme is designed as a

hierarchy.

Spreadsheet

panel

The most common panel is the spreadsheet. It very much looks and feels like a

spreadsheet.

For example, the Dictionary module is one large spreadsheet.

Detail panel The detail pane contains a number of data fields.

For example, the Owner Setting tab in the Owner module is a detail panel.

Tab panel The tab panel might be a collection of spreadsheets. Each spreadsheet on its

own tab. When you click a tab, the spreadsheet is displayed.

For example, panel 2 in the module Preference Profiles is a tab panel. Data is

shown as a hierarchy on each tab.
Status bar

<Message> <Server

name>

<Database

name>

Ins Del 5 1

The status bar is displayed at the bottom of the interface. It contains the following

information:

l <Message> - A message informing about the current activity is displayed, for

example "Saving data...".

l <Server name> - The name of the server.

l <Database name> - The name of the database.

l Ins Insert - It is possible to create items.

l Del Delete - It is possible to delete the items.
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l 5 - The first number tells you in which row the cursor is placed in a spreadsheet

panel.

l 1 - The second number tells you in which column the cursor is placed in a

spreadsheet panel.

6.2 Shortcut keys

Key(s) Description

Arrow Down Moves the cursor to the cell below.

Arrow Left Moves the cursor to the previous cell.

Arrow Right Moves the cursor to the next cell.

Arrow up Moves the cursor to the cell above.

Home Moves the cursor to the first cell in the current row.

End Moves the cursor to the last cell in the current row.

Page Down Moves the cursor one page down. The cursor remains in the same column.

Page Up Moves the cursor one page up. The cursor remains in the same column.

Tab Moves the cursor to the next cell.

Shift+Tab Moves the cursor to the previous cell.

Ctrl+Tab Moves focus from one window to the next.

Ctrl+Shift+Tab Moves focus from one window to the previous window.

Ctrl+Arrow Moves the cursor to the cell furthest away in the arrow's direction.

Ctrl+Home Moves the cursor to the first cell in the window.

Ctrl+End Moves the cursor to the cell furthest away in the window.

Ctrl+Page

Down/Up

Same as Page Down or Page Up.

Ctrl+C - Copies the highlighted area.

Ctrl+D - Deletes the row where the cursor is placed.
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Key(s) Description

Ctrl+F - Opens the window Find (search).

Ctrl+R - Restores the content of the module.

Ctrl+S - Saves your data.

Ctrl+T - Edit current cell in Text Cell Editor. Click in the cell you want to edit,

press F2 and then Ctrl+T.

Ctrl+V - Paste the copied item into the cell where the cursor is placed.

Ctrl+X - Cut the highlighted area.

F2 Edit current cell (opens cell for typing new data).

F4 Opens the drop-down box.

Alt+Arrow

Up/Down

Opens / closes the drop-down box.

Space Removes current value in a drop-down box field cell, and shows the drop-

down box button.

Enter Moves the cursor to the cell below.

ESC Undoes changes in a drop-down box field or a date field, and inserts the

original value.

Backspace Deletes the character in front of the cursor.

Delete Deletes one character after the cursor, the row or current item.

Ctrl+0 Clears current field.

6.3 About cells and fields

29



WorkZone Configuration Management 2021.1

6.3.1 Cells with date fields

When entering a date into a date field, you have two options. Either click the drop-down

list button and pick a date in the calendar or enter the date directly into the field.

Default dates are displayed as day- month- year, for example 24-12-2013.

Date fields - examples

Date fields are for example Start date and End date, which are found in the

Classification Scheme module, the Custom Label module, and the Custom Domain

module.

Navigating the field

The date field is divided into three parts: day, month and year - DD-MM-YYYY.

Use the Right arrow key g and the Left arrow key f to navigate the three parts of the

field.

enter the date directly into the field

1. Click the cell to select it.

2. Click the cell once more to activate it. The date field is ready for input with a

drop-down list button displayed to the right.

3. Enter two digits for day and press the right arrow key

4. Enter two digits for month and press the right arrow key

5. Enter four digits for year.

6. Place the cursor in another cell and click Database > Save.
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insert a date from the calendar

1. Click the cell to select it.

2. Click the cell once more to activate it.

3. Click drop-down list button and select a date from the calendar.

4. Click Database > Save.

Remove a date – empty the date field

1. Click the cell to select it.

2. Click the cell once more to activate it.

3. Press the Delete key and then press the Tab key. The date field is cleared and

the cursor moves to the next cell.

4. Click Database > Save.

6.3.2 Cells with drop-down lists

When entering a value into a drop-down box, you must select a value from the list. An

example is Sub-number type field in the Classification Scheme.

use a drop-down list

1. Click the cell select it.

2. Click the cell once more to activate the drop-down list.

3. Enter the first characters of the value you want to insert. Values containing the

characters entered are displayed. Select a value from the list.

- Or -
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Clik the drop-down list. Browse through the list using up and down arrow

keys, or type the first characters of the value you want to insert. Select the

relevant value.

4. Place the cursor in another cell (otherwise you cannot save) and click

Database > Save.

operate the drop-down list using shortcut keys

1. Press ALT+ARROW DOWN to open the drop-down box.

2. Enter the first characters of a value. A drop-down list is opened on top of the

first one. It displays the values containing the characters entered.

3. Use the ARROW DOWN to select a value and either use the TAB key to

insert the value in the cell (the cursor jumps to the next cell.) or use the

RETURN key to empty the field (the cursor stays in the cell).

6.3.3 Edit a cell

Some cells contain large quantities of text. The Text Cell Editor allows you to have

text displayed in an editor. Here you can make the necessary changes and save the

text in the original cell.

edit a cell

1. Click in the cell you want to edit.

2. Click once more to activate it.

3. Click the Text Cell Editor button in the toolbar. The contents of the cell is

displayed in an editing window.

4. Click OK when you have finished editing. The window is closed and the

contents of the cell has been updated - indicated by the pencil icon
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displayed in the left most cell.

5. Click Database > Save to save the changes.

6.4 Functions

6.4.1 Resize columns and rows

You can adjust the width of the columns and the height of the rows by pulling the divider
to resize column with or the divider to resize row height.

You can also use the context menu if, for example, there is not space enough to pull the

column wider. Some modules have so many columns in the panel that it is impossible to

pull for more space.

use the context menu

1. Right click the header of a column and click Increase Column Width or

Decrease Column Width

2. Click Increase Column Width to increase the column width.

3. Use the scroll bar below to view the column.

6.4.2 Sorting

You can sort the contents of the panels. Click the header of the column you want to use for

sorting the list. The list is automatically sorted.

Primary or Secondary Sorting

You can sort up to three columns. Each time you click on a column header, it becomes the

primary sorting criteria, while a previously sorted column becomes the secondary sorting

criteria.
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6.4.3 Find

Use Find when you need to search for a particular item, for example post code or a

user.

You must open the module, which you want to search within, before you click Find.

Find

Example: You want to find the user "Trine Troelssen" in the Usermodule.

1. Click Operation > Users.

2. Select the first cell of the relevant column.

3. Click .

4. In the Find what field, enter your search criteria, in this example troels.

5. Select where to search in the Look in field is by default set to All columns.

To narrow down the search to one particular column, click the drop-down list

and select the specific column from the list.

6. Select the check boxes under Find options.

7. The first item found is highlighted.

Fields in the Find window

Find what Enter the search criteria here. Click the drop-down list to view the last 10

entries.

Look in Select the scope of the search

l All columns - this is the default setting.

l A specific column. Click the drop-down list to select a particular

column.

Find

options

In this section there are three check boxes:

l Match case - executes a case sensitive search.
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l Match whole column - matches the search criteria exactly - except

for case.

l Search up - searches in ascending order - the default value is

descending order.

6.4.4 Gridview

The purpose of the Gridview is to display large quantities of rows of items faster. With

Gridview the contents of a list is displayed in batches, in stead of one long list.

For example, there are approximately 1300 Danish post codes. With Gridview it is

possible to have them loaded and displayed in batches of, for example, 200.

A search in the Use Log as another example, easily retrieves a large amount of data. It

may take a while to load all data into the display panel. To avoid long response times, you

can use Gridview. When you have looked at one batch of data, you can navigate through

the remaining batches using the navigation buttons, for example Move next.

operate the Gridview

The default number of records in the gridview is 2000. If, for example, you are viewing a

list of Danish post codes, it will (if it exceeds 2000) show a status bar at the bottom of the

list. This bar shows the result in batches of 2000 post codes at a time, for example, 2001 -

4000 of 5058.

Now, you have to click the Move next button to load the next batch of 2000. You can

always navigate the total series of batches by use of the buttons shown below.

Move first - Moves to the first batch of data.

Move previous - Moves to the previous batch of data.

Move next - Moves to the next batch of data.

Move last- Moves to the last batch of data.
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Click Options > Gridviews to set the amount of data per batch. By default, the

gridview is set to display 2000 items. For better performance, you can adjust the

number to, for example, 200 items.

The grid view is by default set to 2000. In the Number of records in gridview field in

the GridViewOption dialog box, the default value is entered as 2000__ , that is two

thousand succeeded by two underscore characters, in all 6 characters.

Important: The field must always contain 6 characters. If you, for example, want to

set the number to 350, you must enter it as 350___ , that is three hundred and fifty

followed by three underscore characters.

1. Click Options > Gridviews.

2. In the Number of records in gridview field, enter a new value, for

example 350, it must be entered as 350___.

3. Clik OK.
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7.1 The Countries and Postcodes Modules

In the Countries and Postcodes module you can manage countries and cities with post

codes.

In order to use a country or postcode in the WorkZone Client or Captia Web Client, you

must first enter it in the Countries and Postcodes module. Country and postcode are

used for example on contact detail pages.

Prerequisite: To access the Countries and Postcodes module, you need the access

code DATAADM.

Click Basic Data > Countries and Postcodes to open the module.

7.1.1 Manage countries

About countries

Before WorkZone users can use countries and postcodes, for example when creating new

contacts, you must create them in the Countries and Post codes module.

Click Basic Data > Countries and Postcodes to display the countries.
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Create a country

You can create a new country in the Countries module.

Prerequisite: You must create the country before you can create postcodes

associated with a country.

Create a new country

1. Click Basic Data > Countries and Postcodes.

2. Click in the empty bottom cell of the column Country.

3. Click the cell once more to be able to enter a country code.

4. Enter the country code in the cell, for instance,N for Norway.

5. Click the next cell - in the Name column.

Enter the name of the country.

6. Click the cell once more to be able to enter a country code.

7. Click Database > Save.

8. The panel Country names for <country> is displayed bottom left.

The name of the country is inserted in all rows.

9. Click the names you want to edit one by one, and make your changes.

Place the cursor in another cell and click Database > Save.
Edit a country

You can edit all information concerning a country except the cell Country. The content

of this cell is the unique ID of the country. As soon as the newly created country has

been saved, the cell is locked for editing.

1. Click Basic Data > Countries and Postcodes.

2. Click the cell of the country you want to edit.
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3. Make the necessary changes.

4. Place the cursor in another cell and click Database > Save.

Delete a country

If you have created and saved a country with a wrong code, you have to delete the

country. You cannot edit the cell in the column Country once you have saved the country.

Important: You cannot delete a country if it has been used or if you have created

postcodes belonging to that country. If this is the case, then you must delete the post

codes one by one before deleting the country.

1. Click Basic Data > Countries and Postcodes.

2. Click the cell in the column to the left of the country you want to delete.

3. Click once more in the cell to select the row of the country to be deleted.

4. Click to delete the country.

5. Click Database > Save.

Country meta data

The data you can register describing a country is shown below.

Data Description

Country This cell contains a code, for instance, the international vehicle registration code.

E.g. NO for Norway.

The contents of this cell is the unique ID of the country. As soon as the data has been

saved, the field is locked for editing.

Name The name of the country, for example, Canada.

In the bottom left panel you can maintain the culture specific names of the country.

Example:
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Data Description

da-DK - Denmark

fr-CA - Canada

To create new entries, follow the general instructions inWorking with the user interface.

See also Post codes metadata.

Metadata

The data you can register describing a country is shown below.

Data Description

Country This cell contains a code, for instance, the international vehicle registration code.

E.g. NO for Norway.

The contents of this cell is the unique ID of the country. As soon as the data has

been saved, the field is locked for editing.

Name The name of the country,for example, Norway.

In the bottom left panel you can maintain the culture specific names of the

country.

Example:

da-DK - Norge

en-GB - Norway

To create new entries, follow the general directions of use in Use - contents.

See also Post codes - metadata.

7.1.2 Manage postcodes

About postcodes

To create a postcode, the country of the postcode must exist. By default a large number

of countries already exists when WorkZone Configuration Management is installed.
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In the Countries and Postcodes module, you can create, edit and delete postcodes of

countries.

1. Click Basic Data > Countries and Postcodes.

2. Click on the field to the left of the country code of that country to see the

postcodes of a specific country. The postcodes are displayed in a separate

panel to the right.

Create a postcode

Prerequisite: To create a post code, the country to which the code belongs must exist

in the module.

Example: You want to create the post code 2150, Nordhavn in Denmark.

1. Click Basic Data > Countries and Postcodes.

2. Select the country to which the post code belongs in the list of countries

(Denmark).

3. Click the cell in the column to the left of the country code.

A panel displaying the postcodes of that country is displayed to the right.

4. Place the cursor in the empty cell of the Post code column's bottom row.

5. Click the cell once more to enter the postcode, for example 2150.

6. Click the next cell of column District.

7. Enter the name of the district for e.g. Nordhavn.

8. Click Database > Save.

Edit a postcode

You can edit all information concerning a postcode except the cell Postcode. The content

of this cell is the unique ID of the postcode. As soon as the newly created post code has
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been saved, the cell is locked for editing.

1. Click Basic Data > Countries and Postcodes.

2. Select the country to which the postcode belongs in the list of countries.

3. Click the cell in the column to the left of the country code.

A panel displaying the post codes of that country is displayed to the right.

4. Click the cell of the postcode you want to edit and make your changes.

5. Place the cursor in another cell and click Database > Save.

6.

Delete a postcode

You can delete a postcode as long as it has not been used in Captia Web Client. If it has

been used with a contact or address in Captia Web Client its entries it cannot be deleted

unless all its instances are deleted or changed in the Captia Web Client user interface.

1. Click Basic Data > Countries and Postcodes.

2. Select the country to which the post code belongs in the list of countries.

3. Click the cell in the column to the left of the country code.

A panel displaying the post codes of that country is displayed to the right.

4. Click the cell in the column to the left of the postcode.

The row is highlighted.

5. Click to delete the postcode.

6. Click Database > Save.

Postcode meta data

The data you can register describing a postcode is shown below.
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Data Description

Postcode The contents of this cell is the unique ID of the postcodes, for

instance, 2150 (Nordhavn in Denmark). As soon as you have saved

the postcode, this cell is locked for editing.

District The name of the post district, for instance Nordhavn (postcode

2150).

To create new entries, see Working with the user interface.

Metadata

The data you can register describing a postcode is shown below.

Data Description

Postcode The contents of this cell is the unique ID of the postcodes, for instance, 7884 (Sørli

in Norway). As soon as you have saved the postcode, this cell is locked for editing.

District The name of the post district, for instance Sørli (postcode 7884).

To create new entries, follow the general directions of use - see Use - contents.

Related topic - see Countries - metadata.

7.2 The Custom label Module

The Custom labelmodule manages both system defined and custom defined Label

Types and Labels. A Label type contains labels. A label either defines the content of a

data field or labels references, that is roles, in WorkZone Client and Captia Web Client.

Prerequisite: To access the Custom labelmodule, you need the access code

DATAADM.

Click Basic Data > Custom label to open the module.

7.2.1 About custom labels

In the Custom labelmodule you can maintain custom labels. A label is the name of a field

that describes the information that field contains.
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WorkZone Client and Captia Web Client contain two different types of labels:

l Fixed labels

The pages and dialog boxes of WorkZone Client and Captia Web Client contain a

number of fixed labels. They are part of the default configuration of and cannot

be changed by the users. An example of a label is the text Case handler on the

case details page.

l Custom labels

These labels are user defined. They are available for registering information, for

example, on the case details page in the bottom section of the page, click

More... > Information.

The purpose of the custom label

The purpose of custom labels is that you can name labels yourself. For example, fields

for registering degrees of longitude and latitude are not default in the clients but can be

added by means of custom labels. Subsequently the WorkZone Client and Captia Web

Client user can register this type of information and search for cases on the basis of it.

Where are custom labels used

Custom labels are used in WorkZone Client and Captia Web Client details and search

pages for cases, documents, and contacts.

7.2.2 About custom label types

Custom labels are grouped according to label types depending on register and data

type. A label type is identified by a code, that is its ID. The code consists of two

characters defining the register they belong to and their function:

l The first character of the code defines which register the label belongs to:
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l A = Documents

l N= Contacts

l S= Cases

l The second character defines the data type to be registered with the custom

label:

l A = Documents (only applied in AA)

l D = Dates

l H = References

l O= Information

l P = Contacts

As an example the label type SH consequently denotes the reference Case references -

references between cases.

Label types for which you can create your own custom labels

Below are the label types you can use for creating your own custom labels:

Label

type

Description Name in

WorkZone

Client/Captia

Web Client

AA References between one document and another. The label characterizes

the role of the actual reference.

One custom label could, for example, be Copy and the reverse label,

Original document.

Document

references

AD Custom labels for special document dates. A custom label could, for

example, be Aground. In the data field you must enter the date when the

ship in question ran aground.

Document

dates

AH References from the current document to cases of relevance for the

document at hand.

Case

references
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Label

type

Description Name in

WorkZone

Client/Captia

Web Client

The label, for instance, defines the role of referenced case, such as Cross

reference.

AO Custom labels for document information not included in the default meta

data fields such as Agenda.

Information

AP Custom labels for contacts reference by documents defining the role of the

contact such as Sender.

Parties

ND Custom labels for special dates to be registered on contacts such as Hired

from.

Dates

NH Custom labels for referencing contact case relations such as Member. Case

references

NO Custom labels for contact information not included in the default

metadata fields such as Marital status.

Information

NP Custom labels for referencing contacts in relation to another contact.

The contacts attached to another contact in this way are automatically

committee members. And the contact to which they are attached is the

committee. The label defines the role of the members, for example,

Chairman, Secretary, Member, etc.

Contact

references

SD Custom labels for special dates registered on cases. Case dates

SH Custom labels for cases attached to another case for reference.

The label is used for describing the role played by the case referred to,

such as Associated case.

Case

references

SO Custom labels for case information not included in the default meta data

fields.

These custom labels could, for instance, be user for non default

information like Degree of longitude and Degree of latitude.

Information

SP Custom labels for contacts reference by cases defining the role of the

contact such as Party.

Parties
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For an in depth description of the functions of the data fields Dates, References,

Information and Contacts, see Types and data fields.

7.2.3 About custom label types and data fields

Custom labels are grouped according to the type of data to be registered with the label in

question:

l D = Dates

l H = References

l O= Information

l P = Contacts

In WorkZone Client and Captia Web Client you can register data in the data fields that

belongs to the custom labels. In the table below the controls of the different type of labels

are described.

Custom label Properties of the data fields

Dates The field only accepts a correct date.

Dates in WorkZone Client and Captia Web Client can be entered in different ways:

l By selecting a date in the calendar.

l As an algorithm, for example +4w, which automatically converts into the

date 4 weeks ahead.

l Directly as a date, which consists of at least 6 digits - ddmmyy, for

example, 241212 displayed as 24-12-2012.

References To register references, you have to select the entities in a dialog box. When you

start registering an entity in a data field, belonging to this type of label, a dialog

box is opened. Here you must search out one or more entities to be referred to.

Only entities already existing in the database can be referred to.

Information The field may have one of two modes that determines the use of the field in

WorkZone Client or Captia Web Client:

l A free text field where the user can enter any text or number into the
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Custom label Properties of the data fields

text box.

l A drop-down box with a controlled choice of possible entries.

The values listed in the drop-down box depends on the selected Routine, (i.e.

dependency) for the custom label.

Contacts

(in Captia

Web Client

called

Parties)

There is no actual input field associated with custom labels of this type. These

custom labels describe the connection between the contact and the entity to which

it is attached.

When you, for example, link a contact to a case, you can specify the role of the

contact in relation to the case. The custom label, used to characterize this relation,

could for example be Complainant, Accused, and so on.

7.2.4 Custom label meta data

Table below displays the meta data you can register concerning Label types and

Labels.

Column Description

Panel:

All Label

type

The first left panel contains all custom label types.

Label

type

The Label type is composed of two letters, for example, SO. This label type

contains labels for supplementary case information.

See also Custom label types.

Label

text

The Label Text contains a description of the subject of the label type.

Panel:

Label:

<label

type>

The upper right panel contains the Labels of the Label type.
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Column Description

Label In this cell you must enter the label which is displayed for the users in the

WorkZone Client or Captia Web Client user interface.

Reverse

label

code

This cell is only used with system defined label types AH and SH and the routine

Cross reference. It is used for cross references, where the source and the target

reference need different tags, such as Copy vs.Original or Parent

As an example, the users can move an archived document from one case to

another. Cross reference information is automatically inserted into both source

and target. In this way the document can be traced back to its original location and

to its new location.

System In this cell, you can enter the name of the owner of the label - if necessary.

Routine In this cell, you can enter the name of the routine that implements dependency

between the label's data field and the validating custom domain.

By default, you can attach validation routines to three types of labels: AO, i.e.,

document information, NO, i.e., contact information and SO, i.e., case

information. Otherwise it must be a customized label type, see Create custom

label type.

The system offers a number of different ways to configure the data field attached

to the labels. For instance, you could have:

l Data fields without validation - a free text box (no Routine is selected).

l Data fields that are validated against a user defined domain in the

Custom Domainmodule (Routine is selected).

l Data fields that are validated against fixed (i.e. mandatory system)

domains in the Custom Domainmodule, such as employees, contact

types, countries, etc.

Text Enter an elaborated description of the label.

Start

date

The date defines the day of initiation.

End date The date defines the day of termination.

Localized What you enter here, is what the users of Captia Web Client see in the user
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Column Description

label interface. It is important that the label is short and precise.

If you system is running inmulti- language mode you must also enter the

culture specific localized labels in the lower right panel.

For information on language mode, see Language mode.

Panel:

Label

value:

<label>

The lower right panel contains the Label values of the selected Label in the

upper right panel - if multi-language mode is selected, the related cultures (i.e.

languages) are shown.

Localized

label

What you enter here, is what the users of Captia Web Client see in the user

interface, depending on the culture they have selected. It is important that the

label is short and precise.

Text Here you can enter an elaborated description of the label.

Culture The culture code of the current row.

Source The current language code (i.e. default language).

7.2.5 Create custom label types

It is possible to create new label types in case of customizations. A label type is a

domain. Here you can create labels for customized fields displayed in WorkZone Client

or Captia Web Client. This could, for example, be fields for dates with labels supporting

the work process of the organization.

create a new Label type

1. Click Basic Data > Custom Label.

2. Click in the cell to the left of label type TY, Label types.

3. In the upper right panel, click in the empty cell in the Label column.

4. Enter a short and precise name for the label type - max. 11 characters. This

name is the ID of the new label type.
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5. Click the column Text in the in the next cell. Click in the cell once more to enter

the specific descriptions of the label - for example, the same as the Label.

6. In Localized Label cell enter the user interface name.

7. Whether the Routine cell is filled in, depends on the use of the Label type.

8. You should enter an initiation date in the column Start date.

9. Place the cursor in another cell and click Database > Save.

Note: If your system is running in multi-language mode, you must also add the culture

specific texts in the lower right panel.

See also

Configure the label type, see Routine.

Create custom label with validation, see Create custom label with validation.

Create custom label without validation, see Create custom label.

7.2.6 Create custom labels

You can create new labels for existing domains, i.e., label types.

Example

When you register cases in Captia Web Client concerning grounded ships, you must

register some supplementary information. You must register the date the ship was

grounded and the date it was brought afloat again.

These dates are not default information in the case details page in WorkZone Client and

Captia Web Client. Therefore, you must create two new custom labels, for example,

Grounded and Afloat. They must be created in the label type SD domain, i.e., case

dates and then the labels and their data fields will be available in WorkZone Client or

Captia Web Client on the case details page. In Captia Web Client,Click More > Dates.
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Create labels

1. Click Basic Data > Custom Label.

2. Click the cell to the left of the Label type in which you want to create labels,

in this example SD. The contents of the Label type is displayed in the upper

right panel.

3. Click the empty cell in the bottom of the Label column.

4. Click once more and enter a short and precise name for the label - max. 11

characters. In this example Grounded. This is the ID of the new label.

Important: A custom label must not be prefixed with a number.

5. In the Text cell, enter the text defining its use, for example The date of

the grounding.

6. In Localized Label cell, enter the label used in the WorkZone Client or

Captia Web Client user interface.

7. Ignore Routine (unless it is called for due to a customization).

8. You should enter an initiation date in the column Start date.

9. Repeat the steps 3 through 8 until you have created all the necessary labels.

10. Click Database > Save.

Note: If your system is running under the multi language mode, you must also add

the culture specific localized labels and texts in the lower right panel.

7.2.7 Create custom label with validation

You can create labels which have either a specific control or no control at all. A control

governs what users in WorkZone Client and Captia Web Client can enter into the data

field belonging to a certain label. Controls can only be attached to labels of label types

AO,NO or SO, unless they have been created as part of a customization - see Create

custom label types.
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You can create labels with a drop-down box in the data field belonging to the label. The

values contained in the drop-down box belong to a domain in the custom domain module.

Both fixed (i.e. mandatory) domains, for example Case type, and user defined domains

can be attached to the label - the data field of the label.

Example

When you register cases in WorkZone Client and Captia Web Client concerning for

example grounded ships, you must register some supplementary information. You must

register the cause of the grounding. This is done by supplying the cause. You select the

cause from the list of predefined causes in the drop-down box.

The prerequisites for this are:

l You have created a domain for the values i.e. a domain type, see Create custom

domain type.

l You have created the values in this domain, see Create custom domain value.

This type of information is not default information in the case details page in WorkZone

Client and Captia Web Client. Therefore, you must create a new custom label, for example

Grounding. It must be created in the label type SO,  "Case information" domain. You

must attach a domain type to the data field of the label. This is done in the cell Routine.

Here you can select the domain type containing the values assigned to the different

causes for groundings.

Now the label and the data field with the specific control, will be available in WorkZone

Client and Captia Web Client as soon as the IIS Admin service has been reset (this

usually happens automatically once every 24hrs.) After the resetting, it will, on the

premiss of this example, be available on the case details page. The user must select the

relevant value from the drop-down box of the data field.
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Create a label with validation

1. Click Basic Data > Custom Label.

2. Click the cell to the left of the Label type in which you want to create labels,

for example SO. The contents of the Label type is displayed in the upper

right panel.

3. Click the empty cell in the bottom of the Label column.

4. Click once more and enter a short and precise name for the label - max. 11

characters.

In this example Grounding. This is the ID of the new label.

5. In the cell Text enter the text defining its use, for example Grounding

causes.

6. In cell Localized Label enter the label used in the WorkZone Client or

Captia Web Client user interface.

7. In the cell Routine select the custom domain that should control the drop-

down box of the label, for example Grounding causes.

8. You should enter an initiation date in the column Start date.

9. Click Database > Save.

After the IIS has been reset, the case handler would be able to process a

grounded ship and supplying the information regarding the cause.

Note: If your system is running in multi language mode, you must also add the

culture specific Localized Labels and texts in the lower right panel.

Validation controls for the data field - see Custom label meta data.

7.2.8 Edit Custom label

You can edit information about label types and custom labels. You can edit information

in all cells, except Label type and Label. The content of these cells is by default
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locked.

edit the Label Types

1. Click Basic Data > Custom Label.

2. Click in the cell to the left of label type TY, Label types.

3. In the upper right panel, click the left cell of the label you want to edit. The

bottom right panel now displays the culture specific names of the label.

4. You can edit the cells Localized Label and Text.

5. When you have made the necessary changes,

6. Place the cursor in another cell and click Database > Save.

edit labels

1. Click Basic Data> Custom Label.

2. Click to the left of the Label type in which you want to edit labels, for example

SO.

3. Click in the cell to the left of that label type.

4. In the upper right panel, you can edit all the cells that are not greyed out or

click in the lower right panel and edit Localized Label and Text cells.

5. Make your corrections.

6. Place the cursor in another cell and click Database Save

For information about individual cells, see Custom label - metadata.

7.2.9 Delete or terminate a custom label

There are two ways to discontinue a label - you can terminate it by applying an end date,

or you can delete it if there are no occurrences of it in WorkZone Client or Captia Web

Client.
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terminate a label

1. Click Basic Data > Custom label.

2. Select the Label type of which you want to terminate labels.

3. Click the column to the left of the code of that label type.

4. In the upper left panel, click End date of the label to be terminated. Click

the cell once more to activate it. Today's date is entered into the cell by

default.

5. You now have two options:

l To enter the date manually, edit each part of the date separately.

l Click the drop-down button of the cell to select a date from the calendar.

6. Place the cursor in another cell and click Database > Save.

Note: To terminate a value immediately, insert yesterday's date.

delete a label that has never been used

1. Click Basic Data > Custom label.

2. Select the Label type of which you want to delete labels.

3. Click the column to the left of the code of that label type.

4. Click to the left most cell of the row of the label you want to delete.

5. Click Edit > Delete Row.

6. Place the cursor in another cell, click Database > Save.
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7.3 The Custom domain Module

In the Custom domainmodule, you manage a collection of domain types. A domain type

is an individual register. Each of these registers contains a number of values that are

presented in the WorkZone Client or Captia Web Client interface in a drop-down box of the

field of the register in question, for example Case types.

You can use both system defined domain types and user defined domains types with both

fixed and variable contents.

Prerequisite: To access to the Custom domainmodule, you need the access code

DATAADM.

Click Basic Data > Custom domain to open the module.

7.3.1 About custom domain

About the Custom Domain module

The Custom domainmodule contains a collection of domain types. A domain type is an

individual register. Each of these registers contains a number of values.

These registers contain basic data that displays in drop-down lists to data fields, for

example, displayed on the details pages in WorkZone Client and Captia Web Client. When

you, for example, click the drop-down list of the Document type field, the values come

from domain type AT, Rec. type.

What does the custom domain module contain?

The Custom domainmodule contains a large number of basic data, for example,

document types, document groups, case types, and so on.

The Custom domainmodule contains 3 types of domain types:

l System defined domain types, which contain both system and user defined

values, for example, case types, document types, and so on.
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l System defined domain types owned by the system and managed by KMD.

l User defined domain types with user defined values.

The system defined domain types are mandatory and must exist in the Custom

Domainmodule prior to implementation. They contain values for data fields belonging

to the WorkZone Client and Captia Web Client details and search pages, and so on.

Some of the system defined domain types are system owned registers that supports

special features. Only KMD can edit these custom domains.

What does a custom domain contain?

A domain type is a domain (or register) that contains a number of values, which

consists of a code and a text. The text defines what the code means. As an example,

the text Embed. image defines the code EMBED in the domain type AT, Rec. type as

an embedded image.

System defined domain types with values managed by you, see User managed domain

types.

User defined domain types with values managed by you, see About user defined

domains.

Custom domain meta data

The data you can register in custom domains is show below.

Column Description

Panel:

All

Domain

Types

The All Domain Types panel contains all domain

types. All domain types are values in domain type TY,

Cust. dom. type, except the domain type itself.

When you have created a new domain type, you have

created a domain (a register). In this domain you can

create the number of values necessary.

Code The unique ID of the domain type

Domain The name of the Domain type - a short and precise
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Column Description

Type description of the domain type.

Custom label module

The Routine cell of the Custom label module contains

a drop-down box. The values of this drop-down box are

the names registered in this field.

If a value is selected here, the data field of the custom

label in question contains a drop-down box when

displayed in WorkZone Client and Captia Web Client.

The values displayed in this drop-down box come from

the custom domain represented by the "routine".

System The owner of the Domain type

If the owner is KMD, only KMD is allowed to edit the

domain type, for example, create values in the domain.

Panel:

Domain:

<Code>

(<Domain

type>)

The upper right panel with the header Domain:

<Code> (<Domain type>). The values of the

current domain type are displayed in this panel.

Code The unique ID of the value.

Text The name of the value.

System The owner of the value.

If the owner is KMD, only KMD is allowed to maintain

the value.

Start date If a date is entered into the cell, the value can be used

in WorkZone Client and Captia Web Client as of this

date.

End date If a date is entered into the cell, the value will as of this

date no longer be available in WorkZone Client and
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Column Description

Captia Web Client.

Panel:

The lower

right

panel

The panel is displayed when the program is working in

multi-language mode. Here the culture specific names

of the values of the domain type are displayed and

managed. The culture specific names of the current

value are maintained here.

Text The culture specific name of the value.

Culture The culture code of language to be used for the text.

Source The current language code (i.e. default language).

See also dependencies between Custom Domain, Custom Label and WorkZone

Client and Captia Web Client, see Using custom domain/label.

Single and multi-language mode, see Language mode.

Using custom domain/label

Custom domain and label dependency

It is possible to make data entries in the custom labelmodule dependant on data from

the custom domainmodule displayed in a drop-down lists.

The purpose of this feature is to allow tailor made labels and drop-down list values in

WorkZone Client and Captia Web Client. This enables you to implement the data set

and labels of your organization, and furthermore to control what data can be registered

from within a specific label.

implement a dependency

When you register cases in WorkZone Client or Captia Web Client concerning for

example grounded ships, you must register the cause of the grounding. In this example,

the organization has a predefined list of so called Grounding codes. Each code describes

the type of cause for the ship to run aground.
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The organization does not want the case handlers to individually define the causes, but

want them to use a predefined list of causes. Therefore, it is necessary to make the

predefined list the only option when registering the cause of the grounding, for example on

the case details page in WorkZone Client and Captia Web Client.

configure a label with a dependency on values from a custom

domain

Follow the process below to configure a label with mandatory data entries from a

predefined and controlled drop-down list.

1: Create domain

type
1. Open the Custom Domainmodule and create a new domain

type, in this example "GC, Grounding cause".

2. Select the domain type TY,Cust. dom. type.

3. In this domain, create a value with code GC and the text

Grounding cause.

4. Saved it to the database and it becomes an individual domain

type. Now it is displayed in the panel All Domain Types.

2: Create values

for the domain

type

1. In the Custom Domainmodule, select the domain type you

just created. The upper right panel is displayed with the

header "Domain: GC (Grounding cause)".

2. Create the necessary values for the domain type, for

example CO, Collision, NM, Navigational mistake, and

so on.

3: Create

custom label
1. Open the Custom Label module and create a label and then

dedicate a data field for registering the grounding cause.

2. In the All Label Types panel, select label type SO for case

information. The values, i.e. labels of this label type, are
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displayed in the upper right panel.

3. Enter the name of the label in the Label, Text and

Localized Label cells, in this example "Grounding".This is

the label which is going to be displayed in WorkZone Client

and Captia Web Client.

4: Create the

dependency

between the

custom domain

type and the

custom label

type

Now attach a dependency (i.e. routine) to the label.

The Routine cell displays a drop-down list. Here you must select the

domain type of the label, creating a controlled drop-down list.

In this example, you must selecte "Grounding cause".

Note: The IIS Admin service must be reset before the dependencies

take fully effect in the user interface.

5: Custom

domain and label

in Captia Web

Client

A ship running aground is to be registered in Captia Web Client. The

Captia Web Client user logs on and creates a new case registering the

grounding.

To register the cause of grounding, the user must select the cause and

supply it as case information in section 4:

1. Open the list "Information" using the menu item More... >

Information.

2. Open a new information entry by clicking Functions > Add

to list.

3. Open the drop-down list "Custom label for free case

information" and select the relevant label , in this example

"Grounding".

4. Open the drop-down list of the "Information" field and

select the relevant value - in this example CO, Collision.

5. Save the information.
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Resetting of the IIS Admin service

When dependencies have been created, the IIS Admin Service must to be reset before

your changes take effect and can be employed fully in the WorkZone Client and Captia

Web Client user interface.

7.3.2 User defined domains

About user defined domains

The purpose of user defined domains is that you can create a domain yourself and define

the contents of that domain. This content is accessible in a drop-down lists in WorkZone

Client and Captia Web Client.

To have the contents of the user defined domain displayed in a drop-down list, you must:

1. Create a label in the Custom labelmodule.

2. Attach your custom domain to the label as a "routine".

Example

As an example, you have a list of codes to be used in WorkZone Client or Captia Web

Client to specify types of reasons for ships running aground. When the users register a

code on a case, they must select the code from a predefined list.

In the example there is no list of codes beforehand and there is no dedicated field on the

case details page for the codes.

This is how to implement it:

1. Create the list as a domain type in the Custom domainmodule, see Create a

domain type.

2. Register all the codes in the new domain, see Create values in a custom domain.
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3. Create a label in the Custom labelmodule with a data field validated

against the registered codes - see Create label with validation.

For information on the dependency between Custom Label, Custom Domain and

WorkZone Client and Captia Web Client, see Using custom domain/label.

Create domain type

You can create a new domain. You create a domain by creating a domain type. In the

new domain you can create values.

Example

As an example, you must register ships grounded within 12 nautical miles from the

coast as cases in WorkZone Client or Captia Web Client. In connection with these

cases, you must register a code defining the reason why the ships ran aground. Your

organization has a list of codes describing the different types of conditions causing

groundings. You must create this list in the database, i.e., in the Custom domain

module.

Create a custom domain

1. Click Basic Data > Custom Domain.

2. Click in the cell to the left of domain type TY, Cust..

3. In the upper right panel, click the empty cell in the bottom of the Code

column.

4. Enter a unique identification code for the new domain type. Maximum 8

letters - in this example "GC".

5. Click the Text column in the next column.
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6. Click in the cell once more to enter the specific descriptions of the domain. In

this example Grounding cause in the Text cell.

7. Enter an initiation date in the Start date column .

8. Place the cursor in another cell and click Database > Save.

Note: If your system is running in multi-language mode, you must also add the culture

specific texts in the lower right panel.

When you have created a new domain, the next steps are:

l Create the values of the domain - see Create values.

l Create a label, for example, "Grounding" in the Custom Labelmodule - see

Create custom label with validation.

l Attach the custom domain GC, Grounding Cause to the label as a "routine". The

data field of the custom label will be validated according to the values of the

custom domain GC.

Now the users can register the proper codes describing the reasons for grounding.

Edit domain type

You can edit the following cells of an existing domain type:

l Start date

l End date

l Text

edit a domain type

1. Click Basic Data >Custom Domain.

2. Click in the column to the left of TY, Cust. dom. type. (All Domain Types are

shown in the upper right panel.)
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3. Click in the date cells of the domain type to be edited and in the lower right

panel, click to edit Text cells.

4. Edit the data of the cell.

5. Place the cursor in another cell and click Database > Save.

Terminate domain type

You can terminate domains which are no longer in use. When entering an End Date in a

domain, the following happens in WorkZone Client and Captia Web Client:

l Values no longer in use remain in place where they were originally used, for

instance values on cases. If you, for example, terminate the custom domain

GC, Grounding causes, the values of that domain remain where they were

registered in WorkZone Client or Captia Web Client.

l The values of the domain will no longer be available in the drop-down list of the

field to which they originally belonged. However, they will still be available in

search pages in the WorkZone Client and Captia Web Client user interfaces.

terminate a custom domain

1. Click Basic Data > Custom Domain.

2. Click the column to the left of the domain type, TY, Cust. dom. type.

3. Click the End date of the Domain Type you want to terminate.

4. Click the cell of End date once more to activate the drop-down list.

5. Click the date you want to insert as End Date.

6. Place the cursor in another cell and click Database > Save. You now have

terminated the domain type.

Note: To terminate a domain immediately, insert yesterday's date as the end date.

7.3.3 Fixed domains
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User managed domains

The table below displays a lists of some of the common predefined domain types. In these

domains you can create, edit and terminate your own values. Create the values preferred

by your organization, for instance, values for different types of documents or cases in AT,

Rec type, ST, Case type.

The values you create here are displayed in WorkZone Client and Captia Web Client. When

you, for example, open the drop-down list of the Case type field, the values displayed are

the ones you created in the Custom Domainmodule.

Domain type Code Description

Address type AD Values registered in the Address type domain could be:

l HA, Main address,

l FI, Branch address.

Use in Captia Web Client

These values are used for defining which address of a contact is the

primary address and which are the secondary addresses. The values

registered in the Address type domain are displayed in the drop-down

list named Type in the address details view - section 5 in the contact

details page.

Rec. group AG Values registered in the Record group domain could be:

l AFT, Agreement

l HM, Enquiry request

l HS, Response

l IN, Recommend.

Use in Captia Web Client

The values could, for instance, be used for grouping documents
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Domain type Code Description

according to contents. The values in the domain Rec. group are

displayed in a drop-down box in the field Document group, e.g. in the

document details page.

Rec. type AT Values registered in Record type domain could be:

l IL, Incoming letter

l IM, Incoming mail

l IF, Incoming fax

l TN, Telephone note

Use in Captia Web Client

The values are intended to show whether an item is an incoming or

outgoing document or mail, an internal document, etc. The values in

the domain Rec. type are displayed in a drop-down box in the field

Document type, for example on the document details page.

Remind. type ET Values registered in the domain Reminder type case could be:

l SU, Suspended

l RS, Restarted

l SH, Shelved

l UR, Urgent

Use in Captia Web Client

The values are used for characterizing the purpose of a case reminder.

The values in the domain Reminder type case are displayed in a drop-

down box in the field Reminder type e.g. in the case details page -

section 4 in the list named Reminders.

Reminder

type rec.

ETAKT Values registered in the domain Reminder type record are used for

characterizing the purpose of a document reminder. The values in the

domain Reminder type record are displayed in a drop-down box in
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Domain type Code Description

the field Reminder type, for example, in the document details page -

section 4 in the list named Document reminders.

Name group NG Values registered in the domain Name group are used for

characterizing and grouping Contacts. The values are displayed in a

drop-down box in the field Group, for example on the Contact details

page.

Location type PT Values registered in the Location type domain are used for defining

purpose and status of the current placement. The values are, for

instance, displayed in a drop-down box in the column named

Placement code in the list called Case locations in the Case

details page.

Case type ST Values in the Case type domain could be:

l ANK, Appeal

l FOR, Enquiry

l KLA, Complaint

l OMJ, Re-registered

Use in Captia Web Client

The values are used for characterizing cases. Values in domain Case

type are displayed in a drop-down box, for instance, in the field Case

type in the case details page.
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Domain type Code Description

Cust. dom.

type

TY The values in the domain Custom domain type are all domains. The

domain Custom domain type is domain for all other domain types.

If you want to create a new custom domain, you must create the

domain as a value in the domain Custom domain type.

Subnumber

type

UT Values in the domain Subnumber type are all domains designed to

contain Subnumbers.

The actual subnumbers are created and edited in the Subnumber

module.

The subnumber module is displayed by means of the menu item

Categories Subnumbers.

Create values

This topic explains how to create a value in a custom domain. The procedure is the

same whether the domain is a fixed domain or a user defined one.

Example

When you register cases in WorkZone Client or Captia Web Client concerning ships run

aground, you must register the reason for the grounding. The organization has a list of

so called Grounding codes. Each code describes a type of cause for the ships

grounding.

You have already created the domain type GC, Grounding cause for the codes see

Create domain type.

Your task now is to fill the domain with values. In this example, you are to create the

following values:

l CO, Collision

l NM, Navigational mistake

l NP, No pilot
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l SC, Submarine conditions

l WC, Weather conditions

Create domain values

1. Click Basic Data > Custom Domain.

2. Click the cell to the left of the Domain type in which you want to create

values, in this example, GC, Grounding cause. The contents of the domain

type is displayed in the upper right panel.

3. Click the empty cell at the bottom of the Code column.

4. Enter the value, i.e. the code identifying the value, in this example CO.

5. Click the next cell, Text, and enter the text defining the code, in this example

Collision.

6. Enter a start date in the Start date column.

7. Repeat the steps 4 to 7 until you have created all the necessary values.

8. Click Database > Save.

Note: If your system is running in multi-language mode, you must also add the culture

specific texts in the lower right panel.

Next step in the process is to create a custom label named "Grounded:" The data field

belonging to the label must be set to be validated against the values of custom domain

"GC, Grounding cause", see Create label with validation.

You can manage domain types with values yourself, see User managed domains .

Edit values

You can edit an existing value belonging to a custom domain type. The following cells can

be edited:

l Start date

l End date
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l Text

edit a domain value

1. Click Basic Data > Custom Domain.

2. Click to the left of the Domain type in which you want to edit values.

3. In the upper right panel, click in the date cells of the domain type to be

edited and in the lower right panel, click to edit Text cells.

4. Edit the data of the cell.

5. Place the cursor in another cell and click Database > Save.

You can manage domain types with values yourself, see User managed domains.

Terminate values

You can terminate values which are no longer in use by entering an End Date.

The following happens in WorkZone Client and Captia Web Client:

l Values no longer in use remain in place where they were originally used, for

instance, in cases.

l The value is no longer available in the drop-down list of the field to which it

originally belonged. However, it is still available in search pages.

terminate a value

1. Click Basic Data >Custom Domain.

2. Select the Domain type of which you want to terminate values.

3. Click the column to the left of the code of that domain type.

4. In the upper left panel, click End date of the value to be terminated. Click

the cell once more to activate it. Today's date is entered into the cell by

default.
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5. Enter the date manually, edit each part of the date separately or select a date

from the calendar.

6. Place the cursor in another cell and click Database > Save.

Note: To terminate a value immediately, insert yesterday's date as the end date.

You can manage domain types with values yourself, see User managed domains.

7.4 The Filing periods Module

The Filing periods module manages preservation and disposal codes used at the

termination of an archive period and/or transfer of data. The data in the Filing periods

module cannot be edited.

Prerequisites for managing periodization

The prerequisite for gaining access to the Filing periods module is the access code

DATAADM.

Click Basic Data > Filing periods to open the module.

Filing periods - preservation and disposal codes

These codes are managed in the Custom Domainmodule, see The Custom domain

Module

Note: This topic is only relevant for organizations and installations subjected to the

rules and regulations of the Danish Archives Act, represented by the Danish State

Archives, who are authorised to oversee the management of the records of Danish

Public Authorities. 

For more information regarding compliance - see the Danish State Archives website.
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7.4.1 Filing periods meta data

You can register the following data in the Filing periods module.

Data Description

Domain type Domain Type

Code Code

System Name of the owner of the domain type - if needed

Code Preservation/Rejection code

Text Text describing the scope of the code

System

Selection

Start date The date of initiation

End date The date of termination

Source The culture code of the master code

Text Text describing the scope of the code

Culture The current language code (i.e. default language).

7.5 The Contact module

The Contact module manages address types. The purpose of address types is to group

the contacts in the Contact register. The contact defines the format of the ID of the

contacts created in the register. The format of the ID could, for instance, be a personal

identification number or a sequence number.

Click Basic Data > Contact menu to open the module.

Prerequisite

You need the access code DATAADM to access the Contact module.
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7.5.1 About Contact type

The purpose of Contact types is to group the contacts in the Contact register. The

contact type defines the format of the ID of the contacts created in the register. The

format of the ID could, for instance, be a personal identification number or a sequence

number.

If there are no contact in the Contact module, no contacts can be created by the users of

WorkZone Client and Captia Web Client.

The individual contact is identified by its unique ID. The ID is composed of a single

letter/digit contact type and a code. The ID for a company, for instance, consists of the

contact type C and the contact code (the code being a sequence number)

Example: C 3542, Cloak & Dagger Inc.

In this example, C is the contact type and the code is a sequence number 3542. For each

contact type, you can specify the way it forms its code using a predefined set of

algorithms.

Contact types reserved by the system

Four contact types are reserved for special purposes. They supply data for drop-down lists

in WorkZone Client and Captia Web Client.

Important: You must not change or delete these four contact types:

l A, Units (i.e. organizational units.)

l M, Employees (i.e. case handlers)

l K, Municipalities (i.e. local government) - only default in some installations!

l U, Committees.

Note:

The register of the contact types M and U deviates from all other contact types. Their

data is automatically transferred from Active directory (AD), and therefore you can

only maintain them in Active Directory.
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How many contact types do you need?

Your organization should keep the types to an operational minimum. You should always

name new contact types in a clear and unambiguous manner to ensure that users of

WorkZone Client and Captia Web Client cannot be in doubt which contact type to select

when creating a contact.

Examples of needs for new contact types:

l Compliance with rules and regulations, for example, CPR or CVR.

l Domain knowledge or entities, such as houses, property, employees,

memberships.

l Simplification, for example, merger of two companies or to remove redundancy

when commencing a new archiving period.

contact types - the simple model

If no special reasons apply, it may only be necessary to add two types to the list of

mandatory contact types: P, Persons and C, Companies.

7.5.2 Create an contact type

You can create two different types of contact types; either one with automatically

generated ID (Auto id), or manually entered ID.

Create with auto ID

Create a contact type with auto ID

1. Click Basic Data > Contact.

2. Click the empty bottom cell of the columnName type.
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3. Enter the value of the new contact type.

You can enter one character into the cell - a letter between A and Z or a digit

between 1 and 9.

4. Click in the Auto id cell.

5. Click once more in the cell and select J in the list (J = Yes).

6. In the column Text, enter a descriptive name for the contact type.

7. In the column Comment, enter a description of its use.

8. Place the cursor in another cell and click Database > Save.

Note: If your system is running in multi language mode, you must also add the culture

specific texts and comments in the bottom panel.

Create with Manual ID

Below is described how to create a contact type with manually entered code, that is ID.

Example

You must create a contact type with personal identification number (CPR-number). When

the users in WorkZone Client or Captia Web Client create a contact with CPR-number, they

must use this particular contact type.

Create a contact type with manual ID

1. Click Basic Data> Contact.

2. Click the empty bottom cell of the columnName type.

3. Enter the value for the new contact type, e.g. P.

You can enter one character into the cell - a letter between A and Z or a digit

between 1 and 9.

4. Click the cell Code check.
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5. Click the drop-down box button of the cell.

6. Select an contact type, for example CPR number.

7. Click the Display Format cell twice. Enter the display format - in this

example XXXXXX-XXXX.

8. Click in the cell Name Code Length twice.

9. Enter the maximum number of characters/digits of the code.

In this example 10 (the dash is not counted).

10. In the column Text, enter a name for the contact type.

11. In the column Comment, enter a description of its use.

12. Place the cursor in another cell and click Database > Save.

Note: If your system is running in multi language mode, you must also add the

culture specific texts and comments in the bottom panel.

See also Contact type meta data.

7.5.3 Edit a contact type

You can edit information concerning existing contact types. You can edit all cells,

except the cell Name Type, which is the ID of the contact type.

How to edit contact types

1. Click Basic Data > Contact.

2. In the upper panel you can edit all the cells that are not greyed out, and in

the bottom panel you can edit Text and Comment cells.

3. Make your corrections.

4. Place the cursor in another cell and click Database > Save.
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7.5.4 Delete a contact type

You can delete contact types which have never been used.

Example: By mistake you have created the contact type F with the descriptive name

Farmer now this must be removed.

How to delete contact types

1. Click Basic Data > Contact.

2. Click in the cell to the left the contact type you want to delete.

The row is highlighted.

3. Click Edit > Delete Row.

4. Click Database > Save.

The contact has been removed.

7.5.5 Contact type meta data

Contacts are identified by their unique ID. The ID is composed of two parts i.e. the

Contact type and a Code. The contact type is Name type and the code is the sequence

number.

In the Contact module you can register the following information:

Column Description

Panel:

Upper panel

Cells of contact types

Name type The address type is identified by one character. Valid characters are

letters from A to Z and numbers from 1 to 9 (both included).

Note: You cannot use the letters A, M, K, and U. They are reserved by

the system: A = organizational unit, M = employee, K = municipality

(local government) and U = committee.

Last Used Code The last number issued to the contact type in question, if the counter

mode is J (= yes).
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Column Description

Auto id The following counter modes are available:

l J (= yes) - The ID is an automatically generated sequence

number.

l N (= no) - You must enter the code manually.

Example: An empty cell = N.

Code Check If the chosen Auto id was N, or left empty, you can select a suitable

control from the list in the cell Code Check.

List of controls

By default you can only select the controls in bold, remaining controls

depend on the customization of your installation:

l Nothing - the manually entered code is subject to no control.

l Numeric - the manually entered code must be numeric.

l CPR Number - the code entered is automatically controlled

according to the modulus 11 control*).

Note: The Central Office of Civil registration (CPR) by

October 2009 discontinued the modulus 11 compliancy.

l SE Number - the code entered is automatically controlled

according to the modulus 11 control.

l External SE number - SE number created in an external

database.

l External CPR number - CPR number created in an external

database.

l CPR Number

l Property Number

l CPR Number (KU-MatrikelStyrelsen)

l Birthday and Sequence Number
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Column Description

l 9 digit CPR Number - 9 digit CPR number

l CPR Number (Færøerne) - CPR number used on the Faroe

islands - 9 digit CPR number)

l CPR Number (fictitious) - fictitious cpr-number - day of birth

dash sequence number.

l Matrikel Number (Land register number)

l CVR Number (Legal units)

l CVR Number (Production Units)

l CVR Number (Legal an Production units)

l CPR Number (No modulus 11 check)

l CPR Number (Færøerne, No modulus 11 check)

Display format If the code must be entered according to a special format, enter the

pattern here. If the code is a CPR number, the format entered here must

be 10 Capital X's with the birthday and sequence number separated by a

dash: XXXXXX-XXXX.

Name code

length

If the Auto id was N (= no) or left blank, you can enter the number of

digits assigned to the number. The name code can be up to 11 digits in

length.

Access Code If you fill in this cell, contacts created with this contact type are subject

to restrictions. Only users with the proper authorization have access to

see these contacts.

You can enter an access code. It must exist in the access_code_domain

to be valid.

The access code entered here is transferred to every contact created

with this contact code.

Text Enter the specific description of the contact type here. Up to 32

characters. For contact type, for example, C, Company.

Comment In this cell you can write an elaborated description - up to 240 characters
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Column Description

- of the contact type.

Panel:

Bottom panel

The panel is displayed when the program is working in multi language

mode. Here the culture specific names of the values of contact types are

displayed and managed.

Text Enter the culture specific description of the contact type here. Up to 32

characters. For contact type C,Company.

This is the type displayed in the Captia Web Client user interface

according to the language selected by the user.

Comment In this cell you can write an elaborated culture description - up to 240

characters - of the contact type.

Culture In this cell, the culture code of the current contact type, defining the

language for the Text and Comment cells.

Source The current language code (i.e. default language).

Start date If a start date is specified , the value will be available in WorkZone Client

and the Captia Web Client from this date forward.

End date If an end date is specified, the value will be available in WorkZone and

Captia Web Client until this date occurs.

7.6 The Stopwords Module

The Stopwords module manages lists of words to be disregarded in free text searches.

The words registered in the Stopwords module are ignored when a free text search is

executed in WorkZone Client or Captia Web Client.

Prerequisites for managing stopwords

The prerequisite for gaining access to the Stopwords module is the access code

DATAADM.

Click Basic Data > Stopwords to open the module. The Stopwords lists already

registered in the module are displayed in the left panel.
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Default system stopword lists

The Stopwords module contains by default only one list of stopwords per culture.

Custom stopword lists

To add stopwords you must create a new stopword list specific for your organization

and/or culture.

Create a custom stopword list

1. Click Basic Data > Stopwords.

2. Click the empty bottom cell of the Stopword List column.

3. Enter the name of the new stopword list. The cell allows for names of maximum

30 characters.

4. Click in the List Type cell and select Custom from the list.

5. Click Database > Save.

6. The dialog box "You must activate the stopword list in Oracle before the

stopwords are used." is displayed. Click OK to continue.Create stopwords

1. Click Basic Data > Stopwords.

2. Click the Stopword List in which you wish to create stopwords.

3. Click the leftmost cell of the row. The contents of the list is displayed in the

right panel.

4. Click in the empty cell of Stopword column in the bottom row.

5. Enter stopword. Maximum 80 characters.

6. Place the cursor in another cell and click Database > Save.
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7.7 Create Corporate Access Codes

Use the procedures below if you want to apply a corporate access code to a contact or

to a file class in WorkZone Configuration Management, and it is the first time that this

corporate access code is used.

If you want to create a simple corporate access code, such as (<Term Access

Codes>&<Org. Access Codes>), you can do it in WorkZone Configuration Management

in the Basic Data module. See Create a simple corporate access code.

As regards a combined corporate access code, such as (<Term Access Codes>&<Org.

Access Codes>)|(<Term Access Codes>&<Org. Access Codes>), you must create it in

WorkZone Client or Captia Web Client first and then select it in WorkZone Configuration

Management. See Create a combined corporate access code.

Create a simple corporate access code

1. Click Basic Data > Create corporate access code.

2. Select one or more term access codes in the Term Part panel and one or

more organizational access codes in the Organizational Parts panel, and

then click Save. A message shows the access code that you just defined.

3. Click OK to create the organizational access code, or click No if you want to

return to the Create corporate access code page to make corrections.

Create a combined corporate access code

WorkZone Client

1. In WorkZone Client, open a search page for any item such as a case,

document, or contact.

2. Click Read access to open the Edit read access dialog box.

3. Click Create new access code.

84



Online Help

4. Create the new combined access code, and click Apply. The new combined

access code has been created. You do not need to perform the search in

WorkZone Client.

5. Open WorkZone Configuration Management. The combined access code that

you just defined is now available on the Access Code lists in WorkZone

Configuration Management.

Captia Web Client

1. In Captia Web Client, open a search page for any item such as a case,

document, or contact.

2. Click Acc. code to open the Select - Acc. code dialog box.

3. Create the new combined access code, and click OK. The new combined access

code has been created. You do not need to perform the search in Captia Web

Client.

4. Open WorkZone Configuration Management. The combined access code that

you just defined is now available on the Access Code lists in WorkZone

Configuration Management.

7.8 The Terms Module

The Terms module is a tool for the KMD technicians only. The Terms module contains

texts used in the user dialog.

The Terms module is the user interface for the TERMS register. The Terms register is

subdivided according to the part of the WorkZone system that it is covering CLIENT,

DOCINT, SOM.
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prerequisite

The prerequisite for gaining access to the Terms module is that you have the access

code TERMSADM.

Examples

Module

type

Id Culture Text

SOM USERMSG_FILE_

CLOSED

da-DK Sagen er afsluttet og kan derfor ikke

ajourføres.

en-GB Case is closed and so, cannot be updated.

Meta data

Information Explanation

Module type The field is a list box. Here you have the following options:

l CLIENT

l DOCINT

l SOM

Id The unique identification of the individual item in the terms register.

Culture Language/culture code for example eng-UK, da-DK.

One line per language.

Text The text that is displayed for the user.
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Example

Module

type

Id Culture Text

CLIENT JS_RECORD_REJOURNAL_MOVE_

ERROR

da-DK Flytning fejlede for nogle af

dokumenterne

en-GB Move failed for some of the

documents
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8. Categories
This section describes how to work with categories.

8.1 The Classification Scheme Module 88

8.2 The Facets-based Classification Scheme Module 101

8.3 The Subnumbers Module 112

8.4 The Dictionaries Module 120

8.1 The Classification Scheme Module

The Classification Schememodule manages the hierarchically ordered decimal

classification system. The individual items in the classification scheme are called

classes.

Click Categories > Classification Scheme to open the Classification Scheme

module.

8.1.1 About the classification scheme

Some organizations are bound by government regulations and must therefore comply

with certain rules and regulations which dictate a certain configuration. Other

organizations may choose a classification scheme that is closer to the way their

business is organized or the business workflow itself.

Traditionally the classes have been organized into ten main classes. These are each

divided into ten divisions, and each division into ten sections. This giving 10 main

classes, 100 divisions and 1000 sections.

The classification scheme is in many ways equivalent to the decimal classification

systems employed by the public libraries, for example, the Universal Decimal

Classification system.

Each class is identified by a decimal number representing the subject content. Each

class has a description of the subject content.
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The purpose of a classification system

The purpose of a classification scheme is to organize the cases handled in WorkZone

Client and Captia Web Client and the purpose of the classes and the subdivision is to

facilitate retrieval of the cases and the documents.

Often the class is a part of the case number. The classes are subdivided in to as many

levels as a class' subject dictates, that is cases are created on the lowest level on the

most specific class, representing the subject and content of the case matter.

Prerequisites for managing the classification scheme

The prerequisite for gaining access to the Classification Schememodule is the access

code DATAADM.

Mandatory system owned classes

Some classes are mandatory and system owned. Do not remove these classes.

l SJ-STD contains all desktop cases i.e. when a new user logs on to Captia Web

Client for the first time a desktop case is created. The desktop case is named SJ-

STD-<username> for example SJ-STD-ABC.

l SJ-TEST is used for test purposes.

l SJ-SYSTEM contains and owns SJ-STD and SJ-TEST.

l SJ-TEMP is used by WorkZone Explorer and WorkZone Meeting.

l SJ-AGENDA is used by WorkZone Meeting.

8.1.2 Classification scheme meta data

You can register different types of information in the classification scheme:

l Information describing the class.

l Information regarding filing periods.
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l Information concerning default data transferred to the case when it is created.

l Information transferred to the documents of the case when they are created.

In the table below is shown the data that can be registered in the classification scheme

module describing a class.

Panel Cell Description

1 This panel displays the case classification scheme. The scheme is

presented in a hierarchy that you can expand and collapse by clicking

on +.

Case

Classification

When the Classification Scheme module is displayed, the

classification scheme is displayed in the left panel:

l Classes at root level and superior levels, which are not to be

used for classifying cases are shown in red. Click the plus

sign to expand the hierarchy and view the underlying levels.

l Classes used in case creation are shown in black.

2 This panel contains basic data and functions of the class.

Class The class number.

The classes are the individual items that together constitute the

classification scheme.

Title The title of the class entry.

Sub-number

type

If the check box in the Fixed SubNumber cell is selected, this cell

must be checked as well.
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Panel Cell Description

Select the value for Sub-number type in the drop-down list. The

selected value defines which domain of sub numbers is attached to

the class.

Case creation The check box offers two options:

l The check box is selected: The users of WorkZone Client and

Captia Web Client are permitted to create cases with the

current class. The class is shown in black.

l The check box is cleared: The class is not available for case

creation in WorkZone Client and Captia Web Client. The class

works as a heading for branch of the hierarchy and is shown

in red.

Fixed

SubNumber

The check box offers two options:

l The check box is selected: The class must be subdivided by a

sub number. When the users in WorkZone Client and Captia

Web Client create a case with the current class they are

prompted to select a sub number.

Note: When this check box is selected, the option Sub-

number type must be selected as well.

l The check box is cleared: Sub numbers are not used for this

class.

The sub numbers must preexist in the Subnumbers module and each

subnumber domain containing the sub numbers must preexist in the

Custom domainmodule.

Free Case

Number

The check box offers two options:

l The check box is selected: Cases created with this class

must be numbered manually. The user in Captia Web Client

must enter the case number into the field thus defining the

unique ID of the case.
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Panel Cell Description

l The check box is cleared: Case numbers are inserted

automatically according to the method chosen, except for

CPR-numbers.

Note: Creation of free case number is not supported in WorkZone

Client.

Start Date Enter the date from which the class should be enabled.

End Date Enter the date of termination.

3 In this panel the culture specific titles of the classes are displayed and

managed. The culture specific title of the current class is maintained

here.

Title The title of the class entry - that is the name of the class.

Description Enter a description of the class.

Culture The culture code of language to be used for the title.

Source The current language code (the default language).

4 The panel displays case information. The information registered here

is automatically inserted into the corresponding fields of the case

details page in Captia Web Client and Captia Web Client when the case

is created.

This panel also contains filing period data.

Notes:

l Do not fill in the field unless required.

l The section is only active if class and title is shown in its

header.

Type Select the case type from the list. The case types come from the

custom domain ST, Case type.

Responsible

OU

Select the organizational unit that you want to apply as responsible

unit to the current case class. You can also select@Unit to apply the

unit of the user who creates cases in the specific case class.

92



Online Help

Panel Cell Description

Executing OU Select the organizational unit that you want to apply as executing unit

to the current case class. You can also select@Unit to apply the unit

of the user who creates cases in the specific case class.

Case Handler Select the employee that you want to apply to the current case class.

When new cases with this case class are created, the selected

employee is applied automatically as case handler. You can also

select@Me to apply the current user who creates the case in the

specific case class as case handler.

Access Code This access code determines which users are allowed to see and use

this class.

Select the access code that is relevant for the class from the list.

Default

access code

 If you select an access code, it will automatically be inserted into all

cases created with the current class.

The default access code determines which users are allowed to see

this case.

Default

update code

If you select an update code, it will automatically be inserted into all

cases created with the current class.

The default update code determines which users are allowed to edit

this case.

Mask The purpose of Mask to allow you to assign special case number

formats to individual classes.

Some case number formats only work if the Create Case page in

Captia Web Client is customized.

To configure case number masks, see About the case number mask.

Cover Enter the name of the case cover to be printed for cases in this class.

Response

limit for

records

This section concerns reply deadlines.

Note: In Captia Web Client Response limit is called Reply

deadline and a record is a document.

First record Fixed response limit for the first record
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Panel Cell Description

In this cell, you can enter a number.

When the user archives the first document of a case in WorkZone

Client and Captia Web Client, a date is automatically inserted into the

Reply deadline field of the document.

If you type 14, the deadline would be 14 days after the date of

registration.

Following

records

Fixed response limit for the following records.

In this cell, you can enter a number.

When the user archives the next document of a case in WorkZone

Client or Captia Web Client, a date is automatically inserted into the

Reply deadline field of the document.

If you type 28, the deadline would be 28 days after the date of

registration.

Draft
Versioning

This section allows you to apply draft versioning to a class.

Apply draft
versioning
automatically
to this class

Select this check box to apply draft versioning automatically to new
cases in this class. See Apply draft versioning.

Filing Period This section is for information concerning the shift from one

classification period to another. Here you can enter information

facilitating a shift from one period to another.

Previous

Case Class

Class in the previous classification period.

Previous

Subnumber

Type

Sub number type in the previous classification period, i.e., archiving

period.

Upcoming

Case Class

Class in the next classification period.

Upcoming

Subnumber

Sub number type in the next classification period.
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Panel Cell Description

Type

Disposal

Code

Code defining the preservation and disposal rules in force for the

class.

Transfer

Code

Code that specifies how cases and documents in the current class are

transferred to the next classification period.

Bottom right,

right side

panel

<Class and

title>

Information automatically transferred to a case at creation.

The purpose of this function is to minimize tedious registration work.

Typical cases subject to a standardized case handling process, such

as complaints, call for standardized registration.

With this function you can have certain basic data inserted

automatically into all new cases of this type.

5 Info On this tab you can register several entries of supplementary case

information.

Each row contains two cells:

l The Label cell is a drop-down box. The contents of the drop-

down box originates from the custom label module label

type SO, Suppl. case.

l The Information cell is a free text field or a drop-down

box. This depends on the label selected for the cell Label.

See - Routine and -Custom label types and data fields.

Note: Normally the information is entered by the case handler

who selects the relevant information during the case handling

process.

In Captia Web Client

When a user creates a new case with the current class, these entries

are automatically inserted. The user can see and update the entries in
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Panel Cell Description

the bottom section of the case details page - click More ... >

Information.

Date On this tab you can register several entries of supplementary case

dates.

Each row contains one cell. The Label cell is a drop-down box. The

contents of the box originates from the custom label module label

type SD, Suppl. case dates,see also Dates.

Note: Normally the dates are entered by the case handler during

the case handling process.

In Captia Web Client

When a user creates a new case with the current class, these entries

are automatically inserted. The user can see and update the entries in

the bottom section of the case details page - click More > Dates.
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Panel Cell Description

Keywords On this tab you can register several entries of keywords.

Each row contains one cell. The Keyword cell is a drop-down box.

The contents of the list originates from the Dictionary module.

Contacts This tab contains rows with three cells:

l Contact type (also called contact type) - for example,

Person with CPR-number

l Contact code (also called Sequence number) - for example

180562-5903

l Role - for example Applicant, Replicant and so on.

You can insert several rows. You can insert rows with only a role or

rows with both role and a specific contact.

In Captia Web Client

When a user creates a new case with the current class, these rows

are automatically inserted. The user can see and update the rows in

the bottom section of the case details page - click More > Parties.

8.1.3 Create a class

Always activate the class of the level above the level where you want to create a new

class.

Example

As an example, if you wish to create class "322, Internally financed projects," you should

start in class 32. The classification scheme of your organization is constructed in such a

way that classes at root level consist of one digit, classes directly subordinated consist of

two digits, and classes at the lowest level consist of three digits:

3 Physical working conditions

32 Projects concerning building and construction

322 Internally financed projects
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create a class

1. Click Categories > Classification Scheme.

2. In the left panel, click the class above the class level in which you want to

create classes.

3. In the upper right panel, click the empty bottom cell of the column Class.

4. Click the cell once more and enter the number of the new class.

5. Click the Title cell. Click the cell once more and enter the name of the class -

in this example "Internally financed projects".

6. Select the check box of the cell Case Creation.

Note: If your class is just a "level" and not an active class, leave it

unchecked. Fill in the following cells only if your class requires it: Fixed

Subnumber, Free Case Number, Start Date, and End Date.

7. Click Database > Save to save the class and the basic information.

Note: If your system is running in multi language mode, you must also add the

culture specific titles in the right middle panel.

add information transferred to cases at creation

Add file information

Use the bottom left panel and the bottom right panel to add file information.

1. Click to the left of the class in the upper right panel.

2. In the File Information section, fill in the fields as necessary.
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l Mask - only fill in this field if the case number format of this particular class should

deviate from default.

l Cover - use this if you have a physical paper archive with special case folders. Fill

in the name of the report holding the case folder template. Now you can print case

folders with case information for the archive.

3. Click Database > Save.

Add response limit for records

Use the bottom left panel and the bottom right panel to add response limit for records.

1. Click the First record field to enter the number of days to be inserted into the

document meta data that is in the Reply deadline field in the document

details page in Captia Web Client.

When the meta data in Captia Web Client are saved in the reply deadline date

will be postdated 21 days if you entered "21".

2. Enter data into the field Following records in the same way. This affects all

other documents than the first document.

3. Place the cursor in another cell and click Database > Save.

Add information, date, keywords, contacts

Use the bottom right panel to add Info, Date, Keywords and Contacts.

1. Click the relevant tab, for example the Info tab.

2. Click the empty cell in the Label column and select a label from the list.

3. Repeat this procedure to add more rows.

4. Place the cursor in another cell and click Database > Save. Use the same

procedure to add rows on the other tabs.
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For description of the above-mentioned cells, see About meta data.

8.1.4 Edit a class

You can edit all information concerning a class except Class. The content of this cell is

the unique ID of the Class. As soon as the newly created class has been saved, the cell

is locked for editing.

How to edit a class

1. Click Categories > Classification Scheme.

2. In the left panel, click the class a level above the class to be edited.

3. Click to the left of the cell of the class to be edited.

The class and all the panels are now active.

4. Click in the cell or cells you want to edit (some cells such as Subnumber

type and dates must be clicked twice)

5. Make the changes.

6. Place the cursor in another cell and click Database > Save.

Description of the cells that can be edited - see About metadata.

8.1.5 Terminate or delete a class

If the area of responsibility of the organization changes, some classes might have to be

terminated. Fill in the End date cell to terminate the classes and possibly a future date.

You can delete classes that are never used.

terminate a class

1. In the Classification Scheme Hierarchy panel to the left, click the class a

level above the class to be terminated.
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2. Click twice in the End Date cell and enter the date of termination.

3. Place the cursor in another cell and click Database > Save.

The class can no longer be used to create cases, however it can still be used as

a search criteria.

delete a class that has never been used

1. In the Classification Scheme Hierarchy panel to the left, click the class a

level above the class to be deleted.

2. Click to the left of the class you want to delete.

3. Click Edit > Delete Row.

4. Place the cursor in another cell and click Database > Save.

8.1.6 Apply draft versioning

You can apply draft versioning to new cases in a class.

apply versioning

1. Click Categories > Classification Scheme.

2. Select the class to which you want to apply draft versioning automatically.

3. In the bottom left panel, go to the Draft Versioning section, and select the

Apply draft versioning automatically to this class check box.

See Draft versioning

8.2 The Facets-based Classification Scheme Module

In the Facet-based Classification Schememodule you can manage the facet scheme.

The facet scheme is a hierarchically ordered keyword classification system. It is a system
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of keywords consisting of coordinate groups of keywords, describing an area of

responsibility within the organization.

Click Categories > Facet-based Classification Scheme to open the facet based

classification scheme.

See also Classification Scheme

8.2.1 About facets

Facets can be employed in two ways, either as a supplement to the Classification

Scheme or instead of a classification scheme. If you employ it as the classification tool

of your organization, its purpose is similar to that of a classic classification scheme,

however with more focus on domain keywords - belonging to more than just one area -

as opposed to the more rigid registration on just one class.

The default interface for facets is implemented on the details pages of cases and/or

documents in WorkZone Client and Captia Web Client at installation. The default

configuration is four fields for facets. One field for each root facet and its branches of

keywords. More (or fewer) root facets can be implemented, however this requires

special configuration and customization of the details pages.

Prerequisites for managing Facet-based Classification

Scheme

The prerequisite for gaining access to the Facet-based Classification Scheme

 module is the access code DATAADM.

See also Classification scheme.

8.2.2 Facet meta data

The table below displays the information you can enter to describe facets.
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Note: The below description is that of a default installation. If you have a customized

facet installation, please refer to your scope documentation as your implementation

may differ from the below description.

Panel Cell Description

Left panel This panel displays the facet based classification scheme. The

scheme is presented in a hierarchy where you can expand and

collapse levels by clicking on +.

Facet

Classification

When the Facet-based Classification Scheme module is

displayed, the facet classification scheme hierarchy is shown in

the left panel:

l All facet levels leading towards facet words are shown

in red; the facet words are shown in black.

l The facet tree is expandable from the level of Root

facets to Facet groups to Facet words.

l Facet words are the registration level.

Click the plus to expand the hierarchy to display the subordinate

facet groups and their facet words. Click the minus to collapse

the hierarchy and hide the subordinate facets.

Upper right

panel

Facet<Facet

and title>

In this panel, you register basic data and functions of the facet.

Class In this cell the facet is entered.

The facets are the individual items that together constitute the

facet classification scheme thesaurus-hierarchy. When you have

saved a new facet, you cannot change it any more - it is the

unique ID of the class.

Title The title is the facet word, for example the key word that is

shown to the end user in WorkZone Client and Captia Web Client.
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Panel Cell Description

Priority Enter a number here. The number entered defines where the

class (that is the facet) is displayed in a list of classes (that is

the facets).

Case

creation
l When the check box is selected, the users can add this

facet to cases. The facet is shown at the lowest level of

the root facet. This word will be shown in black.

l When the check box is cleared the users cannot add

this facet to cases. The facet is either a root facet or a

group facet guiding the user towards the facet words.

These words will be shown in red.

Universal By default Universal is not employed.

Universal is only in effect with specific customizations. When a

root facet, for example, is marked as universal, no more than

one facet of this type is allowed on a particular case or

document.

Mandatory By defaultMandatory is not employed.

Mandatory is only in effect with specific customizations. When

a root facet, for example, is marked as mandatory, at least one

facet of this type must be registered with the case or document.

Start Date The date determines when the facet is available for use.

End Date The date determines when use of the facet is terminated.

Access Code If you select an access code, the facet will only be displayed for

users with this access code.

If you are using corporate access codes, you may choose only

group access codes in this field.

Default

Access Code

By default Default Access Code is not employed.

Default Access Code is only in effect with specific

customizations. If you select an access code, it will

automatically be inserted into all cases created with the current
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Panel Cell Description

class.

The default access code determines which users are allowed to

see this case .

Default

Update Code

By default Default Update Code is not employed.

Default Update Code is only in effect with specific

customizations. If you select an update code, it will

automatically be inserted into all cases created with the current

class.

The default update code determines which users are allowed to

edit this case.

Middle right

panel

In this panel, the culture specific titles of the facets are

displayed and managed. The culture specific title of the current

class is maintained here.

Title The culture specific name of the facet.

Culture The culture code of language to be used for the title.

Source The current language code (the default language).

8.2.3 Working with facets

The facet scheme is composed of groups of facets. At the top level are the root facets and

below the hierarchy of groups of facets. At the bottom level are the facets used for

characterizing cases and documents.

By default the system contains 4 root facets. The facets of each root facet can be

organized in several sub levels.

By default the WorkZone Client and Captia Web Client details pages for cases and

documents can contain fields for the four root facets and their hierarchies of facets. More

or fewer root facets can be implemented, however this demands special configuration of

the details pages.
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Example - a root facet with two levels

The root facet in the example below is Country. On the second level in the facet

scheme are continents, for example, Africa and Europe. The facet words are the

individual countries - in this example, three countries in each continent.

Facet1DB,

Country

F10, Europe F10001, Denmark

F10002, Holland

F10003, Portugal

F20, Africa F20001, Morocco

F20002, Kenya

F20003, Angola

The Captia Web Client user navigates the facets from a pop-up dialog from one level to

the next or searches for a specific facet word. The Captia Web Client user then selects

the facet words that characterized the current case or document.

In this example, the facets on the lowest level - facet words, for example, Angola or

Portugal, are the facets the Captia Web Client user would use in characterizing the

entity.

How to enter the facets in module Facet-based

Classification Scheme

In the table below is shown how the cells are filled in:

Root facet: Country Facet group:
Europe

Facet word:
Denmark

Class Facet1DB F10 F10001

Case Creation cleared cleared Selected

Universal *) *) *)

Mandatory *) *) *)

Access Code optional optional optional
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Root facet: Country Facet group:
Europe

Facet word:
Denmark

Default Access

Code

*) *) *)

Default Update

Code

*) *) *)

Start Date optional optional optional

End Date

Title Facet1DB Europe Denmark

Text Country Europe Denmark

*) By default not in use.

8.2.4 Create facets

The facet scheme is arranged as a hierarchy. At the top level are the root facets. Below

each root facet you can build a hierarchy of facets. By default, four root facets are at your

disposal. If more or fewer are needed, the details pages must be customized.

In the table below is a description of the general process of registering the facet scheme:
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Step Action

1 First create the 4 root facets. The four root facets are: Facet1DB, Facet2DB,

Facet3DB, Facet4DB.

Note: All four root facets must preexist in the module to make the facet

functionality work properly. Even if you only employ, for instance, two of the root

facets.

When you create a root facet, enter the name into the ID cell named Class, for

example Facet1DB

The name of the root facet, for example Facet1DB, must be entered into the Title

cell in this example "Country".

However, unless Facet1DB, is configured in the customjs.js file, Facet1DB will

be what meets the end user in WorkZone Client and Captia Web Client! The name

entered into the title cell is NOT displayed for the users in WorkZone Client and

Captia Web Client 

2 Secondly you must enter the next level of facets. If it is a very small facet scheme,

you could enter the facets used as keywords here.

If it is a larger facet scheme, enter a set of facet groups here. For example, the

continents - Africa, Asia, Europe etc.

3 Thirdly add a new level (group facets) or enter the facets used as keywords - for

example, the countries Algiers, Morocco, Tunisia, etc.

Important: If you operate with both a classification scheme and facet based

classification scheme, the IDs of the facets must not coincide with the IDs of the

classes.
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CreatIng facets

Create root facets

1. Click Categories > Facet-based Classification Scheme.

2. In the left panel, click Case Classification.

3. In the upper right panel, click in the empty cell of the column Class and enter

the ID of the first root facet, in this example Facet1DB.

4. Click twice in the Title cell and enter the name of the facet, in this example

Country.

5. In the Start Date cell, enter the initiation date.

6. Place the cursor in another cell and then click Database > Save.

7. Repeat this procedure to create the other root facets. If no facet groups are

needed, proceed to Create facets below.

Note: If your system is running in multi language mode, you must also add the culture

specific titles in the lower right panel.

Create facet groups

1. Click Categories > Facet-based Classification Scheme.

2. In the left panel, click the root facet you want to work with, in this example

Facet1DB.

3. In the upper right panel, click in the empty cell of the Class column and enter

the ID of the facet group, in this example F10.

4. Click twice in the Title cell and enter the name of the facet group, in this

example Europe.

5. In the Start Date cell, enter the initiation date.
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6. Place the cursor in another cell and then click Database > Save.

7. Repeat the procedure to create the other facet groups.

Note: If your system is running in multi language mode, you must also add the

culture specific titles in the lower right panel.

Create facet words

1. Click Categories > Facet-based Classification Scheme.

2. If you recently created facet groups, it is prudent to click Database >

Refresh to update the facet hierarchy.

3. In the left panel, click the plus of the root facet that you want extend, in this

example Facet1DB.

4. Now, click the facet group that you want work with, here Europe.

5. In the upper right panel, click in the empty cell of the Class column and

enter the ID of the facet word, in this example F100.

6. Click twice in the Title cell and enter the name of the facet word - in this

example Denmark.

7. In the Start Date cell, enter the initiation date.

8. Place the cursor in another cell and then click Database > Save.

9. Repeat the procedure to create the other facet words.

Note: If your system is running in multi language mode, you must also add the

culture specific titles in the lower right panel.

8.2.5 Edit facets

You can edit all information concerning a facets except for the Class. The content of

this cell is the unique ID of the class, that is the facet. As soon as the newly created

facet has been saved, the cell is locked for editing.
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Edit a facet

1. Click Categories Facet-based Classification Scheme.

2. In the left panel, click the facet level above the facet to be edited.

3. Click to the left of the cell of the facet to be edited.

4. Click in the cell or cells you want to edit (some cells like dates and codes must

be clicked twice) and make the changes.

5. Place the cursor in another cell and then click Database > Save.

Description of the cells that can be edited - see About meta data.

8.2.6 Delete or terminate facets

If the area of responsibility of the organization changes, some facets may have to be

terminated. Fill in the end date cell to terminate the facets or, if convenient, a future date.

You can delete facets that are never used.

terminate a facet

1. In the left panel - Facet-based Classification Scheme Hierarchy - click the

facet a level above the facet to be terminated.

2. Click twice in the cell End Date and enter the date of termination.

3. Place the cursor in another cell and then click Database > Save.

The class can no longer be used to create cases but it can still be used as a search

criteria.

delete a facet that has never been used

1. In the left panel - Facet-based Classification Scheme Hierarchy - click the

facet a level above the facet to be deleted.
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2. Click to the left cell of the row of the class you want to delete.

3. Click Edit Delete Row.

4. Place the cursor in another cell and then click Database > Save.

8.3 The Subnumbers Module

The Subnumbers module manages subnumbers. Subnumbers are used for subdividing

classes - in the module Classification Scheme.

Click Categories > Subnumbers to open the module.

8.3.1 About subnumbers

The Subnumbers module manages subnumbers. Subnumbers are used for subdividing

classes in the Classification Schememodule. For example, the class "4507, Bicycle

roads" must be subdivided according to a municipality code. Each municipality is

identified by a unique code. A custom domain must be created to contain the

municipality codes and the codes registered in that domain.

Lastly the dependency between the class, in the classification scheme, and the domain

must be established.

Prerequisites for managing Subnumbers

The prerequisite for gaining access to the Subnumbers module is the access code

DATAADM.

8.3.2 Configure subnumbers

To use subnumbers with the classification scheme, the following four preconditions

must be met:

l Subnumber domain types must be pre-created.
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You must create domains for each set of subnumbers. This is done in the Custom

Domainmodule. Create each subnumber type under the domain type entry UT,

Undernummertype.

l All subnumbers must be created in their respective domain types.

You must create each set of subnumbers in their specific domain types. This is

done in the Subnumbers module.

l The case number format must be adjusted to contain Subnumbers.

You must enable the use of subnumbers in the configuration of your case number.

This means that the code for subnumbers must be included in the case number

mask. This is done in the Ownermodule in the Case Number Format field.

l The Classification Scheme must be set up to handle Subnumbers.

Finally, you must connect each subnumber type with the relevant class in the

classification scheme. This is done in the Classification Schememodule.

Create a subnumber domain

Some classes in the classification scheme are subdivided by subnumbers , for example,

municipalities. The class "4507, Bicycle roads" must be subdivided according to a

municipality ID code. First a custom domain, that is a subnumber type, must be created to

contain the municipality codes, in this example MU, Municipality. It must be created in the

custom domain UT in the custom domain module - Basic Data > Custom Domain.

Create a subnumber

With the subnumber type "MU, Municipality" in place, you now need to create each

individual subnumber - in this case, each municipality. You create these subnumbers in the

Subnumbers module - Categories Subnumbers.

113



WorkZone Configuration Management 2021.1

Adjust the case number format

Then you may have to adjust the case number format to make allowance for

subnumbers. The case number format is set up in the Ownermodule in Case Number
Format section - Operation Owner.

In this example the case number format should be: 2009-4507/175-0003 - with 4507

representing the class and 175 the municipality. The case bearing this number would

then be the 3rd case regarding Bicycle roads (4507) in the Municipality of Rødovre

(175).

To configure the case number format to allow the use of subnumbers reflecting the

example, it should be:

aaaa-gggg(/uuu)-LLLL:

l aaaa- = year, e.g. 2009 followed by a dash

l gggg = class of max four characters, e.g. 4507

l (/uuu) = subnumber of max three characters, e.g. 175 starting with a front

slash.

The parentheses signify that subnumbers are only used if specified in the

Classification Scheme.

l -LLLL = sequence number of max four characters. The numbering is automatic

and proceeded by a dash. The capital L indicates that zeros are included with

numbers of less than four digits, e.g. 0003.

Establish A dependency between Subnumbers and Classes

of the Classification Scheme

Finally you have to link your subnumber domains to the classes in the Classification

Scheme. The dependency is made in the Classification Scheme module - Categories

Classification Scheme.
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Locate the Class. Insert the subnumber type into the cell called Sub-number Type. Now

the class knows where to validate the subnumbers. If the subnumber should be

compulsory, the option Fixed SubNumbermust be enabled.

Subnumbers in Captia Web Client

When users create a case selecting e.g. class 4507, they are prompted to select a

subnumber from, in this case, the domainMU, Municipality.

8.3.3 Create subnumbers type

You can use subnumbers to subdivide individual classes in the Classification Scheme. To

do this, you must create the necessary domains for the subnumbers. These domains are

subnumber types in the Custom Domainmodule. The subnumbers type must be created

in the UT domain.

Example

Lets say you need to create a subnumber type for Municipalities. You need to register

municipality in order to subdivide certain classes accordingly.

create a subnumber

1. Click Basic Data > Custom Domain.

2. In the left panel select UT.

3. Click in the cell to the left of domain type UT.

4. Click the empty bottom cell of the column Code.

5. Enter an identification code for the new subnumber type - maximum 8 letters.

(In this example the code entered is MU.)

6. Click the next cell.

7. Place the cursor in another cell and click Database > Save.
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Note: If your system is running in multi language mode, you must also add the

culture specific texts in the lower right panel.

Create a subnumber entry, see Create subnumbers.

8.3.4 Edit subnumber types

You can edit the following Subnumber Type information:

l Start date - you can change the date of initiation.

l End date - you can change the date of termination

l Text - you can change its description (max 65 characters).

edit a subnumber type

1. Click Basic Data > Custom Domain.

2. In the left panel, click the left most cell of the row UT.

3. In the upper right panel, click in the date cells of the subnumber to be

edited.

4. In the lower right panel, click to edit Text cells.

5. Edit the data of the cell.

6. Place the cursor in another cell and click Database > Save.

8.3.5 Terminate subnumbers type

Subnumber types with subnumbers registered on cases in WorkZone Client and Captia

Web Client cannot be deleted. They must be terminated.

If a set of subnumbers is no longer needed, you must discontinue the subnumber type.

Then disconnect the subnumber type from the classes in the Classification Scheme.
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terminate a subnumber type

1. Click Categories > Subnumbers.

2. In the right panel, click to the left of UT.

3. In the upper right panel, click in the End date cell of the subnumber type you

want to discontinue. 

4. Click once more to input the date of the discontinuation.

5. Place the cursor in another cell and click Database > Save.

disconnect a subnumber type from active classes

1. Click Categories > Classification Scheme.

2. In the Classification hierarchy, select the class from which you want to

disconnect the use of subnumbers.

3. Click in the Subnumber type column, the cell to activate.

4. Click once more to open the drop-down box of the cell.

5. Select the empty line in the top of the list.

6. Clear the check box Fixed SubNumber.

7. Place the cursor in another cell and click Database > Save.

8.3.6 Create subnumbers

You can create new subnumbers. Subnumbers are grouped according to type. Each type is

created in the Custom Domainmodule under the domain type entry UT.

Example

You need to create a number of municipality subnumbers. It is a prerequisite that the

municipality subnumber type already exists in the custom domain.
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create a subnumber

1. Click Categories > Subnumbers.

2. In the top panel, click bottom row cell of the columnNumber Type.

3. Click once in the cell to activate the drop-down box.

4. Click the drop-down button.

5. Select the relevant value - in this example MU, Municipality.

6. Click in the adjacent cell of the Number column and enter the relevant code,

in this example 175.

7. Select the check box in the Create column to make the subnumbers

available for selection in the Child case group field in WorkZone Client and

the Subnumber field in Captia Web Client when creating new cases.

8. Place the cursor in another cell and click Database > Save to save the

code.

9. Click the cell Text in the bottom panel and enter the description for the

code, in this example Rødovre.

10. Place the cursor in another cell and click Database > Save.

You have now successfully created a new Municipal-subnumber in the subnumber

domain MU, Municipality.Repeat the procedure from step 2 to create additional

subnumbers.

See also Create subnumber types.

8.3.7 Edit Subnumbers

You can edit information about existing subnumbers. You can edit the cells Create and

Text.

118



Online Help

Example

If, for instance, the name of a municipality has been misspelled you have to correct the

spelling mistake.

edit a subnumber

1. Click on Categories > Subnumbers.

2. Select the code of the Municipality you want to edit in the Number column.

3. The text describing the code is shown in the bottom panel in the Text column.

4. Click in the cell you want to edit.

5. Enter your change.

6. Place the cursor in another cell and click Database > Save.

See also Edit subnumbers type.

8.3.8 Delete/disable subnumbers

You can delete existing subnumbers that have never been in use.

delete a subnumber

If, for example, a municipality was discontinued or merged with another. The municipality

has been created anyway by mistake. The municipality subnumber must now be

terminated.

1. Click Categories > Subnumbers.

2. In the Number column, click the number code of the subnumber you want to

delete.

3. Click the left most cell of the row. The row is highlighted.

4. Click Edit > Delete Row. The Subnumber is deleted.
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5. Click in another cell.

6. Click Database > Save. The entry has been deleted.

terminate a subnumber

A subnumber is no longer in use. It has been used for an extended period, so it cannot

be deleted. It must be disabled.

1. Click Categories > Subnumbers.

2. In the Number column, click the number code of the subnumber you want to

disable.

3. Select the subnumber to disable.

4. Clear the check box in the Create column.

5. Place the cursor in another cell and click Database > Save.

The subnumber is disabled.

8.4 The Dictionaries Module

In the Dictionary module you can manage keywords.

Click Categories > Dictionary to open the Dictionary module.

8.4.1 About dictionaries

In the Dictionary module you can manage keywords. When the dictionary is turned on,

all keywords used in WorkZone Client and Captia Web Client must be registered in the

Dictionary module. Words to be used as keywords must be created in the dictionary.

The keywords are used for characterizing cases and documents in WorkZone Client and

Captia Web Client.

When the dictionary is turned on, the WorkZone Client and Captia Web Client users

must select keywords for cases and documents in the dictionary. Thus the dictionary is
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meant to hold the keywords allowed to be registered on cases and documents. The

dictionary ensures that only approved words can be applied.

You can create both keywords and synonyms for keywords. The synonym function is

merely a way of replacing words not approved for use. If you enter the synonym, it will

automatically be replaced by the correct word. INSECT POWDER for instance could be

registered as a synonym for INSECTICIDE. When INSECT POWDER is entered, it is

automatically replaced by INSECTICIDE.

Prerequisites for managing Dictionary

The prerequisite for gaining access to the Dictionary module is the access code

DATAADM.

8.4.2 Dictionaries meta data

The dictionary contains keywords. Keywords are used for characterizing cases and

documents in WorkZone Client and Captia Web Client, and not least to facilitate retrieval.

A keyword is registered as two entries, that is a keyword synonym and a standard

keyword. If the keyword synonym and the standard keyword are identical, the word is a

proper keyword. If, on the other hand, the keyword synonym and the standard keyword

are different, the word is a synonym.

The standard keyword is used on, for example, on cases or documents. The keyword

synonym on the contrary is automatically replaced by the standard keyword.

In the Dictionary module you can register the following information concerning

keywords:
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Data Description

Keyword

Synonym

Enter the keyword - that is the word that replaces the synonym.

Example

You want to register the word INSECTICIDE as a keyword. This means that

INSECTICIDE must be registered both in column Keyword Synonym column

and in the Standard Keyword column:

Keyword

Synonym

Standard

Keyword

User Date

INSECTICIDE INSECTICIDE LOF 27-05-

2013

Standard

Keyword

Write the synonym - that is the word that is replaced by the keyword.

Example

You are to register the word INSECT POWDER as a synonym for

INSECTICIDE. This means that the word INSECT POWDER must be registered

in the Keyword Synonym column and the word to replace it in the Standard

Keyword column:

Keyword

Synonym

Standard

Keyword

User Date

INSECT

POWDER

INSECTICIDE LOF 27-05-

2013

INSECTICIDE INSECTICIDE LOF 27-05-

2013

The word INSECT POWDER is now registered as a synonym. If a user in, for

example, the WorkZone Client case details page enters INSECT POWDER i the

keyword field, it will automatically be replaced with INSECTICIDE.

User The cell displays the ID of the user who initially created the keyword or the

synonym.
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Data Description

The ID of the user is by default automatically entered into the field when the

user registers a keyword.

The cell is locked and cannot be edited.

Date The cell displays the date when the keyword was registered.

The date is by default automatically entered into the cell. Hereafter the cell is

locked and cannot be edited.

8.4.3 Prerequisite

The prerequisite for using the Dictionary module is that it is pre-configured in the Owner

module.

In this module, you must decide whether you want to use the dictionary. If you want to

use it, you must:

l Specify which characters are not allowed in connection with keywords.

l Enter a minimum number of characters a keyword must consist of.

See Configure the dictionary in the Owner module.

8.4.4 Create keyword

New entries in the dictionary are registered by a keyword synonym and a standard

keyword. If the entry is a keyword, the words entered in both cells must be identical. If for

instance, you want to register the word INSECTICIDE as a keyword, it must be entered as

a keyword synonym INSECTICIDE and a standard keyword INSECTICIDE.
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register a new keyword

1. Click Categories > Dictionary.

2. In the Keyword Synonym column, click the empty cell in the bottom row.

3. Type the word.

4. Click the next cell in the Standard Keyword column.

5. Type the word again.

6. Select the Enabled check box. The check box must be selected before the

word can be deployed in Captia Web Client.

7. Click Database > Save. User name and date are filled in automatically.

8.4.5 Create synonym

To register a synonym in the dictionary, you must enter the synonym in the Keyword

Synonym column and the keyword in the Standard Keyword column. For example,

you want to register the word INSECT POWDER as a synonym to INSECTICIDE. Do this

by entering INSECT POWDER as the keyword synonym and INSECTICIDE as the

standard keyword.

The synonym function is merely a control. It replaces illegal synonyms with the proper

keyword. If you, for example, enter INSECT POWDER into the Keyword field on the

case details page in WorkZone Client and Captia Web Client, INSECT POWDER will

automatically be replaced by the proper keyword which in this example is

INSECTICIDE.

Register a synonym

1. Click Categories > Dictionary.

2. In the Keyword Synonym column, click the cel in the bottom row.

3. Type the synonym.
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4. Click the next cell in the Standard Keyword column.

5. Type the keyword to be used.

6. Select the Enabled check box. The check box must be selected before the

synonym can be used in WorkZone Client and Captia Web Client.

7. Click Database > Save.

8.4.6 Delete or disable keywords and synonyms

You can delete existing keywords and synonyms.

Important: This function has very extensive effects. When you delete an entry from

the dictionary, then:

l It is removed from the dictionary

l All occurrences are removed from entities in WorkZone Client and Captia Web

Client such as cases and documents.

delete keywords or synonyms

As an example, you want to remove the word PESTICIDE from the dictionary. It has been

registered on several cases and documents.

1. Click Categories > Dictionary.

2. Click the left most column of the entry you want to delete. The row is

highlighted.

3. Click Edit > Delete Row.

If the entry is in use in WorkZone Client or Captia Web Client, a message

displays: "Do you want to delete the keyword '<keyword>' and the <nn

references to it?"

4. Click OK to accept. The row disappears.
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5. Click Database > Save. The entry (and its references in WorkZone Client or

Captia Web Client) have been removed.

disable keywords/synonyms

If you wish to keep its references but discontinue any future use, you should use the

disable the keyword or synonym.

1. Click Categories > Dictionary.

2. Clear the Enabled check box of the entry you want to discontinue.

3. Place the cursor in another cell and Click Database > Save. The entry is

disabled from active use in WorkZone Client and Captia Web Client, but its

previous references are kept.
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9. The Register Security Module
The Register Security module manages the permissions of WorkZone users' access to

tables and registers of the system database.

Click Security in> Register Security to open the module.

9.1 About Register Security 127

9.2 Register security meta data 129

9.3 Permissions for registers and tables 131

9.4 Registers and tables 133

9.5 Permissions 134

See also Restriction of user permissions.

9.1 About Register Security

The module Register Security is part of the WorkZone security system. The purpose is

to assign the proper permissions to the WorkZone users.

Prerequisite

The prerequisite for gaining access to the Register Security module is the access code

DATAADM.

Security Codes

The WorkZone Security System is based on 10 security c Codes: 1, 2, 3, 4, 5, 6, 7, 8, 9,

and 10. For each of these security codes, the system administrator must configure a set of

permissions for every register and table of the system.

Important: Only security codes 1 through 9 are used by WorkZone Client and Captia

Web Client end users. Security code 10 is exclusively for the use of KMD technicians.
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Permissions

You can configure 4 permissions with regard to each security code. They are:

l Search= permission to find and view information in the database.

l Update = permission to edit and change existing information in the database.

l Insert = permission to create new entries or new entities in the database.

l Delete = permission to delete entries or entities in the database.

For the file and contact registers you can configure two more permissions:

l Lock = permission to terminate cases and contacts.

l Unlock = permission to unlock cases and contacts that have been terminated.

See also Permissions.

Permissions per register

The system administrator must define which permissions are assigned to each security

code in the registers and tables of the database.

Permissions per table

Some registers consist of several tables, such as the File register, the Record

register, and the Contact register (containing the cases, documents and contacts).

The permissions of the security codes on the table level may deviate from the

permissions on the register level. Consequently a security code with few permissions

may have more or extended permissions with regard to one or several of the register's

tables.

See also Registers and tables.
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Groups of users

The permissions of each security code can be configured to reflect the demands of specific

groups of users. When a user logs on to Captia Web Client, the security code assigned to

the user defines what the user is allowed to do.

Active Directory - AD

You can assign security codes to users in Active Directory (AD). When a WorkZone user is

created in AD, the user must be made a member of a distribution group, representing one

of the security codes. When the user's relevant AD information is transferred to the

WorkZone Content Serverdatabase, the user is automatically allocated the correct

security code and the corresponding permissions for registers and tables in the database.

Resetting of the IIS Admin service

If you change the configuration of security, you must reset the IIS Admin Service before

your changes take effect.

For more general information about resetting the IIS, see Important notes on usage.

Restriction of user permissions

Despite a user's high security code and extensive access code profile, it is possible to

restrict an individual user's access to the system with regard to Case Permissions,

Organizational Permissions and Contact Permissions.

See also Restrictions of user permissions.

9.2 Register security meta data

In the Register Security module you can configure the security codes (1-10). Each

security code is assigned permissions to execute the types of transactions necessary. You
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can assign the following transaction types (for example, permissions) to the security

codes: Search, Update, Insert, Delete, Lock, Unlock.

Column Description

Name The name of the registers or tables.

Type In this column you will find the following values:

l Main - Primary table, for example the main register itself.

l Parent - A table which has one or more child tables.

l Child - Sub table.

l Extension - Extension to a table.

l Text - Description.

Description A description of the contents of a table or register.

Security

Code

The system has 10 Security Codes. Codes 1 through 9 are assigned to the end-

users of for example WorkZone Client and Captia Web Client.

Code 10 is reserved for the KMD technicians.

Security codes cannot be added or removed.

Search Search is by default enabled for all users. Without this permission the user

would not be able to see anything in the system.

Update To edit existing information the users must have this permission.

Insert To create new entities such as cases in the database the users must have this

permission.

Delete To delete entities the user must have this permission.

Lock This permission allows the users to terminate cases or contacts in WorkZone

Client and Captia Web Client.

Unlock This permission allows the users to unlock cases or contacts in WorkZone Client

and Captia Web Client.

See also Permissions.
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9.3 Permissions for registers and tables

In the Register Security module you can configure the user permissions for registers and

tables. Configure the registers and tables in this order:

1. Configure the permissions on register level. When you save the configuration of

the registers, this configuration is passed on to the register's tables.

2. Adjust the individual tables if they need to deviate from the configuration of the

register.

Example

If, for example, Security Code 6 should have all permissions in the tables of the register

File (case), except the permission to delete the File (case) itself, the procedure would be

as follows:

1. Assign all permissions to Security Code 6 in the register named File.

2. Remove the Delete permission in the table with the name File and type Main.

Security Code 6 users now have all the permissions in all tables of the register

File. However, they do not have the Delete Permission for the primary table. In

other words they cannot delete files, for example cases.

For information on the four (plus two additional) permissions you can configure, see

Permissions.

configure registers

1. Click Security >Register Security.

2. In the Known Registers pane on the left, select the register you want to

configure.
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3. Click in the left most cell of the register. All the tables of the selected

register are displayed Tables in register panel to the right. The security

settings of the register itself are displayed in the lower right Security

settings for all tables in register panel.

4. Select the check boxes to add permissions or clear the check boxes to

remove permissions.

5. Place the cursor in another cell and click Database > Save.

When your register's configuration is saved, its configuration is passed on to the

tables of the entire register. You can always adjust the tables individually, if they

must deviate from the default setting of the register.

configure tables

1. In the upper right Tables in register: <table name> panel, select the

table you want to configure.

2. Click the left most cell of the table. The security settings of the table are

displayed in the lower right panel.

3. Select the check boxes to add permissions or clear the check boxes to

remove permissions.

4. Place the cursor in another cell and click Database > Save.

Resetting of the IIS Admin service

If you change the configuration of the security, you must reset the IIS Admin Service

before your changes take effect.
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9.4 Registers and tables

The WorkZone database is based on a set of registers. Essentially two types of registers:

l Primary registers

l Secondary registers.

A register in WorkZone is a set of tables that describe an entity such as a case (file); the

data in a set of tables correspond with the data presented in the user interface in

WorkZone Client and Captia Web Client. File, for instance, is a Primary register - in

WorkZone Client and Captia Web Clientknown as Case. Opening the main register entity,

for example the case, gives the user access to the tables that comprises the case.

Primary registers

The primary registers are the ones the end users encounter in their work on a daily basis,

that is the File register, the Record register, and the Contact register (corresponding to

cases, documents, and contacts in WorkZone Client and Captia Web Client).

End users

The end users are given permissions to primary registers and their tables depending on

the rules and regulations their organization has to comply with. For the end users of many

organizations, this means that they are not allowed the permission to delete.

System administrators

The system administrators are often given the highest security code to access all levels of

the system and its registers in order to be able to maintain the systems configuration.

Secondary registers

Secondary registers supply basic information for the primary registers. The secondary

registers are characterized by data that is rarely changed. If they need to be adjusted this
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is a job for the WorkZone Configuration Management system administrators. As an

example this could be maintenance of Custom domain, Custom label, Classification

Scheme, or simply adding a new country to Countries and Post codes, and so on.

End users

The end users must have Search permissions to all registers to be able to find and view

information from the secondary registers.

System administrators

The system administrators are usually given the highest security code to access all

levels of the system and its registers in order to be able to maintain the systems

configuration.

9.5 Permissions

Below is a description of the four permissions. There is a big difference between

permissions granted a register or a table. If you, for instance, have delete permissions

in the table containing contacts attached to cases, you are able to remove unwanted

contacts from cases. However, if you have deleted permissions for the case register

itself, you can delete an entire case.

Permissions

The four permissions you can configure with regard to each security code are:

l Search - permission to find and view information in a register or a table.

l Update - permission to edit and change existing information in a register or

table.

l Insert - permission to create new entities in a register or table.

l Delete - permission to delete entries or entities in a register or table.
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Two additional permissions

The registers Contact and File have two additional permissions that can be configured.

You can configure each security code with regard to:

l Lock - permission to terminate a contact or a file (i.e. a contact or a case in

WorkZone Client and Captia Web Client).

l Unlock - permission to reopen the use of a contact or reopen a file.

Note: In the following, the File register is used as an example.

Search permission

With a default configuration all security codes are permitted to search in all registers and

tables. If this were not the case the users would not be able to find or view any information

in any registers or tables.

Update permission

Users who need to edit existing data must be assigned a security code with this

permission.

In tables of the type Main, all users are permitted to edit existing data and to enter

information in empty fields. In WorkZone Client and Captia Web Client, the information

contained in the main table is displayed, for example in the details page of cases.

Note: The main table is the register itself viewed as a table.

In tables of the type Child, the users are permitted to edit all existing data. But the users

are not allowed to add new data. To do this, the users must have insert permission. The

user will not be able to add a new contact to a case in WorkZone Client or Captia Web

Client with the update permission alone.
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Insert permission

In tables of the type Main all users are permitted to create new entries in the register.

This means that the users have permission, for instance, to create new cases in

WorkZone Client and Captia Web Client.

In tables of the type Child the users are permitted to insert new lines of information.

This means that the users have permission, for example, to add new contacts to a case

in WorkZone Client and Captia Web Client.

Note: Even though the user does not have insert permission to tables of the type

main, it is important that the user has "insert" permissions to the tables of the type

Child. Otherwise the users are not allowed to attach contacts, document etc. to

cases. Actually both "insert" and "delete" permissions for tables of the type child

should be assigned to the users if they cannot maintain important case information,

for example, adding and removing contacts.

Delete permission

In tables of the type Main permission to delete is not recommended. If the user has

permission to delete here, that is in the register itself, then the user is permitted to

delete entire entries in the register. In WorkZone Client and Captia Web Client, for

instance, this means that the user is permitted to delete an entire case.

In tables of the type Child, the users are permitted to delete lines of information. This

means that the users have permission, for example, to delete contacts from a case in

WorkZone Client and Captia Web Client.

By default users must have delete permissions to tables type child in order to maintain

files, records and contacts (for example cases, documents and contacts in Captia Web

Client) efficiently.
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Lock and unlock permissions

The registers Contact and File (cases) are supplied with two additional permissions, "lock"

and "unlock". With these two permissions users are allowed to terminate and/or reopen

entities.

On the WorkZone Client and Captia Web Client case details pages it is possible to

terminate and reopen a case if the user's Security Code is configured to contain the

permissions "lock" and "unlock". The same applies to contacts.
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10. The Diagnostic Module
The diagnostic module manages tools for tracing activities of the WorkZone

Configuration Management.

The diagnostic module is started when you log on to WorkZone Configuration

Management. The module starts tracing and logging the activities of the program at

once. The tracing is terminated and the log erased when you close the program.

Click Diagnostic > Trace Output or Enable sjDebug to open the module.

Prerequisites for managing diagnostics

The prerequisite for gaining access to the Trace Output module is the access code

DIAGADM.

No access code is needed for Enable sjDebug.

10.1 Export trace log 138

10.2 Enable sjDebug output 139

10.3 Trace output meta data 139

10.1 Export trace log

You can export the log containing trace information. Do this in order to document

events if you encounter errors in the program. You can send the file containing the log

to KMD for further scrutiny and diagnosis.

export trace output log

1. Click Diagnostics > Trace Output.

2. Click File > Export. The Save Diagnostic dialog is displayed. By default

the file name SysadmDiagnostic is suggested. The file can only be saved as
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a text file (*.txt).

3. Click Save.

10.2 Enable sjDebug output

If you need to document errors in the WorkZone Configuration Management, you can also

use sjDebug. When you apply sjDebug, all program transactions are traced by sjDebug.

Prerequisite:

Before you can enable sjDebug output, sjDebug must be running. If you do not know how

to initiate this program contact your technical system administrator in charge of your

WorkZone installation.

Two possible scenarios:

l You are aware of a problem in WorkZone Configuration Management. Start

sjDebug before logging on to WorkZone Configuration Management.

l You encounter a problem while working in WorkZone Configuration Management.

Start sjDebug and enable sjDebug output.

Start sjDebug

1. Logon to the server where WorkZone Configuration Management is installed.

2. Click Start > Run.

3. Enter sjDebug into the field and click OK.

4. When prompted for password enter scanj.

10.3 Trace output meta data

The Trace Output will display a panel with the following columns:
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Column Description

Time Time of transaction

Module Module that was active

Component Program component that was

involved

Method Function

Text Description
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11. Operation
11.1 The Owner Module 141

11.2 The Users Module 161

11.3 The Preference Profiles Module 166

11.4 The Processes Module 173

11.5 The Service Workflows Module 175

11.6 176

11.7 The Process Settings module 176

11.8 The Process Dispatchers Module 182

11.9 The E-boks Materials Module 186

11.10 The Remote Print Types Module 187

11.11 The Dispatch Sequences module 188

11.12 The Record Access Module 189

11.13 The External Sources Module 192

11.14 The Service Channels Module 193

11.1 The Owner Module

The Owner is the organization that has purchased the right to use for the WorkZone

system.

The Ownermodule manages information regarding ownership and central information

about the system's configuration. This configuration is global, i.e., it applies to the entire

system.

Important: Be careful not to change your configuration once it has been implemented!

Some configuration, such as Case number, hide/show access codes should not be

changed once they have been initiated. Changes during a production period may affect

searches and archiving results, and so on.
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Some configurations, however, may be overridden locally in the WorkZone system; as

an example the global configuration of the case number format can be overridden in the

classification scheme on an individual class level by the employment of a specific mask.

Prerequisites for managing Owner

The prerequisite for gaining access to the Ownermodule is the access code

USERADM.

Click Operation > Owner to open the module.

11.1.1 Owner meta data

In the Ownermodule you can manage information about your organization and the

configuration of the WorkZone system.

The Ownermodule consists of a number of sections where you can register the

following information:

Cell Description

Name Enter the name of the organization using the current installation.

Address Enter the address of the organization mentioned above.

City Enter the post code in the first field.

Press Tab and the postal district is automatically filled into the

adjacent field.

Note: Post code must be configured in the Countries and

Postcodes module.

Country Enter the country code in the first field.

Press Tab and the name of the country is automatically filled into

the adjacent field.

Note: Country codes must be configured in the module

Countries and Postcodes.

Phone Enter the phone number of your organization.
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Cell Description

CVR-NR Enter the CVR number, that is the central business registration

number of your organization.

CVR no. is a Danish Central Business Registration Number.

Important: It is important that you enter the CVR no.

correctly (8 digits) because it is a prerequisite for the

employment of eDeliverynote (e-følgeseddel).

Access Code Visibility

Hide Organizational

Access Codes

Check box with two options:

l Cleared check box - organizational access codes are in

use.

l Selected check box - organizational access codes are

hidden.

Organizational access codes (i.e. unit access codes).

Note: By default the check boxes are cleared. If Corporate

Access Codes are employed, hiding is not an option.

Important: Only users with the AFDADM and STJERNEADM

access codes have the rights to set the Hide Organizational

Access Codes check box.

Hide Employee Access

Codes

Check box with two options:

l Selected check box - employee access codes are in use.

l Cleared check box - employee access codes are hidden.

Employee access codes (i.e. user access codes).

Note: By default the check boxes are cleared. If Corporate

Access Codes are employed, hiding is not an option.

Important: Only users with the MEDARBADM and
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Cell Description

STJERNEADM access codes have the rights to set the Hide

Employee Access Codes check box.

Dictionary

In use Check box with two options:

l Cleared check box - the dictionary is disabled. Entered

words are not validated but accepted.

l Selected check box - the dictionary is enabled. Entries

from the dictionary must be used as keywords. The

words are validated. If a keyword is not in the dictionary

(and enabled), it is rejected.

Illegal characters Characters entered in this box will be rejected if they are entered

in the dictionary.

Minimum length Indicates the minimum length of an entry in the Dictionary.

Other sections

Group Language Select culture code from the drop-down box.

The selected language will be the default language of WorkZone

Client and Captia Web Client.

Case Number Format Enter the default case number format for the system.

Record Access Rights Check box with two options:

l Cleared check box - Record Access Rights module is

disabled.

l Selected check box - Record Access Rights module is

enabled.

The information of the Culture Settings tab:
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Cell Description

Culture Name Languages, for example:

l da-DK (= Denmark)

l en-GB (= Great Britain)

The culture name is set up during the installation of the language

pack and cannot be edited by users.

Date Pattern A mask defining the way dates are formatted for the culture

selected - for example:

l dd-MM-yyyy HH:mm:ss

l MM-dd-yyyy HH:mm:ss

dd day

MM month

yyyy year

HH hour

mm minute

ss second

Note: Changes to this cell will influence all date fields in the

system.

Culture Code Culture codes, for example:

l 1030 (= da-DK)

l 1033 (= en-GB)

Activated The day the date pattern is activated. The date is set at installation

of the language pack and cannot be edited by users.

Deactivated The day the date pattern is deactivated. The date is set at

installation of the language pack and cannot be edited by users.

11.1.2 Hide or show access codes

Users and organizational units are maintained in AD (Active Directory). They are

replicated to the WorkZone database at intervals.
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SJ Active Directory Connector transfers data from AD to the WorkZone database,

for example users and organizational units as well as access codes. Access codes are

used for regulating read/write rights to cases and documents.

By default, access codes for both users and organizational units are available for use.

However if these access codes are not wanted or disruptive for efficient use of Captia

Web Client, they can be hidden.

You can hide access codes for both users and organizational units. This is done if they

are not to be used. You decide whether both or just one of them are to be hidden or

employed.

hide access codes

1. Click Operation Owner. The Access Code Visibility section contains

the options that determines if access codes are hidden or visible:

o Hide Organizational Access Codes (i.e. unit access codes).

Important: Only users with the AFDADM and STJERNEADM access codes

have the rights to set the Hide Organizational Access Codes check box.

o Hide Employee Access Codes (i.e. user access codes).

Important: Only users with the MEDARBADM and STJERNEADM access

codes have the rights to set the Hide Employee Access Codes check box.

2. Select the check boxes to hide the access codes or clear the check boxes to

show the access codes.

3. Place the cursor in another field and click Database > Save.

The programmust be restarted to activate the configuration.

146



Online Help

Note: By default check boxes are cleared. If Corporate Access Codes are deployed,

hiding is not an option.

See also Owner meta data - Hide Employee Access Codes.

11.1.3 Enable or disable record access rights

The purpose of this configuration is to enable or disable Record Access in WorkZone

Client and Captia Web Client altogether. This is done with the check box field Enabled in

the Record Access Rights section.

enable record access rights

1. Click Operation> Owner.

2. In the Record Access Rights section, select the Enabled check box to enable

record access or clear the check to disable it.

3. Place the cursor in another field and click Database > Save.

Note: By default the record access is disabled (the check box is cleared).

11.1.4 Configure the dictionary

The basic configuration of the dictionary is done in the Dictionary section in the Owner

module.

Enable or disable the dictionary

1. Click Operation> Owner.

2. On the Owner Settings tab, select the In use check box field in the

Dictionary section to enable the dictionary or clear the check box to disable

the dictionary.

l Dictionary is enabled - the check box is selected.

All keywords and synonyms must preexist in the dictionary. When you register
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keywords on, for example, cases in WorkZone Client or Captia Web Client, the

words are validated against the dictionary. If they do not exist in the dictionary

(or the keywords are disabled), they are rejected.

l Dictionary is disabled - the check box is cleared.

In WorkZone Client and Captia Web Client, the users can both register

keywords at will and register keywords from the dictionary. There is no

validation.

A message displays saying: "You must restart before this change has any

effect."

2. Place the cursor in another cell and click Database > Save.

3. Restart WorkZone Client or Captia Web Client and WorkZone Configuration

Management to activate the changed configuration.

Illegal characters

In Illegal characters field, you can register characters that are not allowed in

keywords in the dictionary. If you try to enter illegal characters, they will be rejected,

that is the word will not be accepted.

Minimum length

The number registered inMinimum length field defines the minimum length of an

accepted keyword. If you enter a keyword with fewer characters, it will be rejected.

11.1.5 Configure group language

In the Group Language section you can select the default user interface language of

WorkZone Client and Captia Web Client. When the users log on to clients, all labels,

drop-down lists, classification scheme, and so on, in the user interface are displayed in

the selected language.
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The field contains a drop-down box. You must select the culture code of the default

language.

Configure default language

1. Click Operation> Owner.

2. In the Group Language section, select the culture code for the default

language from the list.

3. Place the cursor in another field and click Database > Save.

4. Restart the program to activate the configuration.

See also Language mode and Group Language.

11.1.6 Configure date pattern

You can configure the date pattern for each culture implemented in WorkZone Client and

Captia Web Client. The configuration is set up in the module Owner and is globally

effective but you can deviate from this configuration. In the Usermodule you can define

an individual date pattern for each user and thereby deviating from the global

configuration.

You enter the date patterns on the Culture settings tab in the Ownermodule.

1. Click Operation> Owner.

2. Click the Culture Settings tab. The cultures installed are displayed.

3. Click in the Date Pattern cell.

4. Enter the date pattern for the culture, for example, the Danish date pattern da-

DK: dd-MM-yyyy HH:mm:ss

5. Place the cursor in another field and click Database > Save.

When a culture specific date format is to be specified, the following subset of the .NET way

of specifying the format is used:
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Format specifier Description

dd The day of the month. Single-digit days will be preceded by a zero.

HH The hour in a 24-hour clock. Single-digit hours will be preceded by a zero.

mm The minute. Single-digit minutes will be preceded by a zero.

MM The numeric month. Single-digit months will be preceded by a zero.

ss The second. Single-digit seconds will be preceded by a zero.

yy The year in two digits.

yyyy The year in four digits.

The following separators are valid for separating the parts of the date format:

Separator Description

” ” A space.

. A period.

- A hyphen.

: A colon.

/ A slash.

11.1.7 Configure draft versioning

In the Draft Versioning section, you can enable/disable version control of drafts.

Versioning applies to documents with the state UÅ (Draft) or UP (Personal draft). By

default draft versioning is enabled and a maximum of 100 old versions are kept for any

document. Note that new documents are not automatically put under version control

unless you specify it.

Enable and configure draft versioning

1. Click Operation> Owner and go to the Draft Versioning section.

2. To enable draft versioning, select the Enable draft versioning check box.

3. If you have enabled draft versioning, you can choose to:
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l Keep all versions - Keeps all versions of the drafts.

l Keep number of versions as set in 'Version limit' - If you select

this option, specify a limit in the Version limit field. The system keeps

the number of drafts specified in the Version limit field. If the limit is

exceeded, the oldest versions are deleted automatically.

Note: If you change the version limit, it takes effect next time a document is

changed.

4. Select the Apply draft versioning automatically to new drafts check box

to apply automatically version control to new drafts.

5. Place the cursor in another field and click Database > Save to save the

configuration.

6. Reset the IIS on all web servers to activate the configuration.

Apply versioning control to cases in a class

You can apply versioning control to cases in a specific class, see Classification Scheme -

Apply draft versioning. This means that documents created on these cases have versioning

control applied automatically.

11.1.8 Case number format

About case number formats

Cases are identified by a number - the case number. The case number can be constructed

in different ways, for instance:

l 2009-00001, i.e. year-sequence number,

l 2009-1312/175-0001, i.e. year-class/subnumber-sequence number.
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Global configuration

Configuration of the case number is done in the Ownermodule in the Case Number

Format field. You must enter a global mask for the case number in a special format -

for instance aaaa.gggg(/uuuu)-LLLL.

In this mask, the letters used mean the following:

l a is the year, i.e. aaaa is automatically converted into a four digit year - 2013.

l g is the class, i.e. gggg means that the maximum length of the class is four

characters.

l u is the subnumber, i.e. uuuu, the maximum length of the subnumber is four

characters (/if it applies to the class).

l L is a sequence number, i.e. LLLL, a four digit number, e.g. 0034 (the capital L

signifies that the sequence number i fixed, always 4 digits preceded by zeros

when the number is lower than 4 digits, e.g. LLLL = 0034).

This is an example of a case number mask. The case number mask you enter applies

globally, i.e. to the entire WorkZone system.

Local configuration

You can deviate from the global configuration by configuring the case number format for

individual classes. This is done in the Classification Schememodule.

In the Classification Schememodule, you might for instance have a class reserved

for personnel files. You could, for example, configure this class to be a CPR-number and

in this way, deviate from the global case number format, for example a mask such as

cccc-cccc/LLLL = 180562-5903/0034.

See also Mask.
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Manual case number

It is also possible to number cases manually. If necessary, it is possible to set up classes

to prompt for a manually entered case number at case creation. This is configured in the

Classification Scheme, see Free Case Number.

The sequence number of the case number

When you create a new case, the case is automatically allocated a sequence number. If

the global case number mask does not include g = class or u= subnumber, you must

enter a hash (#) symbol in the case number mask, for example #aaaa-LLLLLL. The

sequence number is automatically generated when you use the hash symbol (#).

When you add the hash symbol (#) in front of the sequence number, the sequence number

is automatically reset when the year changes and a new one is created.

parallel case creation

To ensure scalability of parallel creation of cases, case numbers are not created in

consecutive order without holes. In rare situations a case number may be skipped, for

example when attempts to create a case with invalid data fail due to the transaction being

rolled back. In this case, a log that lists skipped case numbers is created. The log is placed

in the file_numbering_error table and is also available through the register named file_

numbering_error (OData: FileNumberingErrors). Consult the log if you suspect that a case

has been lost. The log shows if the case was never created.

Create case number format

Here you can read how to create or edit the case number format of the company.
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How to format a global case number

1. Click Operation> Owner.

2. Click in the Case Number Format field.

3. Enter or edit the case number mask.

4. Click Database > Save.

See also About case number mask components.

About the case number mask

In the Case Number Format section, you must enter a case number mask. The global

case number mask defines the way that the case number is formatted at case creation.

The case number format entered here applies globally for all cases created, except for

classes with individual case number masks, see Mask.

The components of the case number

The global case number mask can be constructed of a number of different components,

which are described below.

Information Description

Number of

characters

The case number can contain up to 30 characters including punctuation marks

and blank spaces.

Meta data In the table below is listed the components of which the case number can

consist. Components permitted are meta data and a sequence number.

Furthermore, you can see which characters you must enter to include the

different components in the case number mask:

Character Description

a Year - you can enter 2 or 4 characters:
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Information Description

Character Description

l 4 characters, a 4 digit year is used,

l 2 characters, the last 2 digits of the year are used.

g Class - from the classification scheme - contained in the

Classification Scheme module. For example, enter gggg if the

class consists of up to 4 digits.

s Responsible organizational unit - contact codes belonging to

contact type A.

For example, enter sssss if the contact codes of responsible

organizational units consists of up to 5 digits.

t Case type - domain items belonging to domain type case type in

Custom domainmodule.

For example, enter ttt if the class type can consist of up to 3

digits.

u Subnumber - subnumbers belonging to the Subnumbers

module.

For example, enter uuuu if the subnumbers consists of up to 4

digits.

L or l Sequence number - a capital L signifies that the format of the

sequence number is fixed - always the same number of digits and

that the digits will be preceded by zeros when the number is lower

than the allocated Ls.

A lower case l signifies that the format for the sequence of the

sequence number is variable.

See Sequence number format.

c CPR-number - which is the Danish personal identification

number.
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Information Description

Character Description

It is a ten-digit number with the format DDMMYY-SSSS, where

DDMMYY is the date of birth and SSSS is a sequence number. The

first digit of the sequence number encodes the century of birth (so

that centenarians are distinguished from infants), and the last

digit of the sequence number is odd for males and even for

females.

This case number format is normally used locally for the class in

the classification scheme used for registering personnel files for

individual employees.

z Used for case number masks for fictitious CPR numbers.

This case number format is normally used locally for the class in

the classification scheme used for registering dossiers for

individual persons - persons without an officially generated CPR-

number. The format is zzzzzz-zzzz.

This feature requires that the case details page is customized.

Sequence

number

format

You can define whether the sequence number is to be created with a fixed or a

variable format.

Fixed format

Upper-case signifies a fixed format of the sequence number. The sequence

number of the case number is designed to have a fixed number of digits.

If the sequence number, for instance, is defined as 4 capital letters such as

LLLL. The sequence number of the first case created is 0001.

If, for example, the case number mask is defined as: aaaa-gggg-LLLL. Then

the case number for a specific case could be 2009-1380-0004.

Variable format

Lower-case letters signify a variable format. The sequence number of a case
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Information Description

number is designed to have only the necessary number of digits.

If the sequence number, for instance, is defined as 4 lower-case letters such as

llll. The sequence number of the first case created is 1.

If for example the case number mask is defined as: aaaa-gggg-llll. The case

number for the same case would be 2009-1380-4.

Number of

characters

The number of characters in the global case number mask depends on how

many digits (or characters) each part of the case number is made up of.

The upper limit for the whole case number is 30 characters. Note that

punctuation marks and blank spaces are included.

Punctuation

marks

The following punctuation marks can be used to separate the different parts of

the case number:

- - hyphen

/ - slash

. - full stop

Conditional

information

Brackets around part of the case number mask signifies that this particular part

is only included, when the requirements described below are met:

l A subnumber is required by the class selected for the case. Mandatory

subnumbers can be defined for specific classes in the classification

scheme. For instance, the case number mask designed as aaaa-gggg

(/uuuu)-LLLL will, for instance, generates the following case

numbers:

l If subnumbers are mandatory for class 3720, the case

number will be formatted like this: 2009-3720/AAA-0001.

l If subnumbers are not defined for class 2650, the case

number will be formatted like this: 2009-2650-0001.

l The value specified in the mask is case metadata, and must be

entered before the case number can be created. Case metadata is

case type and responsible organisational unit.
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Information Description

This case number mask (#tttttt-) for instance, will generate the

following case numbers:

l If case type ABC is entered on the case, the case number will

be ABC-1380-0001.

l If no case type is entered, the case number will be 1380-

0001.

Mandatory requirements for the classification scheme

In the classification scheme, the check box in the cell Fixed SubNumber must

be selected, and a value selected in the cell Sub-number type. The value

selected defines what domain of sub numbers is attached to the class.

Information

controlling

the

sequence

number

To make a separate part of the case number influence how the sequence

number is generated, you must use the hash (#) symbol in the case number

mask. The hash (#) symbol can be applied in two different ways, with two

different results:

l Disable default numbering method

If you place a hash (#) symbol in front of default case number

information, i.e. class and sub number, the default numbering will be

disabled. This means that class and sub number have no influence on

the sequence number, which will be generated as a global sequence

number. This mask, for example #gggg-#uuuu-LLLLLL, generates

the following case numbers: 3270-AAA-000001, 3270-BBBB-000002,

3270-AAA-000003, etc.

l Enable special numbering method

You can place a hash (#) symbol in front of responsible organisational

unit and case type. This will cause the generation of the sequence

number to take this part of the case number into account. For

instance, gggg-uuu-#tttt-LLL - the case mask includes case type
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Information Description

with a hash (#) symbol. The creation of the sequence number is

controlled by the class, the subnumber and the case type selected.

Default sequence number

By default, primarily the class and secondarily the sub number control how the

sequence number is generated. If the case number mask only contains class

information, e.g. gggg-LLLL, each class will have its own series of sequence

numbers.

If the case number mask contains both class and sub number, for example

gggg/uuuu-LLLL, each combination of class and subnumber will have its own

series of sequence numbers.

Fixed

information

You can include fixed information in the case number mask. Fixed information

can be inserted into the case number mask in the following ways:

l Characters in square brackets [] are inserted directly into the case

number.

If the case number mask, for instance, is designed as [AMA]-gggg-

LLLL, the case number is created like this AMA-1312-0001.

l Characters entered like this !<characters> are inserted directly into

the case number.

If the case number mask, for example, is designed as

gggg-!<AMA>-LLLL, the case number will be created like this 1312-

AMA-0001.

About case number mask components

Below is a description of the different components of the case numbers.

Case number length

The case number can be up to 30 characters long. All components are taken into account

even separators.
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Case number components

Below are the default components of the case number mask:

Information Description

g Case class - the classification scheme.

u Subnumber - supplementary to the classification scheme.

L or l Sequence number entered as an L or l.

See Sequence number below.

a Year - 2 or 4 digits, i.e. aa or aaa.

s Organizational unit.

t Case type.

C or Z CPR number - 6-4 characters.

!<character> !<character> is not interpreted.

[     ] Characters in [ ] are not interpreted.

( ) Characters in ( )brackets are only included if required by the class - see

Fixed Subnumber.

Characters in brackets see Conditional information below.

Sequence number

Fixed

length

Upper case L's, for example LLLL, means that the sequence number has a fixed

length. The first case created gets sequence number 0001.

Variable

length

Lower case l’s, for example llll, means that the sequence number has a variable

length. The first case created gets sequence number 1.

Separators

You can use the following characters as separators between groups of information:

- = hyphen,

/ = slash, and
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. = period.

Conditional information

Brackets means that the information inside the brackets is included in the case number

when one of the following conditions is fulfilled:

l When the information is transferred from the classification scheme.

l When the information exists in the case details page.

11.2 The Users Module

In the Users module you can manage information concerning the user with regard to

security, date formats, culture and entity permissions.

Users are created and maintained in AD (Active Directory). They are transferred to the

WorkZone Content Server database with the WorkZone replication program via a

scheduled task. In WorkZone Configuration Management, you can adjust the privileges of

the individual users concerning the maintenance of data in Captia Web Client.

Prerequisites for managing Users

The prerequisite for gaining access to the Users module is the access code USERADM.

Click Operations > Users to open the module.

11.2.1 Users meta data

Cell Description

Name The unique ID of the user.

Full Name The full name of the current user.

Number The current user's user-number. This number is, for

example, used in the Use Logmodule. Each row of

information is started with the user number. This

way you can find out who has done what in the
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Cell Description

database.

SID The Microsoft Security Identification. The SID is a

unique alphanumeric row of digits identifying each

operating system and each user in the network.

Security The security code allocated the current user (the

code is a number between 1 and 9.) The security

code defines the database authorization of the user.

It represents what the user is allowed to do in each

register in the WorkZone Content Server database,

for example, whether the user is allowed to search,

update, create or delete cases.

The authority granted the security codes are defined

in the Register security module. In this module,

you define the rights granted each security code

level with regard to each register and table.

In Active Directory (AD), there are 9 distribution

groups corresponding to each of the security codes.

In AD, the users must be members of at least one of

these distribution groups to be able to work in

WorkZone programs.

Date Format If the cell is empty, the date format used is the

format configured in the Owner module on the

Culture settings tab.

In this cell you can enter a date format pattern. It

determines the way dates are displayed in Captia

Web Client for the current user, for example dd-MM-

yyyy HH:mm:ss

See also Date patterns.

Culture The cell shows what language the users has chosen

as default language in Captia Web Client.
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Cell Description

Configuration Displays when the current user has initiated an

update in the user's configuration in user_

configuration.

This happens when the user adjusts the set up in the

Captia Web Client interface, for example when the

user configures menus, lists etc.

Universal

access

Select Ja from the drop-down list to assign

universal access to the user. Universal access

means that the user has unlimited access to all

cases and documents. The user is not subject to

access code control.

Note: Only users with the access codes

MEDARBADM and STJERNEADM have the rights

to assign universal access to users.

Restriction of user permission

There are three panels where you can specify certain aspects of the permissions of the

individual user. These are the Case Permissions, the Organizational Permissions,

and the Contact Permissions. As long as these panels are not filled in, the users is not

limited in these areas. As soon as you fill in something in one of the panels, the user's

rights are restricted to the area defined in the panel.

If, for example, in the Organizational Permissions you enter a specific organizational

unit and the permission record, the current user is exclusively restricted to creating and

maintaining documents with the specified unit as responsible unit.
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Case permission

Case Class The function of the panel:

l If the panel empty, the user is permitted to create and update cases

and their documents no matter the case class (naturally in accordance

with the user's security code and access codes).

l If one or more rows of data are entered the user is restricted to

creating and maintaining cases and documents belonging to the case

classes registered here.

In this cell you can select:

l one case class per row,

l as many rows as needed

l a specific class, for example, 3230, Sand and rubble, or

l a value indicating a hierarchy entity, for example 32 (all classes

beginning with 32).

Permission Select the value from the drop-down box belonging to the cell.

The value entered in this cell defines the scope of the permissions. Is the user

granted permission to:

l Case - only cases,

l Record - only documents or

l Case/Record - both cases and documents.

Organizational permission

This panel functions like the "Case Permissions" panel.
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Organizational

Unit

As long as the panel is empty, the user is subject to no restrictions. As soon as

you enter an organizational unit and permissions, the users freedom of action

concerning creating and maintaining entities is severely limited.

The cell contains a drop-down box. Select an organizational unit to which the

user's authority is to be restricted.

Permission Select the restriction you want to impose on the users from the list box. The

user is allowed to create and maintain

l Case - only cases,

l Record - only documents or

l Case/Record - both cases and documents.

Contact permission

In this panel, you are able to limit in which contact types the user is allowed to create and

maintain contacts.

Note: By default, "Editing allowed" is preselected for all users with a security code

permitting creation and maintenance of contacts.

Contact

type

The cell contains a drop-down box with contact types. Select the contact types for

which the user is allowed to create and maintain contacts.

Permission The cell contains a drop-down box. Select the value relevant for the contact type

l Editing allowed (= Redigering tilladt).

l Editing prohibited (= Redigering ikke tilladt).
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Access codes

Access

Code

In this panel, the user's Access Code Profile is displayed - a list of all the access

codes the current user is a member of in Active Directory.

The list of access codes is for display only. They cannot be edited. If additional

access is needed, the users Access Code profile is updated by creating a membership

in AD. Changes are then transferred between AD and the WorkZone database at

regular intervals.

11.3 The Preference Profiles Module

Preference Profiles are employed by users in Captia Web Client. Restricting

Profiles are not by default employed. Restricting profiles are only in effect with specific

customization.

In the Preference Profiles module you can manage information regarding the

configuration of profiles. Profiles are defined and created by your organization. A profile

is a mask filtering out unnecessary values. The profile mirrors, for instance, a specific

job function or work area.

Users can work with or without a profile in Captia Web Client. The purpose of profiles is

that working on the basis of a profile, the user only see the data she needs to see. This

means that when the user opens a list or a pop-up window, only values relevant for the

work of the current user are displayed.

For example, the drop-down list in the Document group or Case handler fields only

display the values used by the current user. If the user needs to see and perhaps to

register other values, then the user can click Show all in the list. Then, the user can

select another value.

Prerequisites for managing Preference Profiles

The prerequisite for gaining access to the Preference profiles module is the access

code PROFILADM.
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Important: Before working in WorkZone Configuration Management, deselect any

active profile in Captia Web Client.

Click Operation> Preference Profiles to open the module.

11.3.1 The Preference Profile meta data

In the table below is an overview of all the information describing a profile.

Cell Description

Code The code is the unique ID of the profile. You must enter a code for the profile

when you create it. The maximum length is 11 characters.

When you have saved the profile the cell is no longer open for editing.

Name Enter a short and precise description of the profile in this cell. Use max. 60

characters.

When you have saved the profile, the cell is no longer open for editing.

Default Case

Handler

Default case handler in Captia Web Client

Select the default case handler from the list in the field.

The profile automatically inserts a default case handler when the user creates a

new case in Captia Web Client.

Default

Responsible

OU

Select the default responsible organizational unit from the list.

The profile automatically inserts a default responsible organizational unit when

the user creates a new case in Captia Web Client.

Access Code You can exclude users from using a profile. This is done by means of an access

code. If an access code is entered into the cell, only users with the same access

code can select the profile.

Start Date Initiation date. If this is not entered the profile cannot be enabled.

End Date Termination date. The profile is disabled from this date.

Tabs with

basic data

In the right panel - with the heading "Profile: <Code>" - are a number of tabs.

Each tab contains a set of basic data, for instance, Custom Domains.

In this panel, you attach basic data to the profile. The profile is a kind of basket

holding basic data. When the user chooses to work according to a specific
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Cell Description

profile, the user only sees the basic data specified by the profile.

When the user chooses to work without a profile, all basic data is displayed in,

for example, the drop-down boxes opened by the user.

Custom Label Select the custom labels that the users employing the profile need to see.

Custom

Domains

Select the values of custom domains that the users employing the profile need

to see.

Classification

Scheme

Select the classes which the users need to see.

Facet-based

Classification

Scheme

Select the facets that the users need to see.

Subnumbers Select the classes that the users need to see.

Employees Select the employes that the users need to see - in the Case handler field in

Captia Web Client.

Organisational

Units

Select the employes which the users need to see - in the Responsible unit

field in Captia Web Client.

11.3.2 Working with preference profiles

In the Preference Profiles module you can:

l Create new profiles.

l Edit already existing profiles.

l Disable profiles no longer in use.

Prerequisites for administering profiles

In order to maintain profiles you must have the administrator access code -

PROFILADM.
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Note: You cannot work in the module with a profile enabled for your user in Captia Web

Client. If you open WorkZone Configuration Management with a profile enabled, the

following message will be displayed: "You have and active profile: <profilename>. This

may cause unexpected behavior in WorkZone Configuration Management.

Working with profiles

Create a profile First create the profile in WorkZone Configuration Management.

l Give the profile an ID and a name. The name is a short and precise

description containing enough information for the users to

understand the scope of the profile.

l Select the data necessary and sufficient for the profile to fulfill its

purpose.

l Enter a start date to enable the profile. 

Select profile In Captia Web Client the profile is now available for the users. When the

user clicks the link to the profiles, a dialog is opened, where the user can

select either a specific profile or the default profile without any restrictions.

The profile in

use

When the user is employing a profile i Captia Web Client, the number of

values available in drop-down lists is limited. However, the value Show all

is available. The user can click Show all to see all values. All values are

available for use, i.e. can be registered on, for example, the case currently

displayed.

11.3.3 Create preference profiles

First you must create the profile and save and then attach data to it.

Create a profile

1. Click Operation> Preference Profiles.

2. Click twice in the empty cell of the Code column.
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3. Enter a short code, which will be the ID of the profile. Maximum 11

characters long.

4. Click the Name cell and enter a description of the profile here. Try to include

purpose and scope of the profile in this description.

5. Fill in the Default Case Handler and Default Responsible OU cells if required.

6. Fill in the Start Date cell to enable the profile.

7. Place the cursor in another cell and click Database > Save. When you

have saved the profile, the Code and Name fields are locked and cannot be

edited again.

create the contents of a profile

1. Click the left most cell of the profile you want to work with. The data you can

attach to the profile is available in the right panel.

2. Click the tabs containing information to be included in the profile. You have

two options concerning each category of information:

l All values are to be displayed:

Select the check box at the highest level.

l Selected values are to be displayed:

Click your way down the hierarchy to the values which should be included.

Click the check boxes of value to be included.

3. When you have selected the values, click Database > Save.

11.3.4 Edit preference profiles

You can edit an existing profile. The left panel contains information that identifies the

profile. You can edit all cells except the Code and Name cells, which are locked. In the

right panel, you can edit the meta data attached to the profile.
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Edit a profile

1. Click Operation> Preference Profiles.

2. Click the profile you want to edit.

3. Click the left most cell of the profile in the Code column. The right panel is now

populated with meta data ready for editing.

4. Make the corrections as needed.

5. Place the cursor in another cell and click Database >Save to save the

changes.

11.3.5 Delete or disable preference profiles

You can disable or delete profiles that out of date and no longer in use.

Disable a profile

1. Click Operation> Preference Profiles.

2. Click the profile you want to edit.

3. Click the cell End Date and select a date.

4. Click the date when the profile is to be disabled, for example today's date.

5. Place the cursor in another cell and click Database > Save to save the

changes.

delete a profile

1. Click Operation> Preference Profiles.

2. Click the profile you want to edit.

3. Click the left most cell of the profile you want to delete.

4. Click Edit > Delete row.
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5. Place the cursor in another cell and click Database >Save to save the

changes.

11.3.6 About restricting profiles

Use - customization

This function is not used in a standard Captia Web Client installation. Restricting Profiles

are intended for organizations with special demands. To implement the use of this

module Captia Web Client must be customized.

Purpose

The purpose of the module called Restricting Profiles is to control the use of basic

data. By means of restricting profiles you can control what basic data the users can see,

select and register in Captia Web Client.

The users can not select a profile themselves. In Captia Web Client, they by default

work according to the profile assigned to them by the organization.

Prerequisites for managing Restricting Profiles

The prerequisite for gaining access to the Restricting Profiles module is the access

code PROFILADM.

Click Operation> Restricting Profiles to open the module.

User interface

The interface of the Restricting Profiles module is identical to that of the Preference

Profiles module.
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Working with the Restricting profiles module

Use the help topic concerning Preference Profiles module as it also apply to the

Restricting Profiles module.

See also Preference Profiles.

11.4 The Processes Module

The Processes module is used to configure WorkZone Process processes. The packages

that you have installed are shown in this module. You can specify the order, access, and

start and end date of the processes.

Process
ID

A unique identifier of the process.

Guid The Globally Unique Identifier (GUID) of the process.
Name The name of the process.
Version The process version number.
Type The type of process. Possible types are:

l MAIN - Phase processes.

l SUB - Processes that can run both as standalone processes and

subprocesses under a main process.

l CASEACT - Case activities package.

l SERVICE - Service workflows.

l SUBSVC - Processes that are started by service workflows.

Note: The CASEACT, SERVICE, and SUBSVC process types are not visible in the

Processes overview.

Order The order of the processes, which defines the display order of the processes in the
Process menu in WorkZone Client and WorkZone for Office.

Access
Code

You cannot specify this setting.

Start The process start date. As of this date the process will be available.
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End The process end date. As of this date the process will no longer be available.
Access Configure who can access the processes in the current environment.

l ACTOR - Only the current user.

l DELEGATE - The user who has access rights to WorkZone Process can

delegate access rights to another user.

l ALL - Access is not limited to a specific user.

By default this setting is not specified. The value of the Access setting in the is

used.

Process specific settings

You can enter settings for each of the processes. Select a process and specify settings

for the selected process in the lower part of the screen.

Manage process versions and access to processes

In the lower left part of the screen, you can see installed versions of a process, specify

start and end date, and who should have access to the process from the Process menu

in WorkZone Client.

174



Online Help

Process
Id

A unique identifier of the process.

Workflow
Id

A unique identifier of the workflow.

Type
name

The name of the process.

Version The process version.
Start
date

The process start date. As of this date the process will be available.

End date The process end date. As of this date the process will no longer be available.
Access
code

Specify who should be able to start a process from the Process menu in
WorkZone Client and WorkZone for Office. You can enter users or organizational
units. If you do not enter a value, the selected process will be available to all
users in the organization.

Profile
enabled

Select this check box to enable a log profile for process. See Reduce log
information in the workflow log using a log profile.

Configure process specific settings

Some of the processes have specific settings that you can configure to suit an

organization’s specific way of working. Select a process and specify the settings for the

selected process in the lower right corner.

For more information about process specific settings, see the WorkZone Process

Administrator's Guide, for example the topics:

l
Configure SmartPost

l
Configure extended submission

l
Configure a ministerial process

l
Configure the history document

11.5 The Service Workflows Module

The Service Workflowmodule is used to configure service workflows in WorkZone

Process. You can set up three types of service workflows:

l Mailbox Monitor

l F2 Requisition Handler

175

http://help.workzone.kmd.dk/wzp/2020_1/InstallGuide/#Maintenance.htm%23Logging%3FTocPath%3DMaintenance|_____1
http://help.workzone.kmd.dk/wzp/2020_1/InstallGuide/#Maintenance.htm%23Logging%3FTocPath%3DMaintenance|_____1
http://help.workzone.kmd.dk/wzp/2020_1/InstallGuide/#SmartPost/SmartPost_Configure_CM.htm%3FTocPath%3DThe%2520SmartPost%2520package|_____6
http://help.workzone.kmd.dk/wzp/2020_1/InstallGuide/#Configure_Extended_Submission.htm%3FTocPath%3DSettings|_____10
http://help.workzone.kmd.dk/wzp/2020_1/InstallGuide/#Configure_Ministerial.htm%3FTocPath%3DOther%2520configurations|_____10
http://help.workzone.kmd.dk/wzp/2020_1/InstallGuide/#Configure_history_document.htm%3FTocPath%3DSettings|_____5


WorkZone Configuration Management 2021.1

l e-Boks Message Handler

l Monitor Process

To create and configure a service flow, you need to create a new row for each of the

workflows and fill in the settings.

Name A unique identifier of the service.
Description A description of the service.
Process The type of process.
Enabled Click this check box to enable that the service is started and monitored

by the Process Service Agent.
Alive check
interval
(minutes)

The interval in minutes between the agent checking that the service is
running.

Restart
interval

The interval in minutes before a new process is started and the old
process is completed. This is to prevent the workflow log from piling up
logging information.

See Service workflows in the WorkZone Process Administrator Guide for information

about specific settings for each of the workflow types.

11.6

11.7 The Process Settings module

The Process settings module is used to configure WorkZone Process.

CreateProcessHistoryDocuement Setting

The settings below apply to the process history document.
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Key Default setting Description

DocumentState ARK You can define a document state for

history documents generated by a

specific process. Click Operations >

Processes, and select a process to

configure process specific settings.

If the document state is neither

specified for each process nor here,

the ARK (Archived) state will be used

as the default state.

Overview Settings

The settings below apply to the Processes overview.

Key Default setting Description
CaseHandlerShownShortNames TRUE Specify if you want to display the

casehandler's initials or full name in

the Processes overview.

TRUE - Initials

FALSE - Full name

CaseHandlerUnitShownShortNames TRUE Specify if you want to display the short

name or the full name of the

casehandler's unit in the Processes

overview.

TRUE - Initials

FALSE - Full name

MaxODataPages 3 Specify the default maximum amount

of data to display on a page in the

Processes overview. See Customize

maximum data to display on a page

in the WorkZone Process
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Key Default setting Description

Administrator's Guide for information

about how the amount of data is

calculated.

OwnerShownShortNames TRUE Specify if you want to display the

process owner's initials or full name in

the Process overview.

TRUE - Initials

FALSE - Full name

PendingShownShortNames TRUE Specify if you want to display the

pending actor's initials or full name in

the Process overview.

TRUE - Initials

FALSE - Full name

PendingUnitShownShortNames TRUE Specify if you want to display the short

name or the full name of the pending

actor's unit in the Process overview.

TRUE - Initials

FALSE - Full name

Workflow host settings

The settings below apply to the workflow host.
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Key Default setting Description
Access DELEGATE Defines who can access

processes on the current

environment.

The default value is

DELEGATE. See Configure

default access settings in the

WorkZone Process

Administrator's Guide.

AllowNewInstancesInAD FALSE Defines whether to recycle

names in WorkZone Process

using Active Directory

Replication.

The default value is FALSE,

which disables recycling of

names. See Configure the

use of new name instances in

the WorkZone Process

Administrator's Guide.
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Key Default setting Description
WatchDelay 30 Controls the amount of time

passed since the workflow
should have been started. The
setting has a default value of
30 minutes.

See Configure workflow

failover in the WorkZone

Process Administrator's Guide.

WatchInterval 5 Controls intervals between
checks. If a web server is
unavailable, workflows are not
reactivated. In order to avoid
this, all workflow hosts
periodically check for
workflows that are overdue.
The setting has a default value
of 5 minutes. See Configure
workflow failover in the
WorkZone Process
Administrator's Guide.
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WORKZONE Settings

Key Default setting Description
PartyIdentifierSources Default location of

WorkZone CPR and

CVR data.

Specifies where the

SmartPostsending process

looks up sender information

such as CVR or CPR numbers.

Change the XML element in

this setting if the location of

the CPR and CVR data has

been customized.

See Configure SmartPost

PartyIdentifierSources in the

WorkZone Process

Developer's Guide.

ContactAddressKeySources Default location of

WorkZone CPR and

CVR data.

Specifies where the SmartPost

receiver process looks up

sender addresses based on the

CVR and CPR numbers

provided by e-Boks. For

example, for the purpose of

linking the received

documents to the addresses of

the senders.

Change the XML element in

this setting if the location of

the CPR and CVR data has

been customized.

See Configure SmartPost

ContactAddressSources in

the WorkZone Process

Developer's Guide.
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11.8 The Process Dispatchers Module

The Process Dispatchers module is used to configure dispatchers used by the

SmartPost process in WorkZone Process. You can set up three types of dispatchers:

l E-Boks

l Straalfors

l Local print

Depending on the type of dispatcher, you can fill in the following settings.

E-Boks

The settings below apply to the EBoks dispatcher.

Name Default
setting

Description

URL The URL for the e-Boks service.

Enter one of the URLs depending on whether the

configuration is made for test or production.

Test system: https://demo-rest.e-

boks.dk/V1.svc

Production system: https://rest.e-

boks.dk/v1.svc

SenderSystemId The sender system identifier, which is retrieved during

the configuration of the system in the e-Boks

administration portal.

ReceiverSystemId The receiver system identifier, which is retrieved during

the configuration of the system in the e-Boks

administration portal.

CertificateThumbPrint Enter the thumbprint that identifies the e-Boks

certificate.

SecurityProtocol Tls12 Denotes the security protocol to be used when

communicating with e-Boks.

182



Online Help

Name Default
setting

Description

e-Boks provides the security protocol to be used.

MaxDocumentSize 7864320
(7.5
megabytes)

The maximum number of bytes that an e-Boks message

can contain. Messages that exceed this limit will not be

sent to e-Boks. The default value is 7864320 (7.5

megabytes). The size is reduced by 25% compared to the

maximum size communicated by e-Boks. Due to

encoding, the maximum allowed size must be reduced by

25%.

ResponseThreshold 1800 Defines the maximum time that SmartPostexpects that it

takes e-Boks to process a message. This value is used to

calculate the deadline (supervised by the deadline

monitor). Specify the threshold in seconds. The default

value is 1800 seconds (30 minutes).

Note: The default value is most often used. In

situations where the communication with e-Boks is

slow, you can increase it. In test scenarios, you can

reduce the threshold, which reduces the time before a

smartmail with information about an exceeded

deadline is sent.

Straalfors

The settings below apply to the Straalfors dispatcher type.
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Name Default setting Description
Url The URL for the Strålfors Connect service.

Depending on whether the configuration is

made for test or production, enter one of the

two URLs.

Test:

https://itestprint.sconnect.dk/fjernprint/1.0.0

Production:

https://prodprint.sconnect.dk/fjernprint/1.0.0

SenderSystemID The system identifier, which is provided when
configuring the system in the Strålfors
administration portal. Either Strålfors or the
person, who configures the portal for
Straalfors, must provide this identifier

CertificateThumbprint Enter the thumbprint that identifies the

Strålfors certificate.

SecurityProtocol Tls The security protocol to be used when

communicating with Strålfors. Strålfors

determines which security protocol to use.

The default value is Tls (TLS 1.0).

If you run Microsoft Windows Server 2012 R2,

you can set it to Tls12 (TLS 1.2).

If you run Microsoft Windows Server 2008 R2,

it is possible to set this to Tls12 (TLS 1.2), but

it requires an additional configuration. See

the Microsoft article TLS/SSL Settings for

more information.

Note: The setting is case sensitive and

must be written as Tls.

MaxDocumentSize 50000000 (50
megabytes)

The maximum number of bytes that a

message for remote print can contain.

Messages that exceed this limit will not be
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Name Default setting Description

sent for remote print. The default value is

50000000 (50 Mb).

Note: Unless otherwise communicated, it

is recommended to keep the values

provided at the installation.

StraalforsResponseThreshold -1 Defines the maximum time that SmartPost

expects that it takes to send a message to

Strålfors. This value is used to calculate the

deadline (supervised by the deadline

monitor). The value is an integer, which (if

positive) specifies the threshold in seconds. If

the value is zero or negative, SmartPost uses

a more advanced algorithm to determine the

deadline, which depends on the weekday, the

type of letter, and the time of the day. If no

value is specified, the advanced algorithm is

used.

Note: Normally, the default setting is

used.

If the communication with Strålfors is very

slow, you can specify a high value. In test

scenarios, you can set the threshold to a low

value (but not zero), which means that the

deadline will be quickly exceeded .

SenderName The name of the company that is used in the
postal address. The postal address is used
when Strålfors produces the letters. The
value should be taken from the address on
which the authority will receive postal letters
and returned mails.
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Local print

The settings below apply to the LocalPrint dispatcher type.

Name Default
setting

Description

LocalPrintResponseThreshold 1800 Defines the maximum time that SmartPost expects

that it takes for local print to process a message. This

value is used to calculate the deadline (supervised by

the deadline monitor). Specify the threshold in number

of seconds. The default value is 1800 seconds (30

minutes).

Note: The default value is most often used.

SenderName Not used.

11.9 The E-boks Materials Module

The e-Boks Materials module is used to set up e-Boks materials that are used in the

SmartPost process. An e-Boks material is a configurable item in e-Boks, which

describes what to be communicated to the end user.

Prerequisite: You need to create e-Boks materials in e-Boks first and get the e-

Boks IDs. See Configure e-Boks materials in the WorkZone Process Administrator's

Guide.

Name The name of the material.

E-Boks ID The identifier of the material that the organization has created in the e-Boks

Administration Portal.
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Replyable Select this check box to indicate whether the material is replyable. You

selection must correspond to the e-Boks material setup in the e-Boks

Administration Portal. If the organization has configured the e-Boks

material as replyable in the e-Boks Administration Portal, you need to

select this check box. The material determines whether the user can reply

to a message.

Order The order in which the materials will be shown in the E-boks material field

in the Send SmartPost dialog box.

Note: You can set up which material to show by default in the

DefaultMaterialID setting. Click Operations > Processes, and then

select the SmartPost process. The SmartPost Settings are shown in

the lower right corner.

Localized names

Text The name of the material that is shown in the Send SmartPost dialog box.

Culture The display language.

Source The current language code (i.e. default language).

11.10 The Remote Print Types Module

In the Remote Print Type module, you can set up remote print types, which are used by

the SmartPost package in WorkZone Process. Each remote print type defines how

Strålfors, the remote print service provider, handles and prints SmartPost messages. The

remote print types are displayed in the Remote print type field in the Send SmartPost

dialog box in WorkZone Client. See also Configure remote print types in the WorkZone

Process Administrator's Guide.

Note: You can set up which remote print type to be displayed by default in the

DefaultRemotePrintypelID setting under Operations > Settings. See .

187

http://help.workzone.kmd.dk/wzp/2020_1/InstallGuide/#SmartPost/SmartPost_Configure_Remote_Print_Types.htm%3FTocPath%3DSmartPost%2520package|Configure%2520SmartPost%2520%2520for%2520sending%2520messages|_____3


WorkZone Configuration Management 2021.1

Cell Description
ID An identifier of the remote print type. The ID is generated automatically.

You need this ID to specify which remote print type to use as default. See

setting in the process settings.

Name Enter a descriptive name for the remote print type. The name will be shown

on the Remote print type list in the SmartPost dialog box.

Postage
category

Specify the postage category.

Returned
Letter
Handling

Specifies how Strålfors handles letters that are returned to Strålfors in case

PostNord has not been able to deliver the letter. If you select true,

Strålfors destroys the letter. If you select false, Strålfors performs no

action.

Urgency Level Specify the level of urgency.

Simple/Duplex Specify whether to print the letter single-sided or double-sided.

Print Color Specify black/white or color print.

Envelope Type Specify the size of the envelope.

Order The order in whichthe remote print types will be shown in the Remote

print type field in the Send SmartPost dialog box.

Access Code Enter an access code if different authorities want to use different remote

print types.

11.11 The Dispatch Sequences module

The Dispatch Sequencesmodule is used to create and configure dispatch sequences

in theSmartPostprocess. A dispatch sequence is a prioritized set of dispatchers that

theSmartPostuser can select in theSend SmartPost dialog box. See also Configure

dispatch sequences in the WorkZone Process Administrator's Guide.

ID The identifier of the dispatch sequence.

Name The name of the dispatch sequence.

Order The order in which the dispatch sequences will be shown in the Dispatch

sequence field in the Send SmartPost dialog box.
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Note: You can select which dispatch sequence to display by default in

theDefaultDispatcherSequenceId setting under Operations >

SmartPost Settings.

Access code Enter an access code if other authorities want different dispatch sequences.

Localized names

Text The name of the dispatch sequence that is displayed in the Send SmartPost

dialog box.

Culture The display language.

Source The current language code (i.e. default language).

Dispatch type order

Dispatch Order The prioritized order of the dispatchers that defines the dispatch sequence.

Dispatcher The dispatcher.

11.12 The Record Access Module

The Record Access module manages access to records. Record Access is used for

defining default values for record access. The purpose of the Record Access module is:

l Based on the role of the contacts attached to documents, you can define which

parties by default are granted record access.

l Based on the document group registered on the document, you can define which

documents by default are open for record access.

Roles

The roles are custom labels for contacts attached to documents. The roles must preexist

in the Custom Labelmodule, domain AP, Document contacts.
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In the Record Access module, you can exclusively register default access for contacts

attached to documents. You can make this function work for contacts attached to cases

as well. To accomplish this you must create identical roles both for contacts attached to

documents and for contacts attached to cases.

If the role "Complainant" by default is to grant record access for contacts attached to

documents as well as for contacts attached to cases, you must create the role

"Complainant" both as a label belonging to label type AP and as a label belonging to SP.

Document groups

The document groups employed must be registered in module Custom Domain as a

value in domain type AG.

Prerequisites for managing Record Access

The prerequisite for gaining access to the Record Access module is the access code

PROFILADM.

Click Operation> Record Access to open the module.

11.12.1 Record access meta data

In the table below describes the record access meta data:

Cell Description

Custom

Label

The contents of the cells in this column displays the values registered for label type

AP in Custom Label module.

Access

Right

The cells in this column contain check boxes. When a box is selected, the access

right is granted for the role selected, that is contacts with the selected role.

Record

Group

The content of the cells in this column displays the values registered for domain type

AG in the Custom Domainmodule.

Access

Right

The cells in this column contain check boxes. When a box is selected, the access

right is granted for the selected document group, that is documents with the selected

document group.
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11.12.2 Create record access

You can define defaults for record access based on contact roles and/or document types.

grant default record access to roles

Example

An organization receives and handles complaints. The parties are registered on the cases

and documents by the roles they play such as Complainant, Defendant, and so on. By

default parties with these two roles must be granted record access.

1. Click Operation> Record Access.

2. Find the role you want to grant default record access in the Custom Label

column.

3. Select the check box in the Access Right column in the same row.

4. Click Database > Save. The custom label is granted default records access.

Repeat the steps 2 to 4 to grant access to more roles.

grant default record access to document groups

Example

An organization wants default record access to be given to documents with document

group "Complaint" and "Decision".

1. Click Operation> Record Access.

2. Find the Record Group (i.e. document types) you want to grant default

records access in the Record group column.

3. Select the check box in the Access Right column in the same row.

4. Click Database > Save. The record group is granted default records access.

Repeat the steps 2 to 4 to grant access to more roles.
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11.12.3 Disable record access

You can disable the default record access grants for both roles (Custom Label) and

document groups (Record Group). The procedure for disabling the grants are the same

for both roles and document groups.

disable default record access

1. Click Operation> Record Access.

2. Find the item for which you want to disable default record access.

3. Clear the check box.

4. Click Database > Save. Default records access has now been disabled for

this item. Repeat the steps 2 to 4 to disable more items.

11.13 The External Sources Module

The module External Sources manages integrations between Captia Web Client and

external systems, for instance, a service that delivers external data from an external

source such as a civil registration system - in Denmark such as the CPR register.

To ensure an integration the following conditions must be met:

l The integration must be set up at the same time as the WorkZone Content

Server database is installed. Then basic data concerning the integration is

automatically entered into the database. Among other things this means that

relevant configuration information is displayed in the columnName and

Description of the External Sources module.

l The organizations that want to use Captia Web Client with an integration, for

example CPR, must have an agreement with the provider of the service. The

provider then supplies information regarding software and configuration. The

name of the software and the parameters of the configuration must then be

registered in the External Sources module.
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Prerequisites for managing External sources

The prerequisite for gaining access to the External sources module is the access code

DATAADM.

Click Operation> External Sources to open the module.

External sources - save parameters

In External Sources module you must register the name of the program that provides

the service of the integration and the parameters required for the configuration of the

integration.

configure a CPR service

1. Click Operations > External Sources.

2. Select the relevant row. In this example, it is the row with CPR in the Name

column and Personer (individuals from the CPR register) in the Description

column.

3. Fill in the cell in the Program ID column - in this example this should be:

sjCPRDRIVER.person

4. Fill in the cell in the column Parameters - in this example this should be: IP=

5. Click in any adjacent cell followed by a click on Database > Save.

11.14 The Service Channels Module

The Service Channels module manages services such as mail import, file import and

server scanning.

Click Operation> Service Channels to open the Service Channels module.
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11.14.1 About service channels

Prerequisites for managing Service channels

The prerequisite for gaining access to the Service Channels module is the access code

DATAADM.

Purpose of the Service Channels module

The purpose of the Service Channels module is to be a general tool for monitoring and

importing of data for Captia Web Client.

Example

If, for example, all incoming letters are scanned into a special folder, the Service

Channels module transfers the scanned letters to Captia Web Client.

As an integrated part of the scanning process, you can use separator sheets. They can

contain information about the letters being scanned. The Service Channels' service will

try to interpret and process this information, attaching it to the letters as meta data.

When the Captia Web Client users open the Scanned today fixed list, the items

displayed are the result of the Service Channels module.

NT-service

Connected to the Service Channels is an NT-service named

Scanjour.Services.Service. It can be configured to support a number of tasks. Its

own task is to support regular planned execution of a number of tasks for one or more

service channels.

Channels

A channel has a number of plug-ins. They are constructed to allow the channel to

perform specific tasks such as monitoring the appearance of:
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l new items, i.e. files in a folder,

l new mails in a mail account, or

l new items in a register in a database.

Plug ins

The number of plug-ins, which a channel needs, to perform its task may vary between 1 to

4. Each plug-in performs a well defined task which can be used by other channels as well.

The NT-service can be installed several times with its own unique ID number.

Configuration of the channel is done in WorkZone Configuration Management. By stating

the service ID for each channel, it is possible to make one service execute all channels or

only one channel.

You can have the following plug ins:

l Awatch-pluginmonitoring and examining new items.

l A data provider plugin that can process and format new data in such a way,

that they can be used in the plug ins mentioned below.

l Ametadata provider plugin that is able to deliver the necessary metadata (in

the correct format) based on data coming into the system.

l A data consumer plugin that can handle transference of data to the database.

A channel can have one or more plug-ins - only the Watch-plugin is mandatory. The

result of the work of one plug-in is delivered to the next plug-in as raw material. Each

plug-in must control whether the input received is valid - if it is not, it must deliver an error

message.

The NT-service calls the plug ins defined for a channel in the following sequence:

1. watch,

2. data provider,
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3. metadata provider,

4. data consumer.

The following options depends on your configuration:

l The service ID for the service to execute the channel.

l How often the service is to watch for data - how many minutes should elapse

between each check.

l If the channel should be enabled or disabled.

11.14.2 Service channel meta data

Meta data for the columns in the upper right panel are described in the table below.

Meta data displayed in the columns of the other panels depends on which channel is

selected for display in the upper right panel. This meta data is explained in the following

configuration examples:

l
Configure file import

l
Configure mail import

l
Configure Serverscan

Meta data - upper right panel

Field Description

Channel

Number

Each channel must have a unique number. The number identifying the channel

is up to you as long as it is unique.

Service

Number

Several Channels can belong to the same service and have the same service

number. It is up to you to decide the number identifying each service.

Description Enter a short and precise description of the channel.

Scan

Interval

(minutes)

Period of time between each surveillance scan in minutes.
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Field Description

Enabled A selected check box indicates that the service channel is enabled.

Watch Class This cell contains a drop-down box with the following options:

l Scanjour.Services.DirectoryWatch

l Scanjour.Services.MailPop3Watch

Data

Provider

Class

This cell contains a drop-down box. Here you can select, for example

Scanjour.Services.MailDataProvider

Metadata

Provider

Class

This cell contains a drop-down box. Here you can select, for example:

l Scanjour.Services.MailMetaDataProvider or

l Scanjour.Services.FileMetaDataProvider

Data

Consumer

Class

This cell contains a drop-down box. Here you select, for example:

Scanjour.Services.XdiDataConsumer

Error Path Enter the error path, for example: C:\ServiceError\Channel1

Last Scan Time stamp displaying when the last scan was executed - automatically

updated by the system.

Server Server name is automatically inserted by the system.

Meta data - lower right panel

Field Description

Service Number The same as the number displayed in the Service Number column in

the upper right panel.

Queue Select the queue which the Service Channel must use. In the drop-

down box, you have the following options: Blank, 1, 2, 3, 4 or 5.

Technical information, see - Service queue - technical note.

Service Name The Service Name is made up of 4 parts:

l The name of the service
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l The service number

l The name of the WorkZone database

l The queue number

Status Status can be Starting, Started, Stopping or Stopped.

If necessary, click the Update button to update status information.

Logon as The drop-down box of this field contains two options: Local System

and User.

Buttons - lower right panel

Button Function

Update Updates the content of the Status field. Here you can see if the service, for

instance, has started or stopped.

Install Installs the service in the operating system.

When you have installed the service, it can be displayed in the list of services with

Control Panel Administrative Tools Services.

Note: You can start or stop a service from the Control Panel. However, you can

neither install nor uninstall a service from the Control Panel.

Start Starts the service in the operating system.

Instead you can choose to start the service by means of Control Panel

Administrative Tools Services.

Stop Stops the service in the operating system.

Instead you can choose to stop the service by means of Control Panel

Administrative Tools Services.

Uninstall Uninstalls the service in the operating system.

When you uninstall a service, it is automatically removed for the list of services

normally displayed with Control Panel Administrative Tools Services.

Note: You can start or stop a service from the Control Panel. However, you can

neither install nor uninstall a service from the Control Panel.
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11.14.3 Mode of operation

1. Plug ins First you must import the Plug in Assemblies. They are

contained in type DLL files. There are two Plug in

Assemblies which are part of the default program:

l Scanjour.Services.Plugins.dll

A plugin performs a specific task. The following types of

plug ins can be contained in a plugin assembly:

l A watch-pluginmonitoring and examining for

new items.

l A data provider plugin that can process and

format new data in such a way, that they can be

used in the plug ins mentioned below.

l A metadata provider plugin that is able to

deliver the necessary meta data (in the correct

format) based on data coming into the system.

l A data consumer plugin that can handle

transference of data to the database.

Import of Plug in Assemblies - see Import plug-in

Assemblies.

2. Channels When you have imported the plug-in assemblies you must

configure the channels. A channel must have some plug ins.

They enable the channel to perform a specific task, for

instance, monitoring instances of new files in a folder - for

example, today's scanned letters.

To configuring the channels you must:

l give a short description of the task of channel, for

example, Serverscan.

l enter what plug-ins the channel must employ.

l enter the path to the folder where error messages
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must be delivered.

A channel can have one or more plug ins - only the Watch

plugin is mandatory. The result of the work of a plug-in is

delivered to the next plug-in as raw material. Each plug-in

must check that the input received is valid. If not, it must

deliver an error message.

Configuration of channels - see Configure service channels.

3. Services When you have finished configuring all the channels, you

must install and start the services that the channels are

using.

When you have installed a service, you can find it in the list

of services of the operating system - Control Panel >

Administrative Tools > Services.

You must enter whether the service should log on as

l Local System - for example, Configure file

import, or

l User.

You can specify whether the service is to use a Queue or

not. If the service operates channels loading large amounts

of mails or documents, choosing a specific queue can be an

advantage.

If no queue is selected, you may risk that free text indexing

of documents, cases, document meta data registered by the

current Captia Web Client users is blocked.

11.14.4 About the interface

The Service Channels module consists of 4 panels.
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Panel 1 The panel is a sheet. Each row can contain one et plug-in assembly. Plug-in
assemblies are DLL files that must be imported one by one. When they have been
imported, they are displayed as separate rows in this panel.

Panel 2 The panel displays information about the service that operates the channel, which is in
focus in panel 3.

Panel 3 Channel definitions for Scanjour Services. The panel contains fields and buttons
for setting up the channels.

Panel 4 Plugin settings for channel n. The content of the panel depends on which channel
is in focus in panel 3.

11.14.5 Import plug-in assemblies

In order to be able to create and configure service channels, you must import the

necessary plug- in assemblies.

The default plug in-assembly is called Scanjour.Services.Plugins.dll. It contains a

number of different plug ins such as:

l Scanjour.services.DirectoryWatch

l Scanjour.services.MailPop3Watch

l Scanjour.services.MailDataProvider

l Scanjour.services.MailMetaDataProvider

l Scanjour.services.FileMetaDataProvider

l Scanjour.services.XdiDataConsumer
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import

1. Click Operation> Service Channels.

2. Click File > Import. The Open dialog is displayed.

3. Find the files. By default they are located in the KMD program folder.

4. Click the DLL you want to import.

5. Click Open . The file is imported.

Use the same procedure to import the other DLLs.

11.14.6 Configure service channels

This section describes how to configure different service channels.

Configure file import

Important: Configuration of file import without eDeliverynote.

Prerequisite

The prerequisite for this procedure is that the relevant plug-in assemblies have already

been imported.

Note: All path descriptions are merely suggestions. They can be altered in the

actual configuration.

It is possible to import one or more files from a folder. For that purpose use the

following configuration:

configure file import

1. Click Operation> Service Channels. The Service Channels module

displays.
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2. Click in the first data cell in an empty row in the upper right panel - Channel

definitions for ScanJour Services and enter the following values:

Column Enter this value

Channel Number 5

Service Number 2 - here is used the same service as for Serverscan.

Description Simple File Import

Scan Intervals 5

Enabled Click in the check box to enable the current channel.

Watch Class Select Scanjour.Services.DirectoryWatch in the drop-down box.

MetaDataProvider

Class

Select Scanjour.Services.FileMetaDataProvider in the drop-down

box.

Data Consumer Class Select Scanjour.Services.XdiDataConsumer in the drop-down box.

Error Path Enter this path C:\ServiceError\Channel 5

3. Place the cursor in another cell and click Database > Save.

4. Click the left most cell of the row you just saved. Now the bottom right panel is

activated. Information concerning plug-in parameters can be registered here in

the panel named Plugin settings for channel 5.

5. Enter the following values:

Column Enter this value

DirectoryWatch monitored

folder

<path> - for example C:\FileImport

DirectoryWatch Folder

mask

*.imp

FileMetaDataProvider

Metadata XML template

<path> - for example C:\Program

Files\KMD\WorkZone\Program\XdiData\SjFesdPacket.xml

FileMetaDataProvider

Organizational Unit

(If wanted - sjKomm compatible)
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Column Enter this value

FileMetaDataProvider

Dokumenttype

(If wanted - sjKomm compatible)

FileMetaDataProvider

Dokumentgruppe

(If wanted - sjKomm compatible)

FileMetaDataProvider

Access code

XdiDataConsumer XML

Scheme folder

<path> - for example, C:\Program

Files\KMD\WorkZone\Program\XdiData

6. Place the cursor in another cell and click Database Save.

The information has been saved.

Installing and starting the service

In the lower left panel, you can now install and start the service. The service must be

started as Local System.

Configure mail import

The prerequisite for this procedure is that the relevant plugin assemblies have already

been imported.

Note: All path descriptions are merely suggestions. They can be altered in the

actual configuration.

It is possible to import mails. For that purpose use the following configuration:

1. Click Operation> Service Channels. The Service Channels module is

displayed.

2. Click in the first data cell in an empty row in the upper right panel - Channel

definitions for ScanJour Services and enter the following data:
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Column Enter this value

Channel Number 4

Service Number 2 - here is used the same service as for Serverscan.

Description Simple Mail Import

Scan Intervals 5

Enabled Click in the check box to enable the current channel.

Watch Class Select Scanjour.Services.MailPop3Watch in the drop-down

box.

DataProvider Class Select Scanjour.Services.MailDataProvider in the drop-

down box.

MetaDataProvider

Class

Select Scanjour.Services.MailMetaDataProvider in the

drop-down box.

Data Consumer

Assembly

Select Scanjour.Services.Plugins in the drop-down box.

Data Consumer Class Select Scanjour.Services.XdiDataConsumer in the drop-

down box.

Error Path Enter the following path: C:\ServiceError\Channel 4

3. Place the cursor in another cell and click Database Save.

The information has been saved.

4. Click the left most cell of the row you just saved.

Now the bottom right panel is activated. Information concerning plugin

parameters can be registered here - the panel named Plugin settings for

channel 4.

5. Enter the following values:

Column Enter this value

MailPop3Watch Mail

server Name

<servername> -e.g.postman.KMD.dk

MailPop3Watch 110 - default pop3 port
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Column Enter this value

Server port

MailPop3Watch user

name

<user> - mail account to watch

MailPop3Watch user

password

<password>

MailPop3Watch Mail

folder

<path> - for example, C:\ServerMail

MailDataProvider

Mail folder

<path> - for example, C:\ServerMail\Mail

MailMetaDataProvid

er Metadata XML

template

<path> - for example C:\Program

Files\KMD\WorkZone\IIS\WorkZone\App\Captia\SjFesdPacket

.xml

MailMetaDataProvid

er organizational

unit

(If wanted - sjKomm compatible)

MailMetaDataProvid

er document type

(If wanted - sjKomm compatible)

MailMetaDataProvid

er document group

(If wanted - sjKomm compatible)

MailMetaDataProvid

er access code

XDIDataConsumer

XML scheme folder

<path> - for example, C:\Program

Files\KMD\WorkZone\Program\XDIData

6. Place the cursor in another cell and click Database > Save.

Install and start the service

In the lower left panel you can now install and start the service. The service must be

started as Local System.
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Configure Serverscan

The prerequisite for this description is that the relevant plug-in assemblies have already

been imported.

Note: All path descriptions are suggestions. You can change them in the actual

configuration.

1. Click Operation> Service Channels. The Service Channels module

displays.

2. Click in the first data cell in an empty row in the upper right panel - Channel

definitions for ScanJour Services and enter the following values:

Column Enter this value

Channel Number 2

Service Number 2

Description Serverscan

Scan Intervals 1

Enabled Click in the check box to enable the current channel.

Watch Class Select Scanjour.Services.DirectoryWatch in the drop-down box.

Data Consumer

Class

Select Scanjour.Services.XdiDataConsumer in the drop-down box.

Error Path Enter the following path: C:\ServiceError\Channel 2

3. Place the cursor in another cell and click Database > Save.

The information has been saved.

4. Click the left most cell of the row you just saved - the cell to the left of Channel

Number. Now the bottom right panel is activated. You can register information

about plugin parameters here - the panel is named Plugin settings for

channel 2.

5. Enter the following values:

207



WorkZone Configuration Management 2021.1

Column Enter this value

DirectoryWatch monitored

folder

C:\XDIPORT

Direct oryWatch Folder mask *.xdi

XdiDataConsumer XMLscheme

folder

C:\Program Files

(x86)\KMD\WorkZone\Program\XDIData

6. Place the cursor in another cell and click Database > Save.

Installing and starting the service

In the lower left panel you can now install and start the service. The service must be

started as Local System.

Service queue - technical note

The WorkZone database has a register service_queue which is used to control the tasks

the agents perform.

The following agents may exist in a Captia Web Client installation:

AgentFIX Responsible for the free text indexing of

documents and records.

AgentOCR Responsible for producing a textual version of

tiff documents.

AgentSUB Responsible for publishing documents.

Scanjour.Service Responsible for scanning documents, importing

files and mails into the WorkZone system.

When a document is imported into Captia Web Client, a job is either queued for the OCR

agent to produce an OCR version of the document or a job is queued for the FIX agent

requesting the document to be indexed. When cases and records are created in the

database, a job to index these is also queued for the FIX agent.
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When the Scanjour.Service is used to import documents or mails, these types of jobs are

also queued for the agents. To avoid that the scanned documents block the agents' work,

initiated by interactive users of Captia Web Client, the database implements a number of

tables used by the service_queue. The actual table used depends on the user. In the

system 5 users are special because they see a table in a different schema:

User Schema and table

Normal users sjsysadm.service_queue

sjserviceagentuser sjsysadm.service_queue

sjserviceagentuser1 sjserviceagentuser1.service_queue

sjserviceagentuser2 sjserviceagentuser2.service_queue

sjserviceagentuser3 sjserviceagentuser3.service_queue

sjserviceagentuser4 sjserviceagentuser4.service_queue

sjserviceagentuser5 sjserviceagentuser5.service_queue

It is possible to start the agents (except AgentSUB) under a special user, the /queue=n

(n>=1, n<=5) controls which of the 5 special users above is used, when the agent calls

SOM. If no queue is specified, the sjserviceagentuser will be used as default.

The documents inserted into the database will result in new jobs for the OCR or FIX agent -

these jobs will end up in sjserviceagentuser1.service_queue. This queue requires that FIX

and OCR using queue=1 (and running under sjserviceagentuser1) are installed and

running, because these agents will be the only ones able to see the table

sjserviceagentuser1.service_queue.

Other scanners or mail importers using Scanjour.Service may be set up to use other

queues which will prevent them from blocking the work of each other (and the interactive

Captia Web Client users work as well).
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12. The Options Module
The Options module manages a number of possibilities for configuring WorkZone

Configuration Management with regard to, for example, language, warnings, and so on.

Prerequisites for managing Options

The prerequisite for gaining access to the Options module is the access code

DATAADM.

Click Options and then select an options sub module, for example Languages.

12.1 Select user interface language 210

12.2 Configure gridviews 211

12.3 Configure warnings 212

12.4 Configure display of custom labels 214

12.5 Configure display of custom domain 214

12.1 Select user interface language

The purpose of the Languagemodule is to configure the user interface according to

language. You can choose to configure the following two options:

l Select language mode - select one of the following:

l Show all - Multi language mode. Data in all implemented languages is

displayed.

l Show current - Single language mode. Only data in the language

selected as current language is displayed.

l Select current language - in this field you must select the culture code of the

language to be the default language of the WorkZone Configuration

Management user interface.
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select language mode

1. Click Options > Language.

2. In the Select language mode field, select the relevant language mode -

Show all or Show current from the list.

3. Click OK. If a module is open, it is automatically closed. The language mode

selected now has been chosen for the WorkZone Configuration Management

user interface as a whole.

How to select current language

1. Click Options > Language.

2. In the Select current language field, select the culture code of the language

to be default language.

3. Click OK.

See also Language mode.

12.2 Configure gridviews

The purpose of the Gridviews Options is a way to limit the number of displayed items

and thereby increase performance and reduce waiting.

When you, for example, search the use log you may risk that the system finds an

excessive amount of items. It takes long time to fetch and load this amount of items into

the module. To avoid this, you can set up how many items should be fetched at a time.

After examining the first set of items, you can go to the next set, and so on.
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The grid view is by default set to 2000. In the Number of records in gridview field in

the GridViewOption dialog box, the default value is 2000__ , that is two thousand

succeeded by two underscore characters, in all 6 characters.

The field must always contain 6 characters. If you, for example, want to set the number

to 350 it must be entered as 350___ , that is three hundred and fifty followed by three

underscore characters.

Configure the gridview

1. Click Options > Gridviews.

2. The contents of the Number of records in gridview field is by default

2000__. If you want to change the value to 350, it must be entered as 350__

_.

3. Click OK.

12.3 Configure warnings

The purpose of the Warnings sub module is to configure the extend of warnings and

the level of sensitivity. Here you can set up the following warnings:

l Warn about a search when the number of rows exceeds a certain number

l Warn about resetting the IIS when the register security is changed.

l Warn about disabling the register protection.

l Sound an acoustic alarm on error.

Open the Warnings form

1. Click Options >Warnings.

2. Click OK to save settings and close the dialog.
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Warning about number of search results exceeds a certain number

If the check box is selected, you set up the system to warn you when the number of rows

retrieved exceeds a reasonable number. You define how many is a reasonable number. If a

warning should be given at, for instance, 500 it must be entered like this: 500___ = five

hundred followed by three underscores. The field must always contain 6 characters.

Example

You want to see post codes of Germany. This means that several thousand post codes

must be retrieved. By default the system will issue a warning, when the number of rows

exceed 1000. A warning is issued:

"The selection returned 1255 rows. It may take a long time to load the rows. Do you really

want to load the rows?".

To avoid waiting use the Gridviews sub module to divide the data into manageable

sections - see Options - Gridviews.

Warning about resetting the IIS when the register security is changed

When changes have been made to the configuration of register security in Register

Security module, the IIS Admin service on the server must be restarted. If the check box

is selected, a warning is issued in this situation. The check box is selected by default.

Warning about disabling the register protection

In special situations users must log on to the WorkZone Configuration Management with

register security disabled.

If the check box is selected, a warning is issued in this situation. The check box is selected

by default.
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Sounding an acoustic alarm on error

An acoustic alarm can be started when an error occurs. If the check box is selected, an

acoustic warning is issued when errors occur. The check box is selected by default.

12.4 Configure display of custom labels

The purpose of the Custom Label Options form is that you can choose what the

module displays.

The configuration you select here only applies to the WorkZone Configuration

Management.

Note: The Custom Labelmodule must be active to be able to select Custom

Label under Options.

Change configuration

1. Click Basic Data > Custom Label.

2. Click Options > Custom Label to open the Custom Label Options form.

3. Select an option:

l Show All - All values are displayed.

l Show Active - Only values without an end date are displayed.

4. Click OK.

12.5 Configure display of custom domain

The purpose of the Custom Domain Options form is that you can chose what the

module displays.
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The configuration you choose here only applies to the WorkZone Configuration

Management.

Note: The Custom Domain module must be active before you can select the Custom

Domain under Options.

Change configuration

1. Click Basic Data > Custom Domain.

2. Click Options > Custom Domain to open the Custom Domain Options

form.

3. Select an option:

l Show All - All values are displayed.

l Show Active - Only values without an end date are displayed.

4. Click the OK .
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13. Technical notes
Some topics contain links to technical notes. They are only supplied where necessary.

The target audience for this type of information is technicians.

l
Service Channels, queue

13.1 Service queue - technical note

The WorkZone database has a register service_queue which is used to control the tasks

the agents perform.

The following agents may exist in a Captia Web Client installation:

AgentFIX Responsible for the free text indexing of

documents and records.

AgentOCR Responsible for producing a textual version of

tiff documents.

AgentSUB Responsible for publishing documents.

Scanjour.Service Responsible for scanning documents, importing

files and mails into the WorkZone system.

When a document is imported into Captia Web Client, a job is either queued for the OCR

agent to produce an OCR version of the document or a job is queued for the FIX agent

requesting the document to be indexed. When cases and records are created in the

database, a job to index these is also queued for the FIX agent.

When the Scanjour.Service is used to import documents or mails, these types of jobs

are also queued for the agents. To avoid that the scanned documents block the agents'

work, initiated by interactive users of Captia Web Client, the database implements a

number of tables used by the service_queue. The actual table used depends on the

user. In the system 5 users are special because they see a table in a different schema:
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User Schema and table

Normal users sjsysadm.service_queue

sjserviceagentuser sjsysadm.service_queue

sjserviceagentuser1 sjserviceagentuser1.service_queue

sjserviceagentuser2 sjserviceagentuser2.service_queue

sjserviceagentuser3 sjserviceagentuser3.service_queue

sjserviceagentuser4 sjserviceagentuser4.service_queue

sjserviceagentuser5 sjserviceagentuser5.service_queue

It is possible to start the agents (except AgentSUB) under a special user, the /queue=n

(n>=1, n<=5) controls which of the 5 special users above is used, when the agent calls

SOM. If no queue is specified, the sjserviceagentuser will be used as default.

The documents inserted into the database will result in new jobs for the OCR or FIX agent -

these jobs will end up in sjserviceagentuser1.service_queue. This queue requires that FIX

and OCR using queue=1 (and running under sjserviceagentuser1) are installed and

running, because these agents will be the only ones able to see the table

sjserviceagentuser1.service_queue.

Other scanners or mail importers using Scanjour.Service may be set up to use other

queues which will prevent them from blocking the work of each other (and the interactive

Captia Web Client users work as well).
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14. Terms and conditions

Intellectual property rights

This document is the property of KMD. The data contained herein, in whole or in part,

may not be duplicated, used or disclosed outside the recipient for any purpose other

than to conduct business and technical evaluation provided that this is approved by

KMD according to the agreement between KMD and the recipient. This restriction does

not limit the recipient’s right to use information contained in the data if it is obtained

from another source without restriction set out in the agreement between KMD and the

recipient or by law.

Disclaimer

This document is intended for informational purposes only. Any information herein is

believed to be reliable. However, KMD assumes no responsibility for the accuracy of the

information. KMD reserves the right to change the document and the products

described without notice. KMD and the authors disclaim any and all liabilities.

Copyright © KMD A/S 2021. All rights reserved.
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