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WorkZone Configuration Man-
agement 2021.2 Online Help

This Online Help describes how to configure WorkZone Content Server, WorkZone Client,
Captia Web Client, and WorkZone Explorer using WorkZone Configuration Management.

The intended target audience for this guide is system administrators who configure and
maintain the basic data, which makes up the foundation for working with WorkZone Con-
tent Server, WorkZone Client, Captia Web Client, and WorkZone Explorer.

WorkZone links

WorkZone documentation

WorkZone support

« WorkZone website

o WorkZone portal



https://docs.workzone.kmd.net/
http://support.kmd.dk/
https://www.kmd.dk/loesninger-og-services/loesninger/enterprise-information-management
https://workzone.kmd.net/

Online Help

What's new

WorkZone Configuration Management 2021.2
No changes in this release.
WorkZone Configuration Management 2021.1
No changes in this release.
WorkZone Configuration Management 2021.0
No changes in this release.
WorkZone Configuration Management 2020.3
No changes in this release.
WorkZone Configuration Management 2020.2
No changes in this release.
WorkZone Configuration Management 2020.1
No changes in this release.
WorkZone Configuration Management 2020.0

All Use Log functionality has been moved from WorkZone Configuration Management to
WorkZone Configurator.

For more information, see The Use Log

USELOGADM and USERADM access code changes

The USERADM access code is now required to access, search and view the Use Log mod-
ule and the USELOGADM access code is required to start and stop the Use Log. This
change affects all methods of accessing the Use Log (either through WorkZone Configurator
or the ODATA interface.

WorkZone Content Server 2019.3

USELOGADM and USERADM access code changes

The USERADM access code is required to see the Use Log menu in WorkZone Con-
figuration Management. Both the USERADM and the USELOGADM access code are


http://help.workzone.kmd.dk/wzcnf/2020_0/WZConfigurator/#Logs/Use_log_settings.htm

WorkZone Configuration Management 2021.2

required for a user to access, search and view the Use Log module as well as start and

stop the Use Log.

The USELOGADM access code also grants access to the Use Log through the ODATA
interface.

WorkZone Configuration Management 2019.2

No changes in this release.

WorkZone Configuration Management 2019.1

No changes in this release.

WorkZone Configuration Management 2019.0

No changes in this release.

WorkZone Configuration Management 2018.2

No changes in this release.

WorkZone Configuration Management 2018.1

No changes in this release.

WorkZone Configuration Management 2018.0

« Topics that describe general WorkZone Process settings and settings that apply

to the SmartPost process have been revised. Dispatcher settings that were pre-
viously part of the Process settings have been split in to specific dispatcher types
(e-Boks, Straalfors, and local print) and moved to a new Dispatcher module. See
The Process Dispatchers Module.

The Lost and Found module has been removed from the Diagnostics module and
replaced with new Dashboard lists (Hidden cases, Hidden documents and Hid-
den contacts) in the WorkZone Client and a new Hidden Elements (da. Skjulte
Elementer) menu in the Captia Web Client. The new lists and menu enable a
user to find hidden WorkZone cases, documents and contacts. Only users with
the "™ System Access code can see hidden cases, documents or contacts. A new
WorkZone LOSTANDFOUND system access code has been introduced which
enables users to access to the Hidden Elements (da. Skjulte Elementer) menu
in the Captia Web Client.

WorkZone Configuration Management 2017
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Operation module

« The Document Formats module has been removed and will be replaced by a new
Documents Formats module in the new WorkZone Configuration Management.

Classification Scheme module

« lItis now possible to select @Unit in the Responsible OU and Executing OU fields,
which applies the unit of the current user who creates cases in the specific case
class. Likewise, you can now select @Me in the Case Handler field to apply the cur-
rent user who creates the case in the specific case class as case handler. See Clas-
sification scheme meta data.

o @Unit is now applied by default to the Responsible OU field on the SJ-TEMP class.

Basic Data module

« You can now create corporate access codes from this module, which you can then
apply to file classes or contacts, see Create Corporate Access Codes.

WorkZone Configuration Management 2016 R2

« The format of the search criteria that is shown in the Search XML column in the use
log has been simplified, see .

WorkZone Configuration Management 2016

o Improvements to the Use Log module

« Two new sections have been added to the Use Log module. Info, which dis-
plays information about the use log, see . Transfer job status, which shows the
status of the job that transfers the current use logs to the monthly use log, see .

« The use log has been extended to show when users create, update, or search
for documents. This is indicated by | (insert) , U (update), or S (search) in the
Action column and #document in the Register column of the log. See .

« The setup and maintenance of use log tables have been changed to increase
performance. See .

11
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o A new system owned class SJ-AGENDA which is used by WorkZone Meeting
has been added. See Mandatory system owned classes.

WorkZone Configuration Management 2014 R2
No changes in this release.

WorkZone Configuration Management 2014

« The Online Help for WorkZone Configuration Management is now available
online on WorkZone Documentation web site. You can also access it directly from
WorkZone Configuration Management.

« Itis now possible to assign universal access codes to users from the Users mod-
ule, see Users meta data.

« A new section on parallel case creation has been added to the About case num-
ber formats topic.

12
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Getting Started

WorkZone Configuration Management is a configuration tool that system administrators use to
configure and maintain basic data that makes up the foundation for working with WorkZone
Content Server and the various WorkZone clients.

WorkZone Configuration Management consists of several modules. Each module gives
access to a specific part of the basic data or configuration options.

Who is allowed to do what ?

To gain access to a specific module, you need adequate authorization, which means that your
user profile must contain the system access code corresponding to the access code of the
modules. See Access codes.

Configuring Configuration Management

You can configure WorkZone Configuration Management to handle either a single language
or several languages. See Language mode.

Modules in WorkZone Configuration Management

The table below displays the names of the modules and the data types, which are maintained
in them.

Basic data

Module Data Type

Countries and
postcodes

Countries and post codes

Custom label Labels

Custom domain Domains and their values

13
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Filing periods Preservation and disposal codes
Contact Contact types

Stopwords Words to be disregarded in searches
The Terms Mod- .

Ule Tool for the KMD technicians only
Categories

Module Data Type

Classification Scheme The classification scheme

Facet-based classification scheme Facets

Dictionary The dictionary containing keywords
Subnumbers Subnumbers
Security

Module Data Type

Register Security Security configuration for registers and tables

Diagnostic

Module Data Type

Diagnostic Module Read about:

o Trace Output
« Enable sjDebug Output

Operation

14
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Module Data Type
Owner Owner specific information and configuration
Users Users

Preference Pro-

: Profiles
files

Restricting Pro-

] Profiles
files

Record Access Default configuration of record access

External Sources Configuration of external integrations (third party programs or services)

. Configuration of data transfers (import of data from third parties or ser-
Service channels

vices)

Options

Language Current language and language mode
Gridviews Default displayed items

Warnings Extend of warnings and the level of sensitivity

Custom Label  Show all or only active items

Custom Domain Show all or only active items

15
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Prerequisites

This section describes the prerequisites for working with WorkZone Configuration Man-

agement.
Prerequisites OVerVIeW ... 16
Installation ... . . 16
AcCesSS COAeS ... ... ... 17
Profile .. 19
Language MoOde ... .. ..l 20

Prerequisites overview

To work in WorkZone Configuration Management, the following conditions must be in
place:

« WorkZone Configuration Management must be installed , see Installation.

« You must have the necessary authorization to open the WorkZone Configuration
Management modules. This authorization consists of a set of system access
codes assigned to you in Active Directory, see Access codes.

o You must be set up to work in Captia Web Client without the limitations of a pro-
file, see Profile.

« You can choose to work in either multi or single language mode, see Language
mode.

Installation

After installing WorkZone Configuration Management on the server, you need to install the
new version locally on your PC. When you open WorkZone Configuration Management,
you are prompted to install the new version of WorkZone Configuration Management on
your PC. The program file is called Scanjour.Sysadm.exe.

For more information, see Installation Guide for WorkZone Configuration Management.

16
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Access codes

WorkZone Configuration Management contains a number of modules. To gain access to a
specific module (and/or sub functions), your user profile must contain the corresponding
access codes.

Allocation and management of access codes is done through Active Directory. Below is a list
of the specific access codes:

Basic Data Access code

Countries and Postcodes DATAADM

Custom Label DATAADM
Custom Domain DATAADM
Filing Period DATAADM
Contact DATAADM
Stopwords DATAADM
Terms TERMSADM

Categories Access code

Classification Scheme DATAADM

Facet DATAADM
Dictionary DATAADM
Subnumbers DATAADM

Security Access code

Register Security DATAADM

17
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Process Log PROCESSADM
Process State PROCESSADM
Trace Output DIAGADM

Enable sjDebug Output No access code is needed.

Operation Access code
Owner USERADM
Users USERADM

Restricting Profiles PROFILADM

Preference Profiles PROFILADM

Processes PROCESSADM

Service Workflows PROCESSADM

Process Settings PROCESSADM

Process Dispatcher PROCESSADM

e-Boks Material PROCESSADM

Remote Print Types PROCESSADM

Dispatch Types PROCESSADM
Record Access PROFILADM
External Sources DATAADM
Service Channels DATAADM

Options Access code

Language DATAADM

18
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Options Access code
Gridviews DATAADM
Warnings DATAADM

Custom Label DATAADM

Custom Domain DATAADM

Profile

An important precondition for working in WorkZone Configuration Management is that your
administration user has no profile limitations. Working on the basis of a profile may mean that
you only see a limited part of the data contained in some of the modules.

The purpose of the profiles is that you only see the data that you actually use working in Cap-
tia Web Client. This, however, is not an efficient way of working in WorkZone Configuration
Management.

change your profile

You can find your profile in section 1 in Captia Web Client by selecting Functions > Select
profile. Section 1 is always visible on the Front page and your can change your profile
instantly.

Change your profile in Captia Web Client

1. Open Captia Web Client.

2. Insection 1, click Functions > Select profile. A dialog box opens with a list of pro-
files.

3. Click the profile named Standard No profile limitation. The dialog box closes.
You have chosen to work without the restrictions of a profile.

For more information on profiles, see Preference Profiles.

19
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Language mode

You can choose to employ either multi language mode or single language mode in your
installation. The choice depends on how many language groups (that is English speaking
and/or Danish speaking employees) your organization needs to accommodate.

Single language mode

If your organization is multinational, you can either choose single language mode, for
example English as the only language, or choose multi language mode, for example Dan-
ish as the default language but each employee has the option to switch to another lan-
guage in the clients (WorkZone Client or Captia Web Client).

Multi language mode

In multi language mode, the user interface will reflect the selected language and, for
example, labels, drop-down lists, and classification scheme will be displayed in that lan-
guage.

change the language mode

You can switch between multi language mode or single language mode. See Select user
interface language.

change current language in WorkZone Configuration Management

You can set the default language of WorkZone Configuration Management's user interface.
See Select user interface language.

change the default language of the Clients

20
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Here you decide which language should be the default language (i.e. group language) of
WorkZone Client and Captia Web Client.

If the language mode is set to multi language mode, the user is able to override the default
language by selecting another language. See Configure group Language.

See also Configure date pattern.
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Important notes on usage

Before you begin working with WorkZone Configuration Management, it is important to
note the following

Not all information can be deleted

All information cannot be deleted!. If it is possible to delete information, the module con-
tains a Delete button. However, some types of information may only be terminated, for
example, an end date that will become inactive in the client user interface.

Example of deletion, see Delete a country.

Example of termination, see Terminate domain type.

Example of deletion and termination, see Delete/terminate a label.

Some changes only take effect after a service has been reset

Some changes only take effect after a service has been reset.

Example, see Using custom domain/label.

Example, see About register security.

Example, see Configure warnings.

The resetting may be a scheduled task that is performed at regular intervals, however it can
be done manually.

Logon to another database

WorkZone Configuration Management logs on to one specific database by default. When
you install WorkZone Configuration Management, the default database of the URL from
which you initiated the installation is shown. The default database is automatically opened
when you start. However, you can log on to another database than the default database.

Be aware that the Logon dialog box is sensitive to whether the site is http or hitps.

22
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Log on to another database

1. Click Database > Logon.

2. Enterthe path of the database in the Database location field. Enter path:
<https://><host>

You only need to enter <https://> ifitis https. Hitp is standard and can be omit-
ted.

3. Click OK. The new default database is opened.

Tip:
If you want to log on to another database but the default database from the
beginning, you can press the Esc key right after clicking WorkZone Con-

figuration Management in the Windows Start menu, which opens the Logon
dialog box.

23
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Working with the user interface

This section describes how to use WorkZone Configuration Management.

About the userinterface ... 24
SOt UL KEYS .. 27
Aboutcellsandfields ... 29
FUNCHiONS .. 32

About the user interface

The WorkZone Configuration Management user interface consists the following parts:

Interface Description

Menu bar Use the menu bar to find the module you want to work with.

Toolbar  The toolbar contains buttons for different functionality, for example, Delete
Row and Text Cell Editor.

Display = When you log on to WorkZone Configuration Management, the window is
panel empty.

When you open a module from the menu bar, the panels of the module are dis-
played, for example Categories > Dictionary.

Status bar The status bar displays messages, for example server name, the data, and so
on.

Menu bar

The menu bar contains the following general items:

Menu item Description

File For example, import and export data.

Edit For example, copy and paste functions.

24
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Menu item Description

Database Log on to a database (change database), refresh, and save.

The menu items below gives access to the different modules of the program:

Menu item Description

Basicdata For example, Countries and Postcodes, Custom Label and Custom Domain.

Categories Modules containing data for classification cases and documents according to
the subject they are covering.

Security The Use log and the Table security modules.

Diagnostics For example tools for diagnosing errors.

Operation  Tools for general configuration of Captia Web Client.

Options Tools for configuring WorkZone Configuration Management.

In the following, when directions are given in procedures, actions in the Functions menu are
referred to in the following way:

The Function bar is the topmost menu bar. It contains the following items:

« Click Basic Data > Stopwords (refers to the Function bar’s entry to the module Basic
Data where you are prompted to activate the submenu entry for the Stopwords func-
tion)

« Click Database > Save (refers to the Function menu’s entry to the function Database
where you are prompted to activate the submenu entry Save - it saves your recent
action in you current module in the database).

Toolbar

The toolbar contains the following buttons:

Button Description

Refresh - Ctrl+R - reloads the data displayed in the panel.
= Save - Ctrl+S - saves data in the database.
[ Export to Excel - exports data to Excel.

25
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Button Description

Cut - Ctrl+X - cuts out selected data.

&
fe Copy - Ctrl+C - copies selected data.
3

Paste - Ctrl+V - pastes selected data into the current position.

— Delete Row - Ctrl+D - removes the current row.
4 Find - Ctrl+F - opens the Find window, where you can search based on the criteria
entered.
E Text Cell Editor - Ctrl+T - opens an Edit window. This is useful when a cell contains
large amounts of data.
@ Online help for WorkZone Configuration Management.
Display panel

The display panel is the central part of WorkZone Configuration Management. It is dis-
played when you open WorkZone Configuration Management. From the display panel, you
can open the modules from the menubar. One or more panels display the data registered in
the modules. The design of the panels depends on the type of data displayed.

Panel Description

Hierarchy Data is shown in a hierarchy. Left of each main heading is a button with a
panel plus, indicating that the branch can be expanded.

As an example, panel 1 in the module Classification Scheme is designed
as a hierarchy.

Spreadsheet The most common panel is the spreadsheet. It very much looks and feels
panel like a spreadsheet.

For example, the Dictionary module is one large spreadsheet.

Detail panel The detail pane contains a number of data fields.

For example, the Owner Setting tab in the Owner module is a detail
panel.

Tab panel The tab panel might be a collection of spreadsheets. Each spreadsheet
on its own tab. When you click a tab, the spreadsheet is displayed.

26
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Panel Description

For example, panel 2 in the module Preference Profiles is a tab panel.
Data is shown as a hierarchy on each tab.

Status bar

<Message> <Server <Database Ins Del 5 1
name> name>

The status bar is displayed at the bottom of the interface. It contains the following information:

« <Message> - A message informing about the current activity is displayed, for
example "Saving data...".

« <Server name> - The name of the server.

. <Database name> - The name of the database.
o InsInsert- Itis possible to create items.

o Del Delete - Itis possible to delete the items.

« 5-The first number tells you in which row the cursor is placed in a spreadsheet
panel.

o 1-The second number tells you in which column the cursor is placed in a spread-

sheet panel.
Shortcut keys
Key(s) Description
Arrow Down Moves the cursor to the cell below.
Arrow Left Moves the cursor to the previous cell.
Arrow Right Moves the cursor to the next cell.
Arrow up Moves the cursor to the cell above.
Home Moves the cursor to the first cell in the current row.
End Moves the cursor to the last cell in the current row.
Page Down Moves the cursor one page down. The cursor remains in the same column.
Page Up Moves the cursor one page up. The cursor remains in the same column.
Tab Moves the cursor to the next cell.
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Key(s) Description
Shift+Tab Moves the cursor to the previous cell.
Ctrl+Tab Moves focus from one window to the next.

Ctrl+Shift+Tab Moves focus from one window to the previous window.

Ctrl+Arrow Moves the cursor to the cell furthest away in the arrow's direction.

Ctrl+Home Moves the cursor to the first cell in the window.

Ctrl+End Moves the cursor to the cell furthest away in the window.

Ctrl+Page Same as Page Down or Page Up.

Down/Up

Ctrl+C - Copies the highlighted area.

Ctrl+D =. Deletes the row where the cursor is placed.

Ctrl+F @ - Opens the window Find (search).

Ctrl+R 2] - Restores the content of the module.

Ctrl+S & - saves your data.

Ctrl+T =- Edit current cell in Text Cell Editor. Click in the cell you want to edit, press
F2 and then Ctrl+T.

Ctrl+V B - paste the copied item into the cell where the cursor is placed.

Ctrl+X & - cut the highlighted area.

F2 Edit current cell (opens cell for typing new data).

F4 Opens the drop-down box.

Alt+Arrow Opens / closes the drop-down box.

Up/Down

Space Removes current value in a drop-down box field cell, and shows the drop-down
box button.

Enter Moves the cursor to the cell below.

ESC Undoes changes in a drop-down box field or a date field, and inserts the original
value.

Backspace Deletes the character in front of the cursor.

Delete Deletes one character after the cursor, the row or current item.

Ctrl+0 Clears current field.
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About cells and fields

Cells with date fields

When entering a date into a date field, you have two options. Either click the drop-down list
button and pick a date in the calendar or enter the date directly into the field. Default dates are
displayed as day- month- year, for example 24-12-2013.

Date fields - examples

Date fields are for example Start date and End date, which are found in the Classification
Scheme module, the Custom Label module, and the Custom Domain module.

Navigating the field

The date field is divided into three parts: day, month and year - DD-MM-YYYY.

Use the Right arrow key = and the Left arrow key € to navigate the three parts of the field.

enter the date directly into the field

1. Click the cell to selectit.

2. Click the cell once more to activate it. The date field is ready for input with a drop-
down list button displayed to the right.

Enter two digits for day and press the right arrow key
Enter two digits for month and press the right arrow key

Enter four digits for year.

S

Place the cursor in another cell and click Database > Save.
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insert a date from the calendar

1. Click the cell to select it.
Click the cell once more to activate it.

Click drop-down list button and select a date from the calendar.

> W N

Click Database > Save.

Remove a date - empty the date field

1. Click the cell to selectit.
2. Click the cell once more to activate it.

3. Press the Delete key and then press the Tab key. The date field is cleared and
the cursor moves to the next cell.

4. Click Database > Save.

Cells with drop-down lists

When entering a value into a drop-down box, you must select a value from the list. An
example is Sub-number type field in the Classification Scheme.

use a drop-down list

1. Click the cell select it.
2. Click the cell once more to activate the drop-down list.

3. Enter the first characters of the value you want to insert. Values containing the
characters entered are displayed. Select a value from the list.

-Or-
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Clik the drop-down list. Browse through the list using up and down arrow keys,
or type the first characters of the value you want to insert. Select the relevant
value.

4. Place the cursor in another cell (otherwise you cannot save) and click Database
> Save.

operate the drop-down list using shortcut keys

1. Press ALT+ARROW DOWN to open the drop-down box.

2. Enter the first characters of a value. A drop-down list is opened on top of the first
one. It displays the values containing the characters entered.

3. Use the ARROW DOWN to select a value and either use the TAB key to insert
the value in the cell (the cursor jumps to the next cell.) or use the RETURN key to
empty the field (the cursor stays in the cell).

Edit a cell

Some cells contain large quantities of text. The Text Cell Editor allows you to have text dis-
played in an editor. Here you can make the necessary changes and save the text in the ori-
ginal cell.

edit a cell

1. Click in the cell you want to edit.
2. Click once more to activate it.

3. Click the Text Cell Editor button in the toolbar. The contents of the cell is dis-
played in an editing window.

4. Click OK when you have finished editing. The window is closed and the contents
of the cell has been updated - indicated by the pencil icon .# displayed in the left
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most cell.

5. Click Database > Save to save the changes.

Functions

Resize columns and rows

You can adjust the width of the columns and the height of the rows by pulling the divider +—

to resize column with or the divider I to resize row height.

You can also use the context menu if, for example, there is not space enough to pull the
column wider. Some modules have so many columns in the panel thatitis impossible to
pull for more space.

use the context menu

1. Rightclick the header of a column and click Increase Column Width or
Decrease Column Width

2. Click Increase Column Width to increase the column width.

3. Use the scroll bar below to view the column.

Sorting

You can sort the contents of the panels. Click the header of the column you want to use for
sorting the list. The list is automatically sorted.

Primary or Secondary Sorting

You can sort up to three columns. Each time you click on a column header, it becomes the
primary sorting criteria, while a previously sorted column becomes the secondary sorting
criteria.
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Find
Use Find when you need to search for a particular item, for example post code or a user.

You must open the module, which you want to search within, before you click Find.

Find

Example: You want to find the user "Trine Troelssen" in the User module.

1. Click Operation > Users.

Select the first cell of the relevant column.
Click #4.

In the Find what field, enter your search criteria, in this example troels.

o & b

Select where to search in the Look in field is by default set to All columns.

To narrow down the search to one particular column, click the drop-down list
and select the specific column from the list.

6. Selectthe check boxes under Find options.

7. The firstitem found is highlighted.

Fields in the Find window

Field Description

Find what Enter the search criteria here. Click the drop-down list to view the last 10

entries.
Look in Select the scope of the search
« All columns - this is the default setting.
« A specific column. Click the drop-down list to select a particular
column.
Find In this section there are three check boxes:
options
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Field Description

« Match case - executes a case sensitive search.

« Match whole column - matches the search criteria exactly - except for
case.

« Search up - searches in ascending order - the default value is des-
cending order.

Gridview

The purpose of the Gridview is to display large quantities of rows of items faster. With Grid-
view the contents of a list is displayed in batches, in stead of one long list.

For example, there are approximately 1300 Danish post codes. With Gridview it is possible
to have them loaded and displayed in batches of, for example, 200.

A search in the Use Log as another example, easily retrieves a large amount of data. It may
take a while to load all data into the display panel. To avoid long response times, you can
use Gridview. When you have looked at one batch of data, you can navigate through the
remaining batches using the navigation buttons, for example Move next.

Operate the Gridview

The default number of records in the gridview is 2000. If, for example, you are viewing a list
of Danish post codes, it will (if it exceeds 2000) show a status bar at the bottom of the list.
This bar shows the result in batches of 2000 post codes at a time, for example, 2001 - 4000
of 5058.

Now, you have to click the Move next button to load the next batch of 2000. You can
always navigate the total series of batches by use of the buttons shown below.

Move first - Moves to the first batch of data.
Move previous - Moves to the previous batch of data.

Move next - Moves to the next batch of data.

= ] [ =

Move last- Moves to the last batch of data.
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Adjust the Gridview

Click Options > Gridviews to set the amount of data per batch. By default, the gridview is set
to display 2000 items. For better performance, you can adjust the number to, for example, 200
items.

The grid view is by default set to 2000. In the Number of records in gridview field in the
GridViewOption dialog box, the default value is entered as 2000___, thatis two thousand suc-
ceeded by two underscore characters, in all 6 characters.

The field must always contain 6 characters. If you, for example, want to set the number to 350,
you must enteritas 350___, thatis three hundred and fifty followed by three underscore char-
acters.

1. Click Options > Gridviews.

2. In the Number of records in gridview field, enter a new value, for example 350, it
must be entered as 350

3. Clik OK.
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The Countries and Postcodes Modules

In the Countries and Postcodes module you can manage countries and cities with post
codes.

In order to use a country or postcode in the WorkZone Client or Captia Web Client, you
must first enter it in the Countries and Postcodes module. Country and postcode are used
for example on contact detail pages.

To access the Countries and Postcodes module, you need the access code DATAADM.

Click Basic Data > Countries and Postcodes to open the module.

Manage countries

About countries

Before WorkZone users can use countries and postcodes, for example when creating new
contacts, you must create them in the Countries and Post codes module.

Click Basic Data > Countries and Postcodes to display the countries.
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Create a country

You can create a new country in the Countries module.

You must create the country before you can create postcodes associated with a country.

Create a new country

o &~ L b

Click Basic Data > Countries and Postcodes.

Click in the empty bottom cell of the column Country.

Click the cell once more to be able to enter a country code.
Enter the country code in the cell, for instance, N for Norway.

Click the next cell - in the Name column.
Enter the name of the country.

Click the cell once more to be able to enter a country code.
Click Database > Save.

The panel Country names for <country> is displayed bottom left.
The name of the country is inserted in all rows.
Click the names you want to edit one by one, and make your changes.

Place the cursor in another cell and click Database > Save.

Edit a country

You can edit all information concerning a country except the cell Country. The content of this

cell is the unique ID of the country. As soon as the newly created country has been saved, the

cell is locked for editing.

Bow N

Click Basic Data > Countries and Postcodes.
Click the cell of the country you want to edit.
Make the necessary changes.

Place the cursor in another cell and click Database > Save.
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Delete a country

If you have created and saved a country with a wrong code, you have to delete the country.
You cannot edit the cell in the column Country once you have saved the country.

You cannot delete a country if it has been used or if you have created postcodes belonging
to that country. If this is the case, then you must delete the post codes one by one before
deleting the country.

1. Click Basic Data > Countries and Postcodes.

2. Click the cell in the column to the left of the country you want to delete.
3. Click once more in the cell to select the row of the country to be deleted.
4. Click = to delete the country.

5. Click Database > Save.

Country meta data

The data you can register describing a country is shown below.

Data Description

Country This cell contains a code, for instance, the international vehicle registration
code. E.g. NO for Norway.

The contents of this cell is the unique ID of the country. As soon as the data has
been saved, the field is locked for editing.

Name  The name of the country, for example, Canada.
In the bottom left panel you can maintain the culture specific names of the coun-
try.
da-DK -Denmark

fr-CA -Canada

To create new entries, follow the general instructions in Working with the user interface.

See also Post codes metadata.
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Metadata

The data you can register describing a country is shown below.

Data Description

Country This cell contains a code, for instance, the international vehicle registration code.
E.g. NO for Norway.

The contents of this cell is the unique ID of the country. As soon as the data has
been saved, the field is locked for editing.

Name  The name of the country,for example, Norway.
In the bottom left panel you can maintain the culture specific names of the country.
da-DK -Norge

en-GB -Norway

To create new entries, follow the general directions of use in Use - contents.

See also Post codes - metadata.

Manage postcodes

About postcodes

To create a postcode, the country of the postcode must exist. By default a large number of
countries already exists when WorkZone Configuration Management is installed.

In the Countries and Postcodes module, you can create, edit and delete postcodes of coun-
tries.

1. Click Basic Data > Countries and Postcodes.

2. Click on the field to the left of the country code of that country to see the post-
codes of a specific country. The postcodes are displayed in a separate panel to
the right.
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Create a postcode

To create a post code, the country to which the code belongs must exist in the module.

You want to create the postcode 2150, Nordhavn in Denmark.

1. Click Basic Data > Countries and Postcodes.

2. Select the country to which the post code belongs in the list of countries (Den-

mark).

3. Click the cell in the column to the left of the country code.
A panel displaying the postcodes of that country is displayed to the right.

Place the cursor in the empty cell of the Post code column's bottom row.
Click the cell once more to enter the postcode, for example 2150.
Click the next cell of column District.

Enter the name of the district for e.g. Nordhavn.

©® N o g &

Click Database > Save.

Edit a postcode

You can edit all information concerning a postcode except the cell Postcode. The content
of this cell is the unique ID of the postcode. As soon as the newly created post code has
been saved, the cell is locked for editing.

1. Click Basic Data > Countries and Postcodes.
2. Select the country to which the postcode belongs in the list of countries.

3. Click the cell in the column to the left of the country code.
A panel displaying the post codes of that country is displayed to the right.

4. Click the cell of the postcode you want to edit and make your changes.

5. Place the cursor in another cell and click Database > Save.
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Delete a postcode

You can delete a postcode as long as it has not been used in Captia Web Client. If it has
been used with a contact or address in Captia Web Client its entries it cannot be deleted
unless all its instances are deleted or changed in the Captia Web Client user interface.

1. Click Basic Data > Countries and Postcodes.
2. Select the country to which the post code belongs in the list of countries.

3. Click the cell in the column to the left of the country code.
A panel displaying the post codes of that country is displayed to the right.
4. Click the cell in the column to the left of the postcode.

The row is highlighted.

5. Click = to delete the postcode.

6. Click Database > Save.

Postcode meta data

The data you can register describing a postcode is shown below.

Data Description

Postcode The contents of this cell is the unique ID of the postcodes, for
instance, 2150 (Nordhavn in Denmark). As soon as you have saved
the postcode, this cell is locked for editing.

District The name of the post district, for instance Nordhavn (postcode
2150).

To create new entries, see Working with the user interface.

Metadata

The data you can register describing a postcode is shown below.
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Data Description

Postcode The contents of this cell is the unique ID of the postcodes, for instance, 7884
(Serli in Norway). As soon as you have saved the postcode, this cell is locked
for editing.

District The name of the post district, for instance Sgr1i (postcode 7884).

To create new entries, follow the general directions of use - see Use - contents.

Related topic - see Countries - metadata.

The Custom label Module

The Custom label module manages both system defined and custom defined Label Types
and Labels. A Label type contains labels. A label either defines the content of a data field
or labels references, that is roles, in WorkZone Client and Captia Web Client.

To access the Custom label module, you need the access code DATAADM.

Click Basic Data > Custom label to open the module.

About custom labels

In the Custom label module you can maintain custom labels. A label is the name of a field
that describes the information that field contains.

WorkZone Client and Captia Web Client contain two different types of labels:

« Fixed labels

The pages and dialog boxes of WorkZone Client and Captia Web Client con-
tain a number of fixed labels. They are part of the default configuration of and
cannot be changed by the users. An example of a label is the text Case handler
on the case details page.

e Custom labels

These labels are user defined. They are available for registering information, for
example, on the case details page in the bottom section of the page, click
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More... > Information.

The purpose of the custom label

The purpose of custom labels is that you can name labels yourself. For example, fields for
registering degrees of longitude and latitude are not default in the clients but can be added by
means of custom labels. Subsequently the WorkZone Client and Captia Web Client user can
register this type of information and search for cases on the basis of it.

Where are custom labels used

Custom labels are used in WorkZone Client and Captia Web Client details and search pages

for cases, documents, and contacts.

About custom label types

Custom labels are grouped according to label types depending on register and data type. A
label type is identified by a code, that is its ID. The code consists of two characters defining

the register they belong to and their function:

« The first character of the code defines which register the label belongs to:

« A =Documents
« N =Contacts

« S =Cases

« The second character defines the data type to be registered with the custom label:

« A =Documents (only applied in AA)
o D =Dates

« H=References

« O =Information

« P =Contacts
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As an example the label type SH consequently denotes the reference Case references -
references between cases.

Label types for which you can create your own custom labels

Below are the label types you can use for creating your own custom labels:

Name in
WorkZone

Description Client/Cap-
tia Web Cli-
ent

AA References between one document and another. The label char- Document
acterizes the role of the actual reference. references

One custom label could, for example, be Copy and the reverse
label, Original document.

AD Custom labels for special document dates. A custom label could, for Document
example, be Aground. In the data field you must enter the date when dates
the ship in question ran aground.

AH References from the current document to cases of relevance for the Case ref-
document at hand. erences

The label, for instance, defines the role of referenced case, such as
Cross reference.

AO Custom labels for document information not included in the default Information
meta data fields such as Agenda.

AP Custom labels for contacts reference by documents defining the role Parties
of the contact such as Sender.

ND Custom labels for special dates to be registered on contacts such as Dates
Hired from.

NH Custom labels for referencing contact case relations such as Mem- Case ref-
ber. erences

NO Custom labels for contact information not included in the default Information
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Namein
WorkZone

Description Client/Cap-
tia Web Cli-
ent

metadata fields such as Marital status.

NP Custom labels for referencing contacts in relation to another contact. Contact ref-

The contacts attached to another contact in this way are auto- elless
matically committee members. And the contact to which they are
attached is the committee. The label defines the role of the mem-
bers, for example, Chairman, Secretary, Member, etc.
SD Custom labels for special dates registered on cases. Case dates
SH Custom labels for cases attached to another case for reference. Case ref-
erences

The label is used for describing the role played by the case referred
to, such as Associated case.

SO Custom labels for case information not included in the default meta Information
data fields.

These custom labels could, for instance, be user for non default
information like Degree of longitude and Degree of latitude.

SP Custom labels for contacts reference by cases defining the role of  Parties
the contact such as Party.

For an in depth description of the functions of the data fields Dates, References, Information
and Contacts, see Types and data fields.

About custom label types and data fields

Custom labels are grouped according to the type of data to be registered with the label in
qguestion:

« D =Dates

« H =References
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« O =Information

« P =Contacts

In WorkZone Client and Captia Web Client you can register data in the data fields that
belongs to the custom labels. In the table below the controls of the different type of labels
are described.

Custom
Properties of the data fields
label
Dates The field only accepts a correct date.

Dates in WorkZone Client and Captia Web Client can be entered in different
ways:

« By selecting a date in the calendar.

« As an algorithm, for example +4w, which automatically converts
into the date 4 weeks ahead.

« Directly as a date, which consists of at least 6 digits - ddmmyy, for
example, 241212 displayed as 24-12-2012.

References To register references, you have to select the entities in a dialog box. When
you start registering an entity in a data field, belonging to this type of label, a
dialog box is opened. Here you must search out one or more entities to be
referred to.

Only entities already existing in the database can be referred to.

Information The field may have one of two modes that determines the use of the field in
WorkZone Client or Captia Web Client:

« Afree text field where the user can enter any text or number into the
text box.

« A drop-down box with a controlled choice of possible entries.

The values listed in the drop-down box depends on the selected Routine,
(i.e. dependency) for the custom label.

Contacts There is no actual input field associated with custom labels of this type.

(in Captia These custom labels describe the connection between the contact and the

entity to which it is attached.
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Custom

Properties of the data fields
label

Web Client When you, for example, link a contact to a case, you can specify the role of
called the contact in relation to the case. The custom label, used to characterize
Parties) this relation, could for example be Complainant, Accused, and so on.

Custom label meta data

Table below displays the meta data you can register concerning Label types and Labels.

Column  Description

Panel: The first left panel contains all custom label types.

All Label
type

Label type The Label type is composed of two letters, for example, SO. This label type con-
tains labels for supplementary case information.

See also Custom label types.

Label text The Label Text contains a description of the subject of the label type.

Panel: The upper right panel contains the Labels of the Label type.

Label:

<label

type>

Label In this cell you must enter the label which is displayed for the users in the

WorkZone Client or Captia Web Client user interface.

Reverse This cell is only used with system defined label types AH and SH and the routine
label code Cross reference. It is used for cross references, where the source and the target
reference need different tags, such as Copy vs.Original or Parent

As an example, the users can move an archived document from one case to
another. Cross reference information is automatically inserted into both source
and target. In this way the document can be traced back to its original location
and to its new location.
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Column  Description

System In this cell, you can enter the name of the owner of the label - if necessary.

Routine In this cell, you can enter the name of the routine that implements dependency
between the label's data field and the validating custom domain.

By default, you can attach validation routines to three types of labels: AQO, i.e.,
document information, NO, i.e., contact information and SO, i.e., case inform-
ation. Otherwise it must be a customized label type, see Create custom label
type.

The system offers a number of different ways to configure the data field attached

to the labels. For instance, you could have:

« Data fields without validation - a free text box (no Routine is selected).

« Data fields that are validated against a user defined domain in the Cus-
tom Domain module (Routine is selected).

« Data fields that are validated against fixed (i.e. mandatory system)
domains in the Custom Domain module, such as employees, contact
types, countries, etc.

Text Enter an elaborated description of the label.
Start date The date defines the day of initiation.
End date The date defines the day of termination.

Localized What you enter here, is what the users of Captia Web Client see in the user inter-
label face. Itis important that the label is short and precise.

If you system is running in multi- language mode you must also enter the culture
specific localized labels in the lower right panel.

For information on language mode, see Language mode.

Panel: The lower right panel contains the Label values of the selected Label in the
Label upper right panel - if multi-language mode is selected, the related cultures (i.e.
value: languages) are shown.

<label>

Localized What you enter here, is what the users of Captia Web Client see in the user inter-
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Column  Description

label face, depending on the culture they have selected. It is important that the label is
short and precise.

Text Here you can enter an elaborated description of the label.
Culture  The culture code of the current row.

Source The current language code (i.e. default language).

Create custom label types

It is possible to create new label types in case of customizations. A label type is a domain.
Here you can create labels for customized fields displayed in WorkZone Client or Captia Web
Client. This could, for example, be fields for dates with labels supporting the work process of
the organization.

create a new Label type

1. Click Basic Data > Custom Label.
Click in the cell to the left of label type TY, Label types.

In the upper right panel, click in the empty cell in the Label column.

> W N

Enter a short and precise name for the label type - max. 11 characters. This name
is the ID of the new label type.

o

Click the column Text in the in the next cell. Click in the cell once more to enter
the specific descriptions of the label - for example, the same as the Label.

In Localized Label cell enter the user interface name.
Whether the Routine cell is filled in, depends on the use of the Label type.

You should enter an initiation date in the column Start date.

© ® N O

Place the cursor in another cell and click Database > Save.

If your system is running in multi-language mode, you must also add the culture specific texts
in the lower right panel.

See also
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Configure the label type, see Routine.

Create custom label with validation, see Create custom label with validation.

Create custom label without validation, see Create custom label.

Create custom labels

You can create new labels for existing domains, i.e., label types.

Example

When you register cases in Captia Web Client concerning grounded ships, you must
register some supplementary information. You must register the date the ship was groun-
ded and the date it was brought afloat again.

These dates are not default information in the case details page in WorkZone Client and
Captia Web Client. Therefore, you must create two new custom labels, for example, Groun-
ded and Afloat. They must be created in the label type SD domain, i.e., case dates and
then the labels and their data fields will be available in WorkZone Client or Captia Web Cli-
ent on the case details page. In Captia Web Client,Click More > Dates.

Create labels

1. Click Basic Data > Custom Label.

2. Click the cell to the left of the Label type in which you want to create labels, in
this example SD. The contents of the Label type is displayed in the upper right
panel.

3. Click the empty cell in the bottom of the Label column.

4. Click once more and enter a short and precise name for the label - max. 11
characters. In this example Grounded. This is the ID of the new label.

A custom label must not be prefixed with a number.

5. Inthe Text cell, enter the text defining its use, for example The date of the
grounding.
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6. In Localized Label cell, enter the label used in the WorkZone Client or Captia
Web Client user interface.

7. Ignore Routine (unless it is called for due to a customization).
8. You should enter an initiation date in the column Start date.
9. Repeat the steps 3 through 8 until you have created all the necessary labels.

10. Click Database > Save.

If your system is running under the multi language mode, you must also add the culture spe-
cific localized labels and texts in the lower right panel.

Create custom label with validation

You can create labels which have either a specific control or no control at all. A control gov-
erns what users in WorkZone Client and Captia Web Client can enter into the data field
belonging to a certain label. Controls can only be attached to labels of label types AO, NO or
SO, unless they have been created as part of a customization - see Create custom label

types.
You can create labels with a drop-down box in the data field belonging to the label. The val-
ues contained in the drop-down box belong to a domain in the custom domain module. Both

fixed (i.e. mandatory) domains, for example Case type, and user defined domains can be
attached to the label - the data field of the label.

Example

When you register cases in WorkZone Client and Captia Web Client concerning for example
grounded ships, you must register some supplementary information. You must register the
cause of the grounding. This is done by supplying the cause. You select the cause from the
list of predefined causes in the drop-down box.

The prerequisites for this are:

« You have created a domain for the values i.e. a domain type, see Create custom

domain type.
« You have created the values in this domain, see Create custom domain value.

This type of information is not default information in the case details page in WorkZone Client
and Captia Web Client. Therefore, you must create a new custom label, for example
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Grounding. It must be created in the label type SO, "Case information" domain. You must
attach a domain type to the data field of the label. This is done in the cell Routine. Here
you can select the domain type containing the values assigned to the different causes for
groundings.

Now the label and the data field with the specific control, will be available in WorkZone Cli-
ent and Captia Web Client as soon as the IIS Admin service has been reset (this usually
happens automatically once every 24hrs.) After the resetting, it will, on the premiss of this
example, be available on the case details page. The user must select the relevant value
from the drop-down box of the data field.

Create a label with validation

1. Click Basic Data > Custom Label.

2. Click the cell to the left of the Label type in which you want to create labels, for
example SO. The contents of the Label type is displayed in the upper right
panel.

3. Click the empty cell in the bottom of the Label column.

4. Click once more and enter a short and precise hame for the label - max. 11
characters.
In this example Grounding. This is the ID of the new label.

5. Inthe cell Text enter the text defining its use, for example Grounding causes.

6. In cell Localized Label enter the label used in the WorkZone Client or Captia
Web Client user interface.

7. In the cell Routine select the custom domain that should control the drop-down
box of the label, for example Grounding causes.

8. You should enter an initiation date in the column Start date.

9. Click Database > Save.

After the IIS has been reset, the case handler would be able to process a grounded
ship and supplying the information regarding the cause.

If your system is running in multi language mode, you must also add the culture specific
Localized Labels and texts in the lower right panel.

Validation controls for the data field - see Custom label meta data.
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Edit Custom label

You can edit information about label types and custom labels. You can edit information in all
cells, except Label type and Label. The content of these cells is by default locked.

edit the Label Types

1. Click Basic Data > Custom Label.

2. Clickin the cell to the left of label type TY, Label types.

3. Inthe upperright panel, click the left cell of the label you want to edit. The bottom
right panel now displays the culture specific names of the label.

4. You can edit the cells Localized Label and Text.

5. When you have made the necessary changes,

6. Place the cursorin another cell and click Database > Save.

edit labels

1. Click Basic Data> Custom Label.

2. Click to the left of the Label type in which you want to edit labels, for example SO.

3. Clickin the cell to the left of that label type.

4. Inthe upper right panel, you can edit all the cells that are not greyed out or click in
the lower right panel and edit Localized Label and Text cells.

5. Make your corrections.

6. Place the cursorin another cell and click Database! Save

For information about individual cells, see Custom label - metadata.

Delete or terminate a custom label

There are two ways to discontinue a label - you can terminate it by applying an end date, or
you can delete it if there are no occurrences of it in WorkZone Client or Captia Web Client.
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terminate a label

1. Click Basic Data > Custom label.
Select the Label type of which you want to terminate labels.

Click the column to the left of the code of that label type.

> W N

In the upper left panel, click End date of the label to be terminated. Click the
cell once more to activate it. Today's date is entered into the cell by default.

5. You now have two options:

« To enter the date manually, edit each part of the date separately.

Click the drop-down button of the cell to select a date from the calendar.

6. Place the cursorin another cell and click Database > Save.

To terminate a value immediately, insert yesterday's date.

delete a label that has never been used

1. Click Basic Data > Custom label.

Select the Label type of which you want to delete labels.

Click the column to the left of the code of that label type.

Click to the left most cell of the row of the label you want to delete.

Click Edit > Delete Row.

o g M v DN

Place the cursor in another cell, click Database > Save.

The Custom domain Module

In the Custom domain module, you manage a collection of domain types. A domain type is
an individual register. Each of these registers contains a number of values that are presen-
ted in the WorkZone Client or Captia Web Client interface in a drop-down box of the field of
the register in question, for example Case types.
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You can use both system defined domain types and user defined domains types with both
fixed and variable contents.
To access to the Custom domain module, you need the access code DATAADM.

Click Basic Data > Custom domain to open the module.

About custom domain

About the Custom Domain module

The Custom domain module contains a collection of domain types. A domain type is an indi-
vidual register. Each of these registers contains a number of values.

These registers contain basic data that displays in drop-down lists to data fields, for example,
displayed on the details pages in WorkZone Client and Captia Web Client. When you, for
example, click the drop-down list of the Document type field, the values come from domain
type AT, Rec. type.

What does the custom domain module contain?

The Custom domain module contains a large number of basic data, for example, document
types, document groups, case types, and so on.

The Custom domain module contains 3 types of domain types:

« System defined domain types, which contain both system and user defined values,
for example, case types, document types, and so on.

« System defined domain types owned by the system and managed by KMD.
« User defined domain types with user defined values.
The system defined domain types are mandatory and must exist in the Custom Domain mod-

ule prior to implementation. They contain values for data fields belonging to the WorkZone Cli-
ent and Captia Web Client details and search pages, and so on.

Some of the system defined domain types are system owned registers that supports special
features. Only KMD can edit these custom domains.
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What does a custom domain contain?

A domain type is a domain (or register) that contains a number of values, which consists of
a code and a text. The text defines what the code means. As an example, the text Embed.
image defines the code EMBED in the domain type AT, Rec. type as an embedded image.

System defined domain types with values managed by you, see User managed domain
types.

User defined domain types with values managed by you, see About user defined domains.

Custom domain meta data

The data you can register in custom domains is show below.

Column  Description

Panel: The All Domain Types panel contains all domain
All Domain tyPes. All domain types are values in domain type
TY, Cust. dom. type, except the domain type itself.

Types
When you have created a new domain type, you
have created a domain (a register). In this domain
you can create the number of values necessary.
Code The unique ID of the domain type

Domain The name of the Domain type - a short and precise
Type description of the domain type.

Custom label module

The Routine cell of the Custom label module con-
tains a drop-down box. The values of this drop-down
box are the names registered in this field.

If a value is selected here, the data field of the cus-
tom label in question contains a drop-down box
when displayed in WorkZone Client and Captia Web
Client. The values displayed in this drop-down box
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Column  Description

come from the custom domain represented by the
"routine".

System The owner of the Domain type

If the owner is KMD, only KMD is allowed to edit the
domain type, for example, create values in the

domain.
Panel: The upper right panel with the header Domain:
Domain:  <Code> (<Domain type>). The values of the current
<Code> domain type are displayed in this panel.
(<Domain
type>)
Code The unique ID of the value.
Text The name of the value.

System The owner of the value.

If the owner is KMD, only KMD is allowed to maintain
the value.

Start date |If a date is entered into the cell, the value can be
used in WorkZone Client and Captia Web Client as
of this date.

End date If a date is entered into the cell, the value will as of
this date no longer be available in WorkZone Client
and Captia Web Client.

Panel: The panel is displayed when the program is working

The lower in multi-language mode. Here the culture specific

right panel names of the values of the domain type are displayed

and managed. The culture specific names of the cur-
rent value are maintained here.
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Column  Description
Text The culture specific name of the value.
Culture The culture code of language to be used for the text.

Source The current language code (i.e. default language).

See also dependencies between Custom Domain, Custom Label and WorkZone Client
and Captia Web Client, see Using custom domain/label.

Single and multi-language mode, see Language mode.

Using custom domain/label

Custom domain and label dependency

Itis possible to make data entries in the custom label module dependant on data from the
custom domain module displayed in a drop-down lists.

The purpose of this feature is to allow tailor made labels and drop-down list values in
WorkZone Client and Captia Web Client. This enables you to implement the data set and
labels of your organization, and furthermore to control what data can be registered from
within a specific label.

implement a dependency

When you register cases in WorkZone Client or Captia Web Client concerning for example
grounded ships, you must register the cause of the grounding. In this example, the organ-
ization has a predefined list of so called Grounding codes. Each code describes the type of
cause for the ship to run aground.

The organization does not want the case handlers to individually define the causes, but
want them to use a predefined list of causes. Therefore, it is necessary to make the pre-
defined list the only option when registering the cause of the grounding, for example on the
case details page in WorkZone Client and Captia Web Client.
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configure a label with a dependency on values from a custom domain

Follow the process below to configure a label with mandatory data entries from a predefined
and controlled drop-down list.

1: Create domain

o 1. Open the Custom Domain module and create a new domain

type, in this example "GC, Grounding cause".
2. Selectthe domain type TY,Cust. dom. type.

3. In this domain, create a value with code GC and the text
Grounding cause.

4. Saved it to the database and it becomes an individual
domain type. Now it is displayed in the panel All Domain
Types.

2: Create values

1. In the Custom Domain module, select the domain type you
for the domain typey

type just created. The upper right panel is displayed with the

header "Domain: GC (Grounding cause)".

2. Create the necessary values for the domain type, for
example CO, Collision, NM, Navigational mistake, and so
on.

3: Create custom

label Open the Custom Label module and create a label and then

dedicate a data field for registering the grounding cause.

2. Inthe All Label Types panel, select label type SO for case
information. The values, i.e. labels of this label type, are dis-
played in the upper right panel.

3. Enter the name of the label in the Label, Text and Localized
Label cells, in this example "Grounding".This is the label
which is going to be displayed in WorkZone Client and Cap-
tia Web Client.

4: Create the Now attach a dependency (i.e. routine) to the label.
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dependency The Routine cell displays a drop-down list. Here you must select the
between the cus- domain type of the label, creating a controlled drop-down list.

tom domaintype |, ;s example, you must selecte "Grounding cause".
and the custom

The IIS Admin service must be reset before the dependencies take fully
label type

effect in the user interface.

5: Custom A ship running aground is to be registered in Captia Web Client. The
domain and label Captia Web Client user logs on and creates a new case registering the
in Captia Web Cli- grounding.

ent To register the cause of grounding, the user must select the cause and

supply it as case information in section 4:

1. Open the list "Information" using the menu item More... >
Information.

2. Open a new information entry by clicking Functions > Add
to list.

3. Open the drop-down list "Custom label for free case inform-
ation" and select the relevant label , in this example
"Grounding".

4. Open the drop-down list of the "Information"” field and select
the relevant value - in this example CO, Collision.

5. Save the information.

Resetting of the IIS Admin service

When dependencies have been created, the [IS Admin Service must to be reset before
your changes take effect and can be employed fully in the WorkZone Client and Captia
Web Client user interface.

User defined domains
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About user defined domains

The purpose of user defined domains is that you can create a domain yourself and define the
contents of that domain. This content is accessible in a drop-down lists in WorkZone Client
and Captia Web Client.

To have the contents of the user defined domain displayed in a drop-down list, you must:

1. Create a label in the Custom label module.

2. Attach your custom domain to the label as a "routine".

Example

As an example, you have a list of codes to be used in WorkZone Client or Captia Web Client
to specify types of reasons for ships running aground. When the users register a code on a
case, they must select the code from a predefined list.

In the example there is no list of codes beforehand and there is no dedicated field on the case
details page for the codes.

This is how to implement it:

1. Create the list as a domain type in the Custom domain module, see Create a
domain type.

2. Register all the codes in the new domain, see Create values in a custom domain.

3. Create a label in the Custom label module with a data field validated against the
registered codes - see Create label with validation.

For information on the dependency between Custom Label, Custom Domain and WorkZone
Client and Captia Web Client, see Using custom domain/label.

Create domain type

You can create a new domain. You create a domain by creating a domain type. In the new
domain you can create values.

Example
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As an example, you must register ships grounded within 12 nautical miles from the coast
as cases in WorkZone Client or Captia Web Client. In connection with these cases, you
must register a code defining the reason why the ships ran aground. Your organization has
a list of codes describing the different types of conditions causing groundings. You must
create this listin the database, i.e., in the Custom domain module.

Create a custom domain

1. Click Basic Data > Custom Domain.

2. Click in the cell to the left of domain type TY, Cust..

3. Inthe upperright panel, click the empty cell in the bottom of the Code column.

4. Enter a unique identification code for the new domain type. Maximum 8 letters
- in this example "GC".

5. Click the Text column in the next column.

6. Clickin the cell once more to enter the specific descriptions of the domain. In
this example Grounding cause in the Text cell.

7. Enter an initiation date in the Start date column .

8. Place the cursorin another cell and click Database > Save.

If your system is running in multi-language mode, you must also add the culture specific
texts in the lower right panel.

When you have created a new domain, the next steps are:

o Create the values of the domain - see Create values.

« Create a label, for example, "Grounding" in the Custom Label module - see
Create custom label with validation.

« Attach the custom domain GC, Grounding Cause to the label as a "routine". The
data field of the custom label will be validated according to the values of the cus-
tom domain GC.

Now the users can register the proper codes describing the reasons for grounding.

62



Online Help

Editdomain type

You can edit the following cells of an existing domain type:

o Startdate
« Enddate

o Text

edit a domain type

1. Click Basic Data >Custom Domain.

2. Click in the column to the left of TY, Cust. dom. type. (All Domain Types are
shown in the upper right panel.)

3. Clickin the date cells of the domain type to be edited and in the lower right panel,
click to edit Text cells.

4. Edit the data of the cell.

5. Place the cursor in another cell and click Database > Save.

Terminate domain type

You can terminate domains which are no longer in use. When entering an End Date in a
domain, the following happens in WorkZone Client and Captia Web Client:

« Values no longer in use remain in place where they were originally used, for instance
values on cases. If you, for example, terminate the custom domain GC, Grounding
causes, the values of that domain remain where they were registered in WorkZone
Client or Captia Web Client.

« The values of the domain will no longer be available in the drop-down list of the field
to which they originally belonged. However, they will still be available in search
pages in the WorkZone Client and Captia Web Client user interfaces.

terminate a custom domain
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1. Click Basic Data > Custom Domain.

Click the column to the left of the domain type, TY, Cust. dom. type.
Click the End date of the Domain Type you want to terminate.

Click the cell of End date once more to activate the drop-down list.

Click the date you want to insert as End Date.

o g M w DN

Place the cursor in another cell and click Database > Save. You now have ter-
minated the domain type.

To terminate a domain immediately, insert yesterday's date as the end date.

Fixed domains

User managed domains

The table below displays a lists of some of the common predefined domain types. In these
domains you can create, edit and terminate your own values. Create the values preferred
by your organization, for instance, values for different types of documents or cases in AT,
Rec type, ST, Case type.

The values you create here are displayed in WorkZone Client and Captia Web Client.
When you, for example, open the drop-down list of the Case type field, the values dis-
played are the ones you created in the Custom Domain module.

Domaintype Code Description

Address type AD Values registered in the Address type domain could be:

« HA, Main address,

« FI, Branch address.

Use in Captia Web Client

These values are used for defining which address of a contact
is the primary address and which are the secondary addresses.
The values registered in the Address type domain are dis-
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Domaintype Code Description

played in the drop-down list named Type in the address details
view - section 5 in the contact details page.

Rec. group AG Values registered in the Record group domain could be:

AFT, Agreement

HM, Enquiry request
« HS, Response

¢ IN, Recommend.

Use in Captia Web Client

The values could, for instance, be used for grouping documents
according to contents. The values in the domain Rec. group are
displayed in a drop-down box in the field Document group, e.g.
in the document details page.

Rec. type AT Values registered in Record type domain could be:

IL, Incoming letter

IM, Incoming mail

« IF, Incoming fax

o TN, Telephone note

Use in Captia Web Client

The values are intended to show whether an item is an incom-
ing or outgoing document or mail, an internal document, etc.
The values in the domain Rec. type are displayed in a drop-
down box in the field Document type, for example on the doc-
ument details page.

Remind. type ET Values registered in the domain Reminder type case could be:

o SU, Suspended
« RS, Restarted
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Domaintype Code Description

Reminder type ETAKT

rec.

Name group

NG

Location type PT

Case type

ST

e« SH, Shelved
« UR, Urgent

Use in Captia Web Client

The values are used for characterizing the purpose of a case
reminder. The values in the domain Reminder type case are dis-
played in a drop-down box in the field Reminder type e.g. in the
case details page - section 4 in the list named Reminders.

Values registered in the domain Reminder type record are
used for characterizing the purpose of a document reminder.
The values in the domain Reminder type record are displayed
in a drop-down box in the field Reminder type, for example, in
the document details page - section 4 in the list named Docu-
ment reminders.

Values registered in the domain Name group are used for char-
acterizing and grouping Contacts. The values are displayed in a
drop-down box in the field Group, for example on the Contact
details page.

Values registered in the Location type domain are used for
defining purpose and status of the current placement. The val-
ues are, for instance, displayed in a drop-down box in the
column named Placement code in the list called Case locations
in the Case details page.

Values in the Case type domain could be:

« ANK, Appeal

« FOR, Enquiry

o KLA, Complaint

« OMJ, Re-registered
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Domaintype Code Description

Use in Captia Web Client

The values are used for characterizing cases. Values in domain
Case type are displayed in a drop-down box, for instance, in the
field Case type in the case details page.

Cust. dom. TY The values in the domain Custom domain type are all domains.
type The domain Custom domain type is domain for all other domain
types.

If you want to create a new custom domain, you must create the
domain as a value in the domain Custom domain type.

Subnumber uT Values in the domain Subnumber type are all domains
type designed to contain Subnumbers.

The actual subnumbers are created and edited in the Sub-
number module.

The subnumber module is displayed by means of the menu item
Categories »Subnumbers.

Create values

This topic explains how to create a value in a custom domain. The procedure is the same
whether the domain is a fixed domain or a user defined one.

Example

When you register cases in WorkZone Client or Captia Web Client concerning ships run
aground, you must register the reason for the grounding. The organization has a list of so
called Grounding codes. Each code describes a type of cause for the ships grounding.
You have already created the domain type GC, Grounding cause for the codes see Create
domain type.

Your task now is to fill the domain with values. In this example, you are to create the following
values:
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e« CO, Collision

« NM, Navigational mistake
« NP, No pilot

e« SC, Submarine conditions

« WC, Weather conditions

Create domain values

1. Click Basic Data > Custom Domain.

2. Click the cell to the left of the Domain type in which you want to create values,
in this example, GC, Grounding cause. The contents of the domain type is dis-
played in the upper right panel.

3. Click the empty cell at the bottom of the Code column.
4. Enterthe value, i.e. the code identifying the value, in this example CO.

5. Click the next cell, Text, and enter the text defining the code, in this example
Collision.

6. Enter a start date in the Start date column.
7. Repeat the steps 4 to 7 until you have created all the necessary values.

8. Click Database > Save.

If your system is running in multi-language mode, you must also add the culture specific
texts in the lower right panel.

Next step in the process is to create a custom label named "Grounded:" The data field
belonging to the label must be set to be validated against the values of custom domain
"GC, Grounding cause", see Create label with validation.

You can manage domain types with values yourself, see User managed domains .

Edit values

You can edit an existing value belonging to a custom domain type. The following cells can
be edited:
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o Startdate
« Enddate

o Text

edit a domain value

1. Click Basic Data > Custom Domain.
2. Click to the left of the Domain type in which you want to edit values.

3. Inthe upper right panel, click in the date cells of the domain type to be edited and
in the lower right panel, click to edit Text cells.

4. Edit the data of the cell.

5. Place the cursor in another cell and click Database > Save.

You can manage domain types with values yourself, see User managed domains.

Terminate values

You can terminate values which are no longer in use by entering an End Date.

The following happens in WorkZone Client and Captia Web Client:

« Values no longer in use remain in place where they were originally used, for
instance, in cases.

« The value is no longer available in the drop-down list of the field to which it originally
belonged. However, it is still available in search pages.

terminate a value

1. Click Basic Data >Custom Domain.
2. Selectthe Domain type of which you want to terminate values.

3. Click the column to the left of the code of that domain type.

69



WorkZone Configuration Management 2021.2

4. Inthe upper left panel, click End date of the value to be terminated. Click the
cell once more to activate it. Today's date is entered into the cell by default.

5. Enterthe date manually, edit each part of the date separately or select a date
from the calendar.

6. Place the cursorin another cell and click Database > Save.

To terminate a value immediately, insert yesterday's date as the end date.

You can manage domain types with values yourself, see User managed domains.

The Filing periods Module

The Filing periods module manages preservation and disposal codes used at the ter-
mination of an archive period and/or transfer of data. The data in the Filing periods module
cannot be edited.

Prerequisites for managing periodization

The prerequisite for gaining access to the Filing periods module is the access code
DATAADM.

Click Basic Data > Filing periods to open the module.

Filing periods - preservation and disposal codes

These codes are managed in the Custom Domain module, see The Custom domain Mod-
ule

This topic is only relevant for organizations and installations subjected to the rules and reg-
ulations of the Danish Archives Act, represented by the Danish State Archives, who are
authorised to oversee the management of the records of Danish Public Authorities.

For more information regarding compliance - see the Danish State Archives website.
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Filing periods meta data

You can register the following data in the Filing periods module.

Data Description

Domain type Domain Type

Code Code

System Name of the owner of the domain type - if needed
Code Preservation/Rejection code

Text Text describing the scope of the code

System

Selection

Start date The date of initiation

End date The date of termination

Source The culture code of the master code

Text Text describing the scope of the code

Culture The current language code (i.e. default language).

The Contact module

Online Help

The Contact module manages address types. The purpose of address types is to group the

contacts in the Contact register. The contact defines the format of the ID of the contacts cre-

ated in the register. The format of the ID could, for instance, be a personal identification num-

ber or a sequence number.

Click Basic Data > Contact menu to open the module.

Prerequisite
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You need the access code DATAADM to access the Contact module.

About Contact type

The purpose of Contact types is to group the contacts in the Contact register. The contact
type defines the format of the ID of the contacts created in the register. The format of the ID
could, for instance, be a personal identification number or a sequence number.

If there are no contact in the Contact module, no contacts can be created by the users of
WorkZone Client and Captia Web Client.

The individual contact is identified by its unique ID. The ID is composed of a single let-
ter/digit contact type and a code. The ID for a company, for instance, consists of the contact
type C and the contact code (the code being a sequence number)

C 3542, Cloak & Dagger Inc.

In this example, C is the contact type and the code is a sequence number 3542. For each
contact type, you can specify the way it forms its code using a predefined set of algorithms.

Contact types reserved by the system

Four contact types are reserved for special purposes. They supply data for drop-down lists
in WorkZone Client and Captia Web Client.

You must not change or delete these four contact types:

« A, Units (i.e. organizational units.)
« M, Employees (i.e. case handlers)
« K, Municipalities (i.e. local government) - only default in some installations!

o U, Committees.

The register of the contact types M and U deviates from all other contact types. Their data
is automatically transferred from Active directory (AD), and therefore you can only main-
tain them in Active Directory.

How many contact types do you need?
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Your organization should keep the types to an operational minimum. You should always
name new contact types in a clear and unambiguous manner to ensure that users of
WorkZone Client and Captia Web Client cannot be in doubt which contact type to select when
creating a contact.

Examples of needs for new contact types:

« Compliance with rules and regulations, for example, CPR or CVR.
« Domain knowledge or entities, such as houses, property, employees, memberships.

« Simplification, for example, merger of two companies or to remove redundancy when
commencing a new archiving period.

contact types - the simple model

If no special reasons apply, it may only be necessary to add two types to the list of mandatory
contacttypes: P, PersonsandC, Companies.

Create an contact type

You can create two different types of contact types; either one with automatically generated ID
(Auto id), or manually entered ID.

Create with auto ID

Create a contact type with auto ID

1. Click Basic Data > Contact.
2. Click the empty bottom cell of the column Name type.

3. Enterthe value of the new contact type.
You can enter one character into the cell - a letter between A and Z or a digit
between 1 and 9.

4. Clickin the Auto id cell.

5. Click once more in the cell and select J in the list (J = Yes).
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6. Inthe column Text, enter a descriptive name for the contact type.
7. Inthe column Comment, enter a description of its use.

8. Place the cursorin another cell and click Database > Save.

If your system is running in multi language mode, you must also add the culture specific
texts and comments in the bottom panel.

Create with Manual ID

Below is described how to create a contact type with manually entered code, thatis ID.

Example

You must create a contact type with personal identification number (CPR-number). When
the users in WorkZone Client or Captia Web Client create a contact with CPR-number,
they must use this particular contact type.

Create a contact type with manual ID

1. Click Basic Data> Contact.
2. Click the empty bottom cell of the column Name type.

3. Enter the value for the new contact type, e.g. P.
You can enter one character into the cell - a letter between A and Z or a digit
between 1 and 9.

Click the cell Code check.
Click the drop-down box button of the cell.

Select an contact type, for example CPR number.

N oo g &

Click the Display Format cell twice. Enter the display format - in this example
XXXKXXK-KXXX.

&

Click in the cell Name Code Length twice.

9. Enter the maximum number of characters/digits of the code.
In this example 10 (the dash is not counted).

10. Inthe column Text, enter a name for the contact type.
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11. In the column Comment, enter a description of its use.

12. Place the cursorin another cell and click Database > Save.

If your system is running in multi language mode, you must also add the culture specific texts
and comments in the bottom panel.

See also Contact type meta data.

Edit a contact type

You can edit information concerning existing contact types. You can edit all cells, except the
cell Name Type, which is the ID of the contact type.

How to edit contact types

1. Click Basic Data > Contact.

2. Inthe upper panel you can edit all the cells that are not greyed out, and in the bot-
tom panel you can edit Text and Comment cells.

3. Make your corrections.

4. Place the cursor in another cell and click Database > Save.

Delete a contact type

You can delete contact types which have never been used.

By mistake you have created the contact type F with the descriptive name Farmer now this
must be removed.

How to delete contact types

1. Click Basic Data > Contact.

2. Click in the cell to the left the contact type you want to delete.
The row is highlighted.
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3. Click Edit > Delete Row.

4. Click Database > Save.
The contact has been removed.

Contact type meta data

Contacts are identified by their unique ID. The ID is composed of two parts i.e. the Contact
type and a Code. The contact type is Name type and the code is the sequence number.

In the Contact module you can register the following information:

Column Description

Panel:
Cells of contact types
Upper panel

The address type is identified by one character.
Valid characters are letters from A to Z and num-
bers from 1 to 9 (both included).

Name type You cannot use the letters A, M, K, and U. They
are reserved by the system: A = organizational
unit, M = employee, K = municipality (local gov-
ernment) and U = committee.

The last number issued to the contact type in

Last Used Code o _
question, if the counter mode is J (= yes).

The following counter modes are available:

o J(=yes)-The ID is an automatically gen-

Auto id erated sequence number.

e N (=no) - You must enter the code manu-
ally.

An empty cell = N.

If the chosen Auto id was N, or left empty, you can
Code Check select a suitable control from the list in the cell
Code Check.
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Column Description

List of controls

By default you can only select the controls in
bold, remaining controls depend on the cus-
tomization of your installation:

« Nothing - the manually entered code is
subject to no control.

« Numeric - the manually entered code
must be numeric.

« CPR Number - the code entered is auto-
matically controlled according to the mod-
ulus 11 control*).

The Central Office of Civil registration
(CPR) by October 2009 discontinued the
modulus 11 compliancy.

« SE Number - the code entered is auto-
matically controlled according to the mod-
ulus 11 control.

« External SE number - SE number cre-
ated in an external database.

« External CPR number - CPR number cre-
ated in an external database.

o CPR Number

o Property Number

o CPR Number (KU-MatrikelStyrelsen)
» Birthday and Sequence Number

« 9digit CPR Number - 9 digit CPR num-
ber

« CPR Number (Faergerne) - CPR num-
ber used on the Faroe islands - 9 digit
CPR number)
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Column Description

Display format

Name code length

Access Code

Text

« CPR Number (fictitious) - fictitious cpr-
number - day of birth dash sequence
number.

« Matrikel Number (Land register number)
o CVR Number (Legal units)

o CVR Number (Production Units)

o CVR Number (Legal an Production units)
« CPR Number (No modulus 11 check)

o CPR Number (Feergerne, No modulus 11
check)

If the code must be entered according to a special
format, enter the pattern here. If the code is a CPR
number, the format entered here must be 10 Cap-
ital X's with the birthday and sequence number
separated by a dash: XXXXXX-XXXX.

If the Auto id was N (= no) or left blank, you can
enter the number of digits assigned to the num-
ber. The name code can be up to 11 digits in
length.

If you fill in this cell, contacts created with this con-
tact type are subject to restrictions. Only users
with the proper authorization have access to see
these contacts.

You can enter an access code. It must exist in the
access_code domain to be valid.

The access code entered here is transferred to
every contact created with this contact code.

Enter the specific description of the contact type
here. Up to 32 characters. For contact type, for
example,C, Company.
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Column Description

In this cell you can write an elaborated descrip-
Comment )

tion - up to 240 characters - of the contact type.

The panel is displayed when the program is work-
Panel: ing in multi language mode. Here the culture spe-
Bottom panel cific names of the values of contact types are

displayed and managed.

Enter the culture specific description of the con-
tact type here. Up to 32 characters. For contact

type C, Company.
Text
This is the type displayed in the Captia Web Cli-

ent user interface according to the language selec-
ted by the user.

In this cell you can write an elaborated culture
Comment description - up to 240 characters - of the contact

type.

In this cell, the culture code of the current contact
Culture type, defining the language for the Text and Com-
ment cells.

The current language code (i.e. default lan-
guage).

Source

If a start date is specified , the value will be avail-
Start date able in WorkZone Client and the Captia Web Cli-
ent from this date forward.

If an end date is specified, the value will be avail-
End date able in WorkZone and Captia Web Client until
this date occurs.

The Stopwords Module

The Stopwords module manages lists of words to be disregarded in free text searches. The
words registered in the Stopwords module are ignored when a free text search is executed in
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WorkZone Client or Captia Web Client.

Prerequisites for managing stopwords

The prerequisite for gaining access to the Stopwords module is the access code
DATAADM.

Click Basic Data > Stopwords to open the module. The Stopwords lists already registered
in the module are displayed in the left panel.

Default system stopword lists

The Stopwords module contains by default only one list of stopwords per culture.

Custom stopword lists

To add stopwords you must create a new stopword list specific for your organization and/or
culture.

Create a custom stopword list

1. Click Basic Data > Stopwords.
2. Click the empty bottom cell of the Stopword List column.

3. Enter the name of the new stopword list. The cell allows for names of max-
imum 30 characters.

4. Clickin the List Type cell and select Custom from the list.
5. Click Database > Save.

6. The dialog box "You must activate the stopword listin Oracle before the stop-
words are used." is displayed. Click OK to continue.

Create stopwords
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1. Click Basic Data > Stopwords.
2. Click the Stopword List in which you wish to create stopwords.

3. Click the leftmost cell of the row. The contents of the list is displayed in the right
panel.

4. Click in the empty cell of Stopword column in the bottom row.
5. Enter stopword. Maximum 80 characters.

6. Place the cursorin another cell and click Database > Save.

Create Corporate Access Codes

Use the procedures below if you want to apply a corporate access code to a contact or to a file
class in WorkZone Configuration Management, and it is the first time that this corporate
access code is used.

If you want to create a simple corporate access code, such as (<Term Access Codes>&<0rg.
Access Codes>), you can do itin WorkZone Configuration Management in the Basic Data
module. See Create a simple corporate access code.

As regards a combined corporate access code, such as (<Term Access Codes>&<0Org.
Access Codes>)|(<Term Access Codes>&<O0rg. Access Codes>), you must create it in
WorkZone Client or Captia Web Client first and then select itin WorkZone Configuration Man-
agement. See Create a combined corporate access code.

Create a simple corporate access code

1. Click Basic Data > Create corporate access code.

2. Select one or more term access codes in the Term Part panel and one or more
organizational access codes in the Organizational Parts panel, and then click
Save. A message shows the access code that you just defined.

3. Click OK to create the organizational access code, or click No if you want to
return to the Create corporate access code page to make corrections.
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Create a combined corporate access code

WorkZone Client

1.

In WorkZone Client, open a search page for any item such as a case, doc-
ument, or contact.

Click Read access to open the Edit read access dialog box.
Click Create new access code.

Create the new combined access code, and click Apply. The nhew combined
access code has been created. You do not need to perform the search in
WorkZone Client.

Open WorkZone Configuration Management. The combined access code that
you just defined is now available on the Access Code lists in WorkZone Con-
figuration Management.

Captia Web Client

In Captia Web Client, open a search page for any item such as a case, doc-
ument, or contact.

Click Acc. code to open the Select - Acc. code dialog box.

Create the new combined access code, and click OK. The new combined
access code has been created. You do not need to perform the search in Cap-
tia Web Client.

Open WorkZone Configuration Management. The combined access code that
you just defined is nhow available on the Access Code lists in WorkZone Con-
figuration Management.

The Terms Module

The Terms module is a tool for the KMD technicians only. The Terms module contains

texts used in the user dialog.
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The Terms module is the user interface for the TERMS register. The Terms register is sub-
divided according to the part of the WorkZone system that itis covering CLIENT, DOCINT,
SOM.

prerequisite

The prerequisite for gaining access to the Terms module is that you have the access code
TERMSADM.

Examples
Module
Id Culture Text
type
SOM USERMSG _FILE da-DK  Sagen er afsluttet og kan derfor ikke
CLOSED ajourfares.
en-GB Case is closed and so, cannot be updated.
Meta data

Information Explanation

Module type The field is a list box. Here you have the following options:

o« CLIENT

« DOCINT

« SOM
Id The unique identification of the individual item in the terms register.
Culture Language/culture code for example eng-UK, da-DK.

One line per language.

Text The text that is displayed for the user.
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Example

Module
Id Culture Text

type

CLIENT JS_RECORD_REJOURNAL_ da-DK Flytning fejlede for nogle af dok-
MOVE_ERROR umenterne

en-GB Move failed for some of the doc-
uments
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Categories

This section describes how to work with categories.

The Classification Scheme Module ... . 85
The Facets-based Classification Scheme Module ... ... 98
The Subnumbers Module ... .. 107
The Dictionaries Module ... .. .l 115

The Classification Scheme Module

The Classification Scheme module manages the hierarchically ordered decimal classification
system. The individual items in the classification scheme are called classes.

Click Categories > Classification Scheme to open the Classification Scheme module.

About the classification scheme

Some organizations are bound by government regulations and must therefore comply with cer-
tain rules and regulations which dictate a certain configuration. Other organizations may
choose a classification scheme that is closer to the way their business is organized or the
business workflow itself.

Traditionally the classes have been organized into ten main classes. These are each divided
into ten divisions, and each division into ten sections. This giving 10 main classes, 100 divi-
sions and 1000 sections.

The classification scheme is in many ways equivalent to the decimal classification systems
employed by the public libraries, for example, the Universal Decimal Classification system.

Each class is identified by a decimal number representing the subject content. Each class has
a description of the subject content.

The purpose of a classification system
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The purpose of a classification scheme is to organize the cases handled in WorkZone Cli-
ent and Captia Web Client and the purpose of the classes and the subdivision is to facil-
itate retrieval of the cases and the documents.

Often the class is a part of the case number. The classes are subdivided in to as many
levels as a class' subject dictates, that is cases are created on the lowest level on the most
specific class, representing the subject and content of the case matter.

Prerequisites for managing the classification scheme

The prerequisite for gaining access to the Classification Scheme module is the access
code DATAADM.

Mandatory system owned classes

Some classes are mandatory and system owned. Do not remove these classes.

« SJ-STD contains all desktop cases i.e. when a new user logs on to Captia Web
Client for the first time a desktop case is created. The desktop case is hamed SJ-
STD-<username> for example SJ-STD-ABC.

o SJ-TEST is used for test purposes.

o SJ-SYSTEM contains and owns SJ-STD and SJ-TEST.

o SJ-TEMP is used by WorkZone Explorer and WorkZone Meeting.
o SJ-AGENDA is used by WorkZone Meeting.

Classification scheme meta data

You can register different types of information in the classification scheme:

« Information describing the class.

Information regarding filing periods.

Information concerning default data transferred to the case when itis created.

« Information transferred to the documents of the case when they are created.
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In the table below is shown the data that can be registered in the classification scheme mod-
ule describing a class.

1 2
3
£ 5
Panel Cell Description
1 This panel displays the case classification scheme. The scheme is

presented in a hierarchy that you can expand and collapse by click-
ing on +.

Case Clas- When the Classification Scheme module is displayed, the clas-
sification sification scheme is displayed in the left panel:

« Classes atroot level and superior levels, which are not to be
used for classifying cases are shown in red. Click the plus
sign to expand the hierarchy and view the underlying levels.

« Classes used in case creation are shown in black.

2 This panel contains basic data and functions of the class.

Class The class number.

The classes are the individual items that together constitute the clas-
sification scheme.

Title The title of the class entry.

Sub-number If the check box in the Fixed SubNumber cell is selected, this cell
type must be checked as well.

Select the value for Sub-number type in the drop-down list. The
selected value defines which domain of sub numbers is attached to
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Panel Cell

Description

the class.

Case creation The check box offers two options:

Fixed
SubNumber

Free Case
Number

« The check box is selected: The users of WorkZone Client
and Captia Web Client are permitted to create cases with
the current class. The class is shown in black.

« The check box is cleared: The class is not available for case
creation in WorkZone Client and Captia Web Client. The
class works as a heading for branch of the hierarchy and is
shown in red.

The check box offers two options:

« The check box is selected: The class must be subdivided by
a sub number. When the users in WorkZone Client and Cap-
tia Web Client create a case with the current class they are
prompted to select a sub number.

When this check box is selected, the option Sub-number
type must be selected as well.

e The check box is cleared: Sub numbers are not used for this
class.

The sub numbers must preexist in the Subnumbers module and
each subnumber domain containing the sub numbers must preexist
in the Custom domain module.

The check box offers two options:

« The check box is selected: Cases created with this class
must be numbered manually. The user in Captia Web Client
must enter the case number into the field thus defining the
unique ID of the case.

e« The check box is cleared: Case numbers are inserted auto-
matically according to the method chosen, except for CPR-
numbers.
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Panel Cell Description

Creation of free case number is not supported in WorkZone Client.

Start Date Enter the date from which the class should be enabled.
End Date Enter the date of termination.

3 In this panel the culture specific titles of the classes are displayed
and managed. The culture specific title of the current class is main-
tained here.

Title The title of the class entry - that is the name of the class.

Description  Enter a description of the class.

Culture The culture code of language to be used for the title.
Source The current language code (the default language).
4 The panel displays case information. The information registered here

is automatically inserted into the corresponding fields of the case
details page in Captia Web Client and Captia Web Client when the
case is created.

This panel also contains filing period data.

o Do notfill in the field unless required.

« The section is only active if class and title is shown in its
header.

Type Select the case type from the list. The case types come from the cus-
tom domain ST, Case type.

Responsible Select the organizational unit that you want to apply as responsible
ou unit to the current case class. You can also select @Unit to apply the
unit of the user who creates cases in the specific case class.

Executing OU Select the organizational unit that you want to apply as executing
unit to the current case class. You can also select @Unit to apply the
unit of the user who creates cases in the specific case class.

89



WorkZone Configuration Management 2021.2

Panel Cell Description

Case Handler Select the employee that you want to apply to the current case class.
When new cases with this case class are created, the selected
employee is applied automatically as case handler. You can also
select @Me to apply the current user who creates the case in the
specific case class as case handler.

Access Code This access code determines which users are allowed to see and
use this class.

Select the access code that is relevant for the class from the list.
Default If you select an access code, it will automatically be inserted into all
access code cases created with the current class.

The default access code determines which users are allowed to see
this case.

Default If you select an update code, it will automatically be inserted into all
update code cases created with the current class.

The default update code determines which users are allowed to edit
this case.

Mask The purpose of Mask to allow you to assign special case number
formats to individual classes.

Some case number formats only work if the Create Case page in
Captia Web Client is customized.

To configure case number masks, see About the case number mask.

Cover Enter the name of the case cover to be printed for cases in this class.
Response This section concerns reply deadlines.
limit for

In Captia Web Client Response limit is called Reply deadline and a

records record is a document.

First record Fixed response limit for the first record
In this cell, you can enter a number.

When the user archives the first document of a case in WorkZone Cli-
entand Captia Web Client, a date is automatically inserted into the
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Cell Description
Reply deadline field of the document.

If you type 14, the deadline would be 14 days after the date of regis-
tration.

Following Fixed response limit for the following records.

records In this cell, you can enter a number.

When the user archives the next document of a case in WorkZone
Client or Captia Web Client, a date is automatically inserted into the
Reply deadline field of the document.

If you type 28, the deadline would be 28 days after the date of regis-
tration.

Draft Ver- This section allows you to apply draft versioning to a class.
sioning

Apply draft Select this check box to apply draft versioning automatically to new
versioning cases in this class. See Apply draft versioning.

automatically

to this class

Filing Period This section is for information concerning the shift from one clas-
sification period to another. Here you can enter information facil-
itating a shift from one period to another.

Previous Class in the previous classification period.
Case Class

Previous Sub- Sub number type in the previous classification period, i.e., archiving
number Type period.

Upcoming Class in the next classification period.

Case Class

Upcoming Sub number type in the next classification period.

Subnumber

Type

Disposal Code defining the preservation and disposal rules in force for the
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Panel Cell Description

Code class.

Transfer Code Code that specifies how cases and documents in the current class
are transferred to the next classification period.

Bottom right, Information automatically transferred to a case at creation.
right side
panel

The purpose of this function is to minimize tedious registration work.
Typical cases subject to a standardized case handling process, such
<Class and as complaints, call for standardized registration.

title> With this function you can have certain basic data inserted auto-

matically into all new cases of this type.

5 Info On this tab you can register several entries of supplementary case
information.

Each row contains two cells:

« The Label cell is a drop-down box. The contents of the drop-
down box originates from the custom label module label
type SO, Suppl. case.

« The Information cell is a free text field or a drop-down box.
This depends on the label selected for the cell Label.
See - Routine and -Custom label types and data fields.

Normally the information is entered by the case handler who
selects the relevant information during the case handling process.

In Captia Web Client

When a user creates a new case with the current class, these entries
are automatically inserted. The user can see and update the entries
in the bottom section of the case details page - click More ... > Inform-
ation.

Date On this tab you can register several entries of supplementary case
dates.
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Panel Cell Description

Each row contains one cell. The Label cell is a drop-down box. The
contents of the box originates from the custom label module label
type SD, Suppl. case dates,see also Dates.

Normally the dates are entered by the case handler during the case
handling process.

In Captia Web Client

When a user creates a new case with the current class, these entries

are automatically inserted. The user can see and update the entries

in the bottom section of the case details page - click More > Dates.
Keywords On this tab you can register several entries of keywords.

Each row contains one cell. The Keyword cell is a drop-down box.

The contents of the list originates from the Dictionary module.

Contacts This tab contains rows with three cells:

« Contact type (also called contact type) - for example, Per-
son with CPR-number

» Contact code (also called Sequence number) - for example
180562-5903

« Role -for example Applicant, Replicant and so on.

You can insert several rows. You can insert rows with only a role or
rows with both role and a specific contact.

In Captia Web Client

When a user creates a new case with the current class, these rows
are automatically inserted. The user can see and update the rows in
the bottom section of the case details page - click More > Parties.

Create a class

Always activate the class of the level above the level where you want to create a new class.
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Example

As an example, if you wish to create class "322, Internally financed projects," you should
startin class 32. The classification scheme of your organization is constructed in such a
way that classes at root level consist of one digit, classes directly subordinated consist of
two digits, and classes at the lowest level consist of three digits:

3 Physical working conditions

32 Projects concerning building and construction

322 Internally financed projects

create a class

1. Click Categories > Classification Scheme.

2. Inthe left panel, click the class above the class level in which you want to cre-
ate classes.

3. Inthe upper right panel, click the empty bottom cell of the column Class.

4. Click the cell once more and enter the number of the new class.

5. Click the Title cell. Click the cell once more and enter the name of the class -
in this example "Internally financed projects".

6. Selectthe check box of the cell Case Creation.
If your class is just a "level" and not an active class, leave it unchecked. Fill in

the following cells only if your class requires it: Fixed Subnumber, Free Case
Number, Start Date, and End Date.

7. Click Database > Save to save the class and the basic information.

If your system is running in multi language mode, you must also add the culture specific
tittes in the right middle panel.

add information transferred to cases at creation
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Add file information

Use the bottom left panel and the bottom right panel to add file information.

1. Click to the left of the class in the upper right panel.

2. Inthe File Information section, fill in the fields as necessary.

« Mask - only fill in this field if the case number format of this particular class should
deviate from default.

« Cover - use this if you have a physical paper archive with special case folders. Fill in
the name of the report holding the case folder template. Now you can print case
folders with case information for the archive.

3. Click Database > Save.

Add response limit for records

Use the bottom left panel and the bottom right panel to add response limit for records.

1. Click the First record field to enter the number of days to be inserted into the doc-
ument meta data that is in the Reply deadline field in the document details page
in Captia Web Client.

When the meta data in Captia Web Client are saved in the reply deadline date
will be postdated 21 days if you entered "21".

2. Enter data into the field Following records in the same way. This affects all other
documents than the first document.

3. Place the cursor in another cell and click Database > Save.

Add information, date, keywords, contacts

Use the bottom right panel to add Info, Date, Keywords and Contacts.

1. Click the relevant tab, for example the Info tab.
2. Click the empty cell in the Label column and select a label from the list.

3. Repeat this procedure to add more rows.
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4. Place the cursor in another cell and click Database > Save. Use the same pro-
cedure to add rows on the other tabs.

For description of the above-mentioned cells, see About meta data.

Edit a class

You can edit all information concerning a class except Class. The content of this cell is the
unique ID of the Class. As soon as the newly created class has been saved, the cell is
locked for editing.

How to edit a class

1. Click Categories > Classification Scheme.
2. Inthe left panel, click the class a level above the class to be edited.

3. Click to the left of the cell of the class to be edited.
The class and all the panels are now active.

4. Click in the cell or cells you want to edit (some cells such as Subnumber type
and dates must be clicked twice)
5. Make the changes.

6. Place the cursorin another cell and click Database > Save.

Description of the cells that can be edited - see About metadata.

Terminate or delete a class

If the area of responsibility of the organization changes, some classes might have to be ter-
minated. Fill in the End date cell to terminate the classes and possibly a future date. You
can delete classes that are never used.

terminate a class
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1. In the Classification Scheme Hierarchy panel to the left, click the class a level
above the class to be terminated.

2. Click twice in the End Date cell and enter the date of termination.

3. Place the cursorin another cell and click Database > Save.

The class can no longer be used to create cases, however it can still be used
as a search criteria.

delete a class that has never been used

1. In the Classification Scheme Hierarchy panel to the left, click the class a level
above the class to be deleted.

2. Click to the left of the class you want to delete.
3. Click Edit > Delete Row.

4. Place the cursor in another cell and click Database > Save.

Apply draft versioning

You can apply draft versioning to new cases in a class.

apply versioning

1. Click Categories > Classification Scheme.
2. Select the class to which you want to apply draft versioning automatically.

3. Inthe bottom left panel, go to the Draft Versioning section, and select the Apply
draft versioning automatically to this class check box.

See Draft versioning
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The Facets-based Classification Scheme Module

In the Facet-based Classification Scheme module you can manage the facet scheme. The
facet scheme is a hierarchically ordered keyword classification system. It is a system of
keywords consisting of coordinate groups of keywords, describing an area of responsibility
within the organization.

Click Categories > Facet-based Classification Scheme to open the facet based clas-
sification scheme.

See also Classification Scheme

About facets

Facets can be employed in two ways, either as a supplement to the Classification Scheme

or instead of a classification scheme. If you employ it as the classification tool of your organ-
ization, its purpose is similar to that of a classic classification scheme, however with more
focus on domain keywords - belonging to more than just one area - as opposed to the more
rigid registration on just one class.

The default interface for facets is implemented on the details pages of cases and/or doc-
uments in WorkZone Client and Captia Web Client at installation. The default configuration
is four fields for facets. One field for each root facet and its branches of keywords. More (or
fewer) root facets can be implemented, however this requires special configuration and cus-
tomization of the details pages.

Prerequisites for managing Facet-based Classification Scheme

The prerequisite for gaining access to the Facet-based Classification Scheme module is
the access code DATAADM.

See also Classification scheme.

Facet meta data

The table below displays the information you can enter to describe facets.
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The below description is that of a default installation. If you have a customized facet install-
ation, please refer to your scope documentation as your implementation may differ from the
below description.

Panel Cell Description

Left panel This panel displays the facet based classification scheme.
The scheme is presented in a hierarchy where you can
expand and collapse levels by clicking on +.

Facet Clas- When the Facet-based Classification Scheme module is dis-
sification played, the facet classification scheme hierarchy is shown in
the left panel:

« All facet levels leading towards facet words are
shown in red; the facet words are shown in black.

o The facet tree is expandable from the level of Root
facets to Facet groups to Facet words.

» Facetwords are the registration level.
Click the plus to expand the hierarchy to display the sub-

ordinate facet groups and their facet words. Click the minus to
collapse the hierarchy and hide the subordinate facets.

Upper right In this panel, you register basic data and functions of the
panel facet.
Facet<Facet
and title>
Class In this cell the facet is entered.

The facets are the individual items that together constitute
the facet classification scheme thesaurus-hierarchy. When
you have saved a new facet, you cannot change it any more -
itis the unique ID of the class.

Title The title is the facet word, for example the key word that is
shown to the end user in WorkZone Client and Captia Web
Client.

Priority Enter a number here. The number entered defines where the
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Panel

Cell

Case creation

Universal

Mandatory

Start Date
End Date

Access Code

Default
Access Code

Description

class (that is the facet) is displayed in a list of classes (that is
the facets).

« When the check box is selected, the users can add
this facet to cases. The facet is shown at the lowest
level of the root facet. This word will be shown in
black.

« When the check box is cleared the users cannot add
this facet to cases. The facet is either a root facet or a
group facet guiding the user towards the facet words.
These words will be shown in red.

By default Universal is not employed.

Universal is only in effect with specific customizations. When
a root facet, for example, is marked as universal, no more
than one facet of this type is allowed on a particular case or
document.

By default Mandatory is not employed.

Mandatory is only in effect with specific customizations.
When a root facet, for example, is marked as mandatory, at
least one facet of this type must be registered with the case or
document.

The date determines when the facet is available for use.
The date determines when use of the facet is terminated.

If you select an access code, the facet will only be displayed
for users with this access code.

If you are using corporate access codes, you may choose
only group access codes in this field.
By default Default Access Code is not employed.

Default Access Code is only in effect with specific cus-
tomizations. If you select an access code, it will automatically
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Panel Cell Description

be inserted into all cases created with the current class.
The default access code determines which users are allowed
to see this case .

Default By default Default Update Code is not employed.

Update Code Default Update Code is only in effect with specific cus-
tomizations. If you select an update code, it will automatically
be inserted into all cases created with the current class.

The default update code determines which users are allowed
to edit this case.

Middle right In this panel, the culture specific titles of the facets are dis-
panel played and managed. The culture specific title of the current
class is maintained here.

Title The culture specific name of the facet.

Culture The culture code of language to be used for the title.

Source The current language code (the default language).
Working with facets

The facet scheme is composed of groups of facets. At the top level are the root facets and
below the hierarchy of groups of facets. At the bottom level are the facets used for char-
acterizing cases and documents.

By default the system contains 4 root facets. The facets of each root facet can be organized in
several sub levels.

By default the WorkZone Client and Captia Web Client details pages for cases and doc-
uments can contain fields for the four root facets and their hierarchies of facets. More or fewer
root facets can be implemented, however this demands special configuration of the details
pages.

Example - a root facet with two levels
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The root facet in the example below is Country. On the second level in the facet scheme
are continents, for example, Africa and Europe. The facet words are the individual coun-
tries - in this example, three countries in each continent.

F10, Europe F10001, Denmark
F10002, Holland
F10003, Portugal
F20001, Morocco
F20002, Kenya
F20003, Angola

The Captia Web Client user navigates the facets from a pop-up dialog from one level to the
next or searches for a specific facet word. The Captia Web Client user then selects the
facet words that characterized the current case or document.

In this example, the facets on the lowest level - facet words, for example, Angola or Por-
tugal, are the facets the Captia Web Client user would use in characterizing the entity.

How to enter the facets in module Facet-based Classification
Scheme

In the table below is shown how the cells are filled in:

Root facet: Coun- Facet group: Facet word: Den-
try Europe mark
Class Facet1DB F10 F10001
Case Creation cleared cleared Selected
Universal *) *) *)
Mandatory *) *) *)
Access Code optional optional optional
Default Access ) *) *)
Code
Default Update *) *) *)
Code
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Root facet: Coun- Facet group: Facet word: Den-
113 Europe mark

Start Date optional optional optional

End Date

Title Facet1DB Europe Denmark

Text Country Europe Denmark

*) By default notin use.

Create facets

The facet scheme is arranged as a hierarchy. At the top level are the root facets. Below each
root facet you can build a hierarchy of facets. By default, four root facets are at your disposal. If
more or fewer are needed, the details pages must be customized.

In the table below is a description of the general process of registering the facet scheme:

1 First create the 4 root facets. The four root facets are: Facet1DB, Facet2DB,
Facet3DB, Facet4DB.

Note: All four root facets must preexist in the module to make the facet func-
tionality work properly. Even if you only employ, for instance, two of the root
facets.

When you create a root facet, enter the name into the ID cell named Class, for
example Facet1DB

The name of the root facet, for example Facet1DB, must be entered into the Title
cell in this example "Country".

However, unless Facet1DB, is configured in the customijs. js file, Facet1DB
will be what meets the end user in WorkZone Client and Captia Web Client! The
name entered into the title cell is NOT displayed for the users in WorkZone Client
and Captia Web Client
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2 Secondly you must enter the next level of facets. If it is a very small facet scheme,
you could enter the facets used as keywords here.

Ifitis a larger facet scheme, enter a set of facet groups here. For example, the
continents - Africa, Asia, Europe etc.

3 Thirdly add a new level (group facets) or enter the facets used as keywords - for
example, the countries Algiers, Morocco, Tunisia, etc.

If you operate with both a classification scheme and facet based classification scheme, the
IDs of the facets must not coincide with the IDs of the classes.

Creatlng facets

Create root facets

1. Click Categories > Facet-based Classification Scheme.
2. Inthe left panel, click Case Classification.

3. Inthe upper right panel, click in the empty cell of the column Class and enter
the ID of the first root facet, in this example Facet1DB.

4. Click twice in the Title cell and enter the name of the facet, in this example
Country.

5. In the Start Date cell, enter the initiation date.
6. Place the cursorin another cell and then click Database > Save.

7. Repeat this procedure to create the other root facets. If no facet groups are
needed, proceed to Create facets below.

If your system is running in multi language mode, you must also add the culture specific
titles in the lower right panel.

Create facet groups
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1. Click Categories > Facet-based Classification Scheme.

2. Inthe left panel, click the root facet you want to work with, in this example
FacetlDB.

3. Inthe upperright panel, click in the empty cell of the Class column and enter the
ID of the facet group, in this example F10.

4. Click twice in the Title cell and enter the name of the facet group, in this example

Europe.
5. In the Start Date cell, enter the initiation date.
6. Place the cursor in another cell and then click Database > Save.

7. Repeat the procedure to create the other facet groups.

If your system is running in multi language mode, you must also add the culture specific titles
in the lower right panel.

Create facet words

1. Click Categories > Facet-based Classification Scheme.

2. Ifyou recently created facet groups, it is prudent to click Database > Refresh to
update the facet hierarchy.

3. Inthe left panel, click the plus of the root facet that you want extend, in this
example Facet1DB.

4. Now, click the facet group that you want work with, here Europe.

5. Inthe upperright panel, click in the empty cell of the Class column and enter the
ID of the facet word, in this example F100.

6. Click twice in the Title cell and enter the name of the facet word - in this example

Denmark.
7. In the Start Date cell, enter the initiation date.
8. Place the cursor in another cell and then click Database > Save.

9. Repeat the procedure to create the other facet words.

If your system is running in multi language mode, you must also add the culture specific titles
in the lower right panel.
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Edit facets

You can edit all information concerning a facets except for the Class. The content of this
cell is the unique ID of the class, that is the facet. As soon as the newly created facet has
been saved, the cell is locked for editing.

Edit a facet

1. Click Categories* Facet-based Classification Scheme.

In the left panel, click the facet level above the facet to be edited.

Click to the left of the cell of the facet to be edited.

W N

Click in the cell or cells you want to edit (some cells like dates and codes must
be clicked twice) and make the changes.

5. Place the cursor in another cell and then click Database > Save.

Description of the cells that can be edited - see About meta data.

Delete or terminate facets

If the area of responsibility of the organization changes, some facets may have to be ter-
minated. Fill in the end date cell to terminate the facets or, if convenient, a future date. You
can delete facets that are never used.

terminate a facet

1. In the left panel - Facet-based Classification Scheme Hierarchy - click the
facet a level above the facet to be terminated.

2. Click twice in the cell End Date and enter the date of termination.

3. Place the cursor in another cell and then click Database > Save.

The class can no longer be used to create cases but it can still be used as a search
criteria.
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delete a facet that has never been used

1. Inthe left panel - Facet-based Classification Scheme Hierarchy - click the facet a
level above the facet to be deleted.

2. Click to the left cell of the row of the class you want to delete.
3. Click Edit » Delete Row.

4. Place the cursor in another cell and then click Database > Save.

The Subnumbers Module

The Subnumbers module manages subnumbers. Subnumbers are used for subdividing
classes - in the module Classification Scheme.

Click Categories > Subnumbers to open the module.

About subnumbers

The Subnumbers module manages subnumbers. Subnumbers are used for subdividing
classes in the Classification Scheme module. For example, the class "4507, Bicycle roads"
must be subdivided according to a municipality code. Each municipality is identified by a
unique code. A custom domain must be created to contain the municipality codes and the
codes registered in that domain.

Lastly the dependency between the class, in the classification scheme, and the domain must
be established.

Prerequisites for managing Subnumbers

The prerequisite for gaining access to the Subnumbers module is the access code
DATAADM.
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Configure subnumbers
To use subnumbers with the classification scheme, the following four preconditions must
be met:

o Subnumber domain types must be pre-created.

You must create domains for each set of subnumbers. This is done in the Cus-
tom Domain module. Create each subnumber type under the domain type entry
UT, Undernummertype.

« All subnumbers must be created in their respective domain types.
You must create each set of subnumbers in their specific domain types. This is

done in the Subnumbers module.

The case number format must be adjusted to contain Subnumbers.

You must enable the use of subnumbers in the configuration of your case num-
ber. This means that the code for subnumbers must be included in the case
number mask. This is done in the Owner module in the Case Number Format
field.

o The Classification Scheme must be set up to handle Subnumbers.

Finally, you must connect each subnumber type with the relevant class in the
classification scheme. This is done in the Classification Scheme module.

Create a subnumber domain

Some classes in the classification scheme are subdivided by subnumbers , for example,
municipalities. The class "4507, Bicycle roads" must be subdivided according to a muni-
cipality ID code. First a custom domain, that is a subnumber type, must be created to con-
tain the municipality codes, in this example MU, Municipality. It must be created in the
custom domain UT in the custom domain module - Basic Data > Custom Domain.

Create a subnumber
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With the subnumber type "MU, Municipality" in place, you nhow need to create each individual
subnumber - in this case, each municipality. You create these subnumbers in the Sub-
numbers module - Categories » Subnumbers.

Adjust the case number format

Then you may have to adjust the case number format to make allowance for subnumbers. The

case number format is set up in the Owner module in Case Number Format section - Oper-
ation»Owner.

In this example the case number format should be: 2009-4507/175-0003 - with 4507 rep-
resenting the class and 175 the municipality. The case bearing this number would then be the
3rd case regarding Bicycle roads (4507) in the Municipality of Rgdovre (175).

To configure the case number format to allow the use of subnumbers reflecting the example, it

should be:
aaaa—-gggqg (/uuu) -LLLL:

aaaa- =year, e.g. 2009 followed by a dash

gggg = class of max four characters, e.g. 4507

e (/uuu) =subnumber of max three characters, e.g. 175 starting with a front slash.
The parentheses signify that subnumbers are only used if specified in the Clas-
sification Scheme.

o -LLLL =sequence number of max four characters. The numbering is automatic and
proceeded by a dash. The capital L indicates that zeros are included with humbers of
less than four digits, e.g. 0003.

Establish A dependency between Subnumbers and Classes of the
Classification Scheme

Finally you have to link your subnumber domains to the classes in the Classification Scheme.
The dependency is made in the Classification Scheme module - Categories  Classification

Scheme.
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Locate the Class. Insert the subnumber type into the cell called Sub-number Type. Now
the class knows where to validate the subnumbers. If the subnumber should be com-
pulsory, the option Fixed SubNumber must be enabled.

Subnumbers in Captia Web Client

When users create a case selecting e.g. class 4507, they are prompted to select a sub-
number from, in this case, the domain MU, Municipality.

Create subnumbers type

You can use subnumbers to subdivide individual classes in the Classification Scheme. To
do this, you must create the necessary domains for the subnumbers. These domains are
subnumber types in the Custom Domain module. The subnumbers type must be created in
the UT domain.

Example

Lets say you need to create a subnumber type for Municipalities. You need to register muni-
cipality in order to subdivide certain classes accordingly.

create a subnumber

1. Click Basic Data > Custom Domain.
In the left panel select UT.
Click in the cell to the left of domain type UT.

Click the empty bottom cell of the column Code.

a b~ e b

Enter an identification code for the new subnumber type - maximum 8 letters.
(In this example the code entered is MU.)

6. Click the nextcell.

7. Place the cursor in another cell and click Database > Save.

If your system is running in multi language mode, you must also add the culture specific
texts in the lower right panel.
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Create a subnumber entry, see Create subnumbers.

Edit subnumber types

You can edit the following Subnumber Type information:

« Start date - you can change the date of initiation.
« End date - you can change the date of termination

« Text-you can change its description (max 65 characters).

edit a subnumber type

1. Click Basic Data > Custom Domain.

In the left panel, click the left most cell of the row UT.

In the upper right panel, click in the date cells of the subnumber to be edited.
In the lower right panel, click to edit Text cells.

Edit the data of the cell.

o g &~ W b

Place the cursor in another cell and click Database > Save.

Terminate subnumbers type

Subnumber types with subnumbers registered on cases in WorkZone Client and Captia Web
Client cannot be deleted. They must be terminated.

If a set of subnumbers is no longer needed, you must discontinue the subnumber type. Then
disconnect the subnumber type from the classes in the Classification Scheme.

terminate a subnumber type
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Click Categories > Subnumbers.
In the right panel, click to the left of UT.

In the upper right panel, click in the End date cell of the subnumber type you
want to discontinue.

Click once more to input the date of the discontinuation.

Place the cursor in another cell and click Database > Save.

disconnect a subnumber type from active classes

N o o &~ W

Click Categories > Classification Scheme.

In the Classification hierarchy, select the class from which you want to dis-
connect the use of subnumbers.

Click in the Subnumber type column, the cell to activate.
Click once more to open the drop-down box of the cell.
Select the empty line in the top of the list.

Clear the check box Fixed SubNumber.

Place the cursor in another cell and click Database > Save.

Create subnumbers

You can create new subnumbers. Subnumbers are grouped according to type. Each type

is created in the Custom Domain module under the domain type entry UT.

Example

You need to create a number of municipality subnumbers. Itis a prerequisite that the muni-

cipality subnumber type already exists in the custom domain.

create a subnumber
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Click Categories > Subnumbers.

In the top panel, click bottom row cell of the column Number Type.
Click once in the cell to activate the drop-down box.

Click the drop-down button.

Select the relevant value - in this example MU, Municipality.

Click in the adjacent cell of the Number column and enter the relevant code, in
this example 175.

Select the check box in the Create column to make the subnumbers available for
selection in the Child case group field in WorkZone Client and the Subnumber
field in Captia Web Client when creating new cases.

Place the cursor in another cell and click Database > Save to save the code.

Click the cell Text in the bottom panel and enter the description for the code, in
this example Radovre.

Place the cursor in another cell and click Database > Save.

You have now successfully created a new Municipal-subnumber in the subnumber domain

MU, Municipality.Repeat the procedure from step 2 to create additional subnumbers.

See also Create subnumber types.

Edit Subnumbers

You can editinformation about existing subnumbers. You can edit the cells Create and Text.

Example

If, for instance, the name of a municipality has been misspelled you have to correct the

spelling mistake.

edit a subnumber

1.
2,

Click on Categories > Subnumbers.

Select the code of the Municipality you want to edit in the Number column.

3. The text describing the code is shown in the bottom panel in the Text column.
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4. Click in the cell you want to edit.
5. Enteryour change.

6. Place the cursorin another cell and click Database > Save.

See also Edit subnumbers type.

Delete/disable subnumbers

You can delete existing subnumbers that have never been in use.

delete a subnumber

If, for example, a municipality was discontinued or merged with another. The municipality
has been created anyway by mistake. The municipality subnumber must now be ter-
minated.

1. Click Categories > Subnumbers.

2. Inthe Number column, click the number code of the subnumber you want to
delete.

Click the left most cell of the row. The row is highlighted.
Click Edit > Delete Row. The Subnumber is deleted.

Click in another cell.

o 0 o~ w

Click Database > Save. The entry has been deleted.

terminate a subnumber

A subnumber is no longer in use. It has been used for an extended period, so it cannot be
deleted. It must be disabled.

1. Click Categories > Subnumbers.

2. Inthe Number column, click the number code of the subnumber you want to
disable.
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3. Select the subnumber to disable.
4. Clearthe check box in the Create column.

5. Place the cursorin another cell and click Database > Save.
The subnumber is disabled.

The Dictionaries Module

In the Dictionary module you can manage keywords.

Click Categories > Dictionary to open the Dictionary module.

About dictionaries

In the Dictionary module you can manage keywords. When the dictionary is turned on, all
keywords used in WorkZone Client and Captia Web Client must be registered in the Dic-
tionary module. Words to be used as keywords must be created in the dictionary. The
keywords are used for characterizing cases and documents in WorkZone Client and Captia
Web Client.

When the dictionary is turned on, the WorkZone Client and Captia Web Client users must
select keywords for cases and documents in the dictionary. Thus the dictionary is meant to
hold the keywords allowed to be registered on cases and documents. The dictionary ensures
that only approved words can be applied.

You can create both keywords and synonyms for keywords. The synonym function is merely a
way of replacing words not approved for use. If you enter the synonym, it will automatically be
replaced by the correct word. INSECT POWDER for instance could be registered as a syn-
onym for INSECTICIDE. When INSECT POWDER is entered, it is automatically replaced by
INSECTICIDE.

Prerequisites for managing Dictionary

The prerequisite for gaining access to the Dictionary module is the access code DATAADM.
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Dictionaries meta data

The dictionary contains keywords. Keywords are used for characterizing cases and doc-
uments in WorkZone Client and Captia Web Client, and not least to facilitate retrieval.

A keyword is registered as two entries, that is a keyword synonym and a standard keyword.
If the keyword synonym and the standard keyword are identical, the word is a proper
keyword. If, on the other hand, the keyword synonym and the standard keyword are dif-
ferent, the word is a synonym.

The standard keyword is used on, for example, on cases or documents. The keyword syn-
onym on the contrary is automatically replaced by the standard keyword.

In the Dictionary module you can register the following information concerning keywords:

Data Description

Keyword Enter the keyword - that is the word that replaces the synonym.

Synonym Example

You want to register the word INSECTICIDE as a keyword. This means
that INSECTICIDE must be registered both in column Keyword Synonym
column and in the Standard Keyword column:

Keyword Syn-  Standard Key-

User Date

onym word
INSECTICIDE INSECTICIDE LOF 27-05-
2013

Standard Write the synonym - that is the word that is replaced by the keyword.

Keyword Example

You are to register the word INSECT POWDER as a synonym for
INSECTICIDE. This means thatthe word INSECT POWDER must be
registered in the Keyword Synonym column and the word to replace itin the
Standard Keyword column:
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Data Description

Keyword Syn- Standard Key-

User Date
onym word
INSECT INSECTICIDE LOF 27-05-
POWDER 2013

INSECTICIDE INSECTICIDE LOF 27-05-
2013

The word INSECT POWDER is now registered as a synonym. If a user in, for
example, the WorkZone Client case details page enters INSECT POWDER
i the keyword field, it will automatically be replaced with INSECTICIDE.

User The cell displays the ID of the user who initially created the keyword or the
synonym.

The ID of the user is by default automatically entered into the field when the
user registers a keyword.

The cell is locked and cannot be edited.

Date The cell displays the date when the keyword was registered.

The date is by default automatically entered into the cell. Hereafter the cell
is locked and cannot be edited.

Prerequisite

The prerequisite for using the Dictionary module is that it is pre-configured in the Owner mod-
ule.

In this module, you must decide whether you want to use the dictionary. If you want to use it,
you must:
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« Specify which characters are not allowed in connection with keywords.

« Enter a minimum number of characters a keyword must consist of.

See Configure the dictionary in the Owner module.

Create keyword

New entries in the dictionary are registered by a keyword synonym and a standard
keyword. If the entry is a keyword, the words entered in both cells must be identical. If for
instance, you want to register the word INSECTICIDE as a keyword, it must be entered
as a keyword synonym INSECTICIDE and a standard keyword INSECTICIDE.

register a new keyword

1. Click Categories > Dictionary.

In the Keyword Synonym column, click the empty cell in the bottom row.
Type the word.

Click the next cell in the Standard Keyword column.

Type the word again.

2L T

Select the Enabled check box. The check box must be selected before the
word can be deployed in Captia Web Client.

7. Click Database > Save. User name and date are filled in automatically.

Create synonym

To register a synonym in the dictionary, you must enter the synonym in the Keyword Syn-
onym column and the keyword in the Standard Keyword column. For example, you want to
register the word INSECT POWDER as a synonymto INSECTICIDE. Do this by entering
INSECT POWDER as the keyword synonym and INSECTICIDE as the standard keyword.

The synonym function is merely a control. It replaces illegal synonyms with the proper
keyword. If you, for example, enter INSECT POWDER into the Keyword field on the case
details page in WorkZone Client and Captia Web Client, INSECT POWDER will auto-
matically be replaced by the proper keyword which in this example is INSECTICIDE.
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Register a synonym

1. Click Categories > Dictionary.

In the Keyword Synonym column, click the cel in the bottom row.
Type the synonym.

Click the next cell in the Standard Keyword column.

Type the keyword to be used.

o g ~ b

Select the Enabled check box. The check box must be selected before the syn-
onym can be used in WorkZone Client and Captia Web Client.

7. Click Database > Save.

Delete or disable keywords and synonyms

You can delete existing keywords and synonyms.

This function has very extensive effects. When you delete an entry from the dictionary, then:

« ltis removed from the dictionary

« All occurrences are removed from entities in WorkZone Client and Captia Web Client
such as cases and documents.

delete keywords or synonyms

As an example, you want to remove the word PESTICIDE from the dictionary. It has been
registered on several cases and documents.

1. Click Categories > Dictionary.
2. Click the left most column of the entry you want to delete. The row is highlighted.

3. Click Edit > Delete Row.
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If the entry is in use in WorkZone Client or Captia Web Client, a message
displays: "Do you want to delete the keyword '<keyword>' and the <nn ref-
erences to it?"

4. Click OKto accept. The row disappears.

5. Click Database > Save. The entry (and its references in WorkZone Client or
Captia Web Client) have been removed.

disable keywords/synonyms

If you wish to keep its references but discontinue any future use, you should use the dis-
able the keyword or synonym.

1. Click Categories > Dictionary.
2. Clearthe Enabled check box of the entry you want to discontinue.

3. Place the cursor in another cell and Click Database > Save. The entry is dis-
abled from active use in WorkZone Client and Captia Web Client, but its pre-
vious references are kept.
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The Register Security Module

The Register Security module manages the permissions of WorkZone users' access to tables
and registers of the system database.

Click Security in > Register Security to open the module.

About Register Security ... .. 121
Register security metadata ... .. .. 123
Permissions for registers andtables ... .. .. .. ... 124
Registers and tables ... . ...l 126
PermissiONSs .. 127

See also Restriction of user permissions.

About Register Security

The module Register Security is part of the WorkZone security system. The purpose is to
assign the proper permissions to the WorkZone users.

Prerequisite

The prerequisite for gaining access to the Register Security module is the access code
DATAADM.

Security Codes

The WorkZone Security System is based on 10 security c Codes: 1, 2, 3,4,5,6,7, 8,9, and
10. For each of these security codes, the system administrator must configure a set of per-
missions for every register and table of the system.

Only security codes 1 through 9 are used by WorkZone Client and Captia Web Client end
users. Security code 10 is exclusively for the use of KMD technicians.

Permissions
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You can configure 4 permissions with regard to each security code. They are:

Search = permission to find and view information in the database.

Update = permission to edit and change existing information in the database.

« Insert = permission to create new entries or new entities in the database.

» Delete = permission to delete entries or entities in the database.

For the file and contact registers you can configure two more permissions:

» Lock = permission to terminate cases and contacts.

« Unlock = permission to unlock cases and contacts that have been terminated.

See also Permissions.

Permissions per register

The system administrator must define which permissions are assigned to each security
code in the registers and tables of the database.

Permissions pertable

Some registers consist of several tables, such as the File register,the Record register,
and the Contact register (containing the cases, documents and contacts).

The permissions of the security codes on the table level may deviate from the permissions
on the register level. Consequently a security code with few permissions may have more or
extended permissions with regard to one or several of the register's tables.

See also Registers and tables.

Groups of users

The permissions of each security code can be configured to reflect the demands of specific
groups of users. When a user logs on to Captia Web Client, the security code assigned to
the user defines what the user is allowed to do.

Active Directory - AD
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You can assign security codes to users in Active Directory (AD). When a WorkZone user is
created in AD, the user must be made a member of a distribution group, representing one of
the security codes. When the user's relevant AD information is transferred to the WorkZone
Content Serverdatabase, the user is automatically allocated the correct security code and the
corresponding permissions for registers and tables in the database.

Resetting of the IIS Admin service

If you change the configuration of security, you must reset the IIS Admin Service before your
changes take effect.

For more general information about resetting the IS, see Important notes on usage.

Restriction of user permissions

Despite a user's high security code and extensive access code profile, itis possible to restrict
an individual user's access to the system with regard to Case Permissions, Organizational
Permissions and Contact Permissions.

See also Restrictions of user permissions.

Register security meta data

In the Register Security module you can configure the security codes (1-10). Each security
code is assigned permissions to execute the types of transactions necessary. You can assign
the following transaction types (for example, permissions) to the security codes: Search,
Update, Insert, Delete, Lock, Unlock.

Column Description
Name The name of the registers or tables.
Type In this column you will find the following values:
« Main - Primary table, for example the main register itself.

« Parent - A table which has one or more child tables.
o Child - Sub table.
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Column Description

« Extension - Extension to a table.

« Text - Description.

Description A description of the contents of a table or register.

Security
Code

Search

Update

Insert

Delete

Lock

Unlock

The system has 10 Security Codes. Codes 1 through 9 are assigned to the
end-users of for example WorkZone Client and Captia Web Client.

Code 10 is reserved for the KMD technicians.

Security codes cannot be added or removed.

Search is by default enabled for all users. Without this permission the user
would not be able to see anything in the system.

To edit existing information the users must have this permission.

To create new entities such as cases in the database the users must have this
permission.

To delete entities the user must have this permission.

This permission allows the users to terminate cases or contacts in WorkZone
Client and Captia Web Client.

This permission allows the users to unlock cases or contacts in WorkZone Cli-
ent and Captia Web Client.

See also Permissions.

Permissions for registers and tables

In the Register Security module you can configure the user permissions for registers and
tables. Configure the registers and tables in this order:

1. Configure the permissions on register level. When you save the configuration

of the registers, this configuration is passed on to the register's tables.

2. Adjust the individual tables if they need to deviate from the configuration of the

register.
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Example

If, for example, Security Code 6 should have all permissions in the tables of the register File

(case), except the permission to delete the File (case) itself, the procedure would be as fol-
lows:

1. Assign all permissions to Security Code 6 in the register named File.
2. Remove the Delete permission in the table with the name File and type Main.
Security Code 6 users now have all the permissions in all tables of the register

File. However, they do not have the Delete Permission for the primary table. In
other words they cannot delete files, for example cases.

For information on the four (plus two additional) permissions you can configure, see Per-
missions.

configure registers

1. Click Security >Register Security.
2. Inthe Known Registers pane on the left, select the register you want to configure.

3. Clickin the left most cell of the register. All the tables of the selected register are
displayed Tables in register panel to the right. The security settings of the register
itself are displayed in the lower right Security settings for all tables in register
panel.

4. Selectthe check boxes to add permissions or clear the check boxes to remove
permissions.

5. Place the cursorin another cell and click Database > Save.

When your register's configuration is saved, its configuration is passed on to the tables
of the entire register. You can always adjust the tables individually, if they must deviate
from the default setting of the register.

configure tables
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1. Inthe upperright Tables in register: <table name> panel, select the table you
want to configure.

2. Click the left most cell of the table. The security settings of the table are dis-
played in the lower right panel.

3. Select the check boxes to add permissions or clear the check boxes to remove
permissions.

4. Place the cursor in another cell and click Database > Save.

Resetting of the [IS Admin service

If you change the configuration of the security, you must reset the [IS Admin Service before
your changes take effect.

Registers and tables

The WorkZone database is based on a set of registers. Essentially two types of registers:

« Primary registers

« Secondary registers.
A register in WorkZone is a set of tables that describe an entity such as a case (file); the
data in a set of tables correspond with the data presented in the user interface in WorkZone
Client and Captia Web Client. File, for instance, is a Primary register - in WorkZone Client

and Captia Web Clientknown as Case. Opening the main register entity, for example the
case, gives the user access to the tables that comprises the case.

Primary registers

The primary registers are the ones the end users encounter in their work on a daily basis,
that is the File register, the Record register, and the Contact register (corresponding to
cases, documents, and contacts in WorkZone Client and Captia Web Client).

End users
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The end users are given permissions to primary registers and their tables depending on the
rules and regulations their organization has to comply with. For the end users of many organ-
izations, this means that they are not allowed the permission to delete.

System administrators

The system administrators are often given the highest security code to access all levels of the
system and its registers in order to be able to maintain the systems configuration.

Secondary registers

Secondary registers supply basic information for the primary registers. The secondary
registers are characterized by data that is rarely changed. If they need to be adjusted this is a
job for the WorkZone Configuration Management system administrators. As an example this
could be maintenance of Custom domain, Custom label, Classification Scheme, or simply
adding a new country to Countries and Post codes, and so on.

End users

The end users must have Search permissions to all registers to be able to find and view
information from the secondary registers.

System administrators

The system administrators are usually given the highest security code to access all levels of
the system and its registers in order to be able to maintain the systems configuration.

Permissions

Below is a description of the four permissions. There is a big difference between permissions
granted a register or a table. If you, for instance, have delete permissions in the table con-
taining contacts attached to cases, you are able to remove unwanted contacts from cases.
However, if you have deleted permissions for the case register itself, you can delete an entire
case.

Permissions
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The four permissions you can configure with regard to each security code are:

Search - permission to find and view information in a register or a table.

Update - permission to edit and change existing information in a register or table.

Insert - permission to create new entities in a register or table.

Delete - permission to delete entries or entities in a register or table.

Two additional permissions

The registers Contact and File have two additional permissions that can be configured.
You can configure each security code with regard to:

» Lock - permission to terminate a contact or a file (i.e. a contact or a case in
WorkZone Client and Captia Web Client).

« Unlock - permission to reopen the use of a contact or reopen a file.

In the following, the File register is used as an example.

Search permission

With a default configuration all security codes are permitted to search in all registers and
tables. If this were not the case the users would not be able to find or view any information
in any registers or tables.

Update permission

Users who need to edit existing data must be assigned a security code with this per-
mission.

In tables of the type Main, all users are permitted to edit existing data and to enter inform-
ation in empty fields. In WorkZone Client and Captia Web Client, the information contained
in the main table is displayed, for example in the details page of cases.

The main table is the register itself viewed as a table.

In tables of the type Child, the users are permitted to edit all existing data. But the users are
not allowed to add new data. To do this, the users must have insert permission. The user
will not be able to add a new contact to a case in WorkZone Client or Captia Web Client
with the update permission alone.
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Insert permission

In tables of the type Main all users are permitted to create new entries in the register. This
means that the users have permission, for instance, to create new cases in WorkZone Client
and Captia Web Client.

In tables of the type Child the users are permitted to insert new lines of information. This
means that the users have permission, for example, to add new contacts to a case in
WorkZone Client and Captia Web Client.

Even though the user does not have insert permission to tables of the type main, it is import-
ant that the user has "insert" permissions to the tables of the type Child. Otherwise the users
are not allowed to attach contacts, document etc. to cases. Actually both "insert" and "delete"
permissions for tables of the type child should be assigned to the users if they cannot main-
tain important case information, for example, adding and removing contacts.

Delete permission

In tables of the type Main permission to delete is not recommended. If the user has per-
mission to delete here, that is in the register itself, then the user is permitted to delete entire
entries in the register. In WorkZone Client and Captia Web Client, for instance, this means
that the user is permitted to delete an entire case.

In tables of the type Child, the users are permitted to delete lines of information. This means
that the users have permission, for example, to delete contacts from a case in WorkZone Cli-
ent and Captia Web Client.

By default users must have delete permissions to tables type child in order to maintain files,
records and contacts (for example cases, documents and contacts in Captia Web Client) effi-
ciently.

Lock and unlock permissions

The registers Contact and File (cases) are supplied with two additional permissions, "lock"
and "unlock". With these two permissions users are allowed to terminate and/or reopen entit-
ies.

On the WorkZone Client and Captia Web Client case details pages it is possible to terminate
and reopen a case if the user's Security Code is configured to contain the permissions "lock"
and "unlock". The same applies to contacts.
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The Diagnostic Module

The diagnostic module manages tools for tracing activities of the WorkZone Configuration
Management.

The diagnostic module is started when you log on to WorkZone Configuration Man-
agement. The module starts tracing and logging the activities of the program at once. The
tracing is terminated and the log erased when you close the program.

Click Diagnostic > Trace Output or Enable sjDebug to open the module.

Prerequisites for managing diagnostics

The prerequisite for gaining access to the Trace Output module is the access code
DIAGADM.

No access code is needed for Enable sjDebug.

EXxporttrace 10Q ... . . 130
Enable sjDebug output .. ... 131
Traceoutput metadata ... .. ... ... 131

Export trace log

You can export the log containing trace information. Do this in order to document events if
you encounter errors in the program. You can send the file containing the log to KMD for fur-
ther scrutiny and diagnosis.

export trace output log

1. Click Diagnostics > Trace Output.

2. Click File > Export. The Save Diagnostic dialog is displayed. By default the
file name sysadmDiagnostic is suggested. The file can only be saved as a
text file (*.txt).

3. Click Save.
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Enable sjDebug output

If you need to document errors in the WorkZone Configuration Management, you can also use
sjDebug. When you apply sjDebug, all program transactions are traced by sjDebug.

Prerequisite:

Before you can enable sjDebug output, sjDebug must be running. If you do not know how to
initiate this program contact your technical system administrator in charge of your WorkZone
installation.

Two possible scenarios:

« You are aware of a problem in WorkZone Configuration Management. Start sjDebug
before logging on to WorkZone Configuration Management.

« You encounter a problem while working in WorkZone Configuration Management.
Start sjDebug and enable sjDebug output.

Start sjDebug

1. Logon to the server where WorkZone Configuration Management is installed.
Click Start > Run.
Enter sjDebug into the field and click OK.

W N

When prompted for password enter scan;.

Trace output meta data

The Trace Output will display a panel with the following columns:

Column Description

Time Time of transaction

Module Module that was active
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Column Description

Component Program component that was

involved
Method Function
Text Description
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Operation

The Owner Module . ... . 133
The Users Module ... . 152
The Preference Profiles Module ... ... . .. 156
The Processes Module .. .. .. . 163
The Service Workflows Module ... ... . 165

166
The Process Settings module ... . 166
The Process Dispatchers Module ... 171
The E-boks Materials Module ... .. . .. .. 175
The Remote Print Types Module ... ... . L 176
The Dispatch Sequences module ... ... 177
The Document format Module ... .. .. . 178
The Record Access Module ... .. .. . 184
The External Sources Module ... ... . 187
The Service Channels Module ... .. . . 188

The Owner Module

The Owner is the organization that has purchased the right to use for the WorkZone system.

The Owner module manages information regarding ownership and central information about
the system's configuration. This configuration is global, i.e., it applies to the entire system.

Be careful not to change your configuration once it has been implemented! Some con-
figuration, such as Case number, hide/show access codes should not be changed once they
have been initiated. Changes during a production period may affect searches and archiving
results, and so on.

Some configurations, however, may be overridden locally in the WorkZone system; as an
example the global configuration of the case number format can be overridden in the clas-
sification scheme on an individual class level by the employment of a specific mask.
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Prerequisites for managing Owner

The prerequisite for gaining access to the Owner module is the access code USERADM.

Click Operation > Owner to open the module.

Owner meta data

In the Owner module you can manage information about your organization and the con-
figuration of the WorkZone system.

The Owner module consists of a number of sections where you can register the following

information:
Cell Description
Name Enter the name of the organization using the current install-
ation.
Address Enter the address of the organization mentioned above.
City Enter the post code in the first field.
Press Tab and the postal district is automatically filled into the
adjacent field.
Post code must be configured in the Countries and Postcodes
module.
Country Enter the country code in the first field.
Press Tab and the name of the country is automatically filled
into the adjacent field.
Country codes must be configured in the module Countries
and Postcodes.
Phone Enter the phone number of your organization.
CVR-NR Enter the CVR number, that is the central business registration

number of your organization.

CVR no. is a Danish Central Business Registration Number.
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Cell Description

Itis important that you enter the CVR no. correctly (8 digits)
because it is a prerequisite for the employment of eDe-
liverynote (e-falgeseddel).

Access Code Visibility

Hide Organizational Check box with two options:

Access Codes
« Cleared check box - organizational access codes are

in use.
« Selected check box - organizational access codes are
hidden.

Organizational access codes (i.e. unit access codes).

By default the check boxes are cleared. If Corporate Access
Codes are employed, hiding is not an option.

Only users with the AFDADM and STJERNEADM access
codes have the rights to set the Hide Organizational Access
Codes check box.

Hide Employee Access Check box with two options:

Codes
« Selected check box - employee access codes are in

use.

« Cleared check box - employee access codes are hid-
den.

Employee access codes (i.e. user access codes).

By default the check boxes are cleared. If Corporate Access
Codes are employed, hiding is not an option.

Only users with the MEDARBADM and STJERNEADM
access codes have the rights to set the Hide Employee
Access Codes check box.

Dictionary

In use Check box with two options:
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Cell Description

« Cleared check box - the dictionary is disabled.
Entered words are not validated but accepted.

« Selected check box - the dictionary is enabled.
Entries from the dictionary must be used as keywords.
The words are validated. If a keyword is not in the dic-
tionary (and enabled), itis rejected.

lllegal characters

Characters entered in this box will be rejected if they are
entered in the dictionary.

Minimum length

Indicates the minimum length of an entry in the Dictionary.

Other sections

Group Language

Select culture code from the drop-down box.

The selected language will be the default language of
WorkZone Client and Captia Web Client.

Case Number Format

Enter the default case number format for the system.

Record Access Rights

Check box with two options:

« Cleared check box - Record Access Rights module is
disabled.

« Selected check box - Record Access Rights module
is enabled.

The information of the Culture Settings tab:

Cell Description

Culture Name

Languages, for example:

« da-DK (= Denmark)
« en-GB (= Great Britain)

The culture name is set up during the installation of the lan-
guage pack and cannot be edited by users.
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Cell Description

Date Pattern A mask defining the way dates are formatted for the culture
selected - for example:

o dd-MM-yyyy HH:mm:ss
o MM-dd-yyyy HH:mm:ss

dd day
MM month
yyyy year
HH hour
mm minute
Ss second

Changes to this cell will influence all date fields in the system.
Culture Code Culture codes, for example:
« 1030 (= da-DK)
« 1033 (= en-GB)

Activated The day the date pattern is activated. The date is set at install-
ation of the language pack and cannot be edited by users.

Deactivated The day the date pattern is deactivated. The date is set at
installation of the language pack and cannot be edited by
users.

Hide or show access codes

Users and organizational units are maintained in AD (Active Directory). They are replicated to
the WorkZone database at intervals.

SJ Active Directory Connector transfers data from AD to the WorkZone database, for
example users and organizational units as well as access codes. Access codes are used for
regulating read/write rights to cases and documents.

By default, access codes for both users and organizational units are available for use.
However if these access codes are not wanted or disruptive for efficient use of Captia Web Cli-
ent, they can be hidden.
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You can hide access codes for both users and organizational units. This is done if they are
not to be used. You decide whether both or just one of them are to be hidden or employed.

hide access codes

1. Click Operation * Owner. The Access Code Visibility section contains the

options that determines if access codes are hidden or visible:

o Hide Organizational Access Codes (i.e. unit access codes).

Only users with the AFDADM and STJIERNEADM access codes have the rights to
set the Hide Organizational Access Codes check box.

o Hide Employee Access Codes (i.e. user access codes).

Only users with the MEDARBADM and STJERNEADM access codes have the
rights to set the Hide Employee Access Codes check box.

2. Select the check boxes to hide the access codes or clear the check boxes to
show the access codes.

3. Place the cursor in another field and click Database > Save.

The program must be restarted to activate the configuration.

By default check boxes are cleared. If Corporate Access Codes are deployed, hiding is not
an option.

See also Owner meta data - Hide Employee Access Codes.

Enable or disable record access rights

The purpose of this configuration is to enable or disable Record Access in WorkZone Cli-
ent and Captia Web Client altogether. This is done with the check box field Enabled in the
Record Access Rights section.

enable record access rights
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Click Operation > Owner.

In the Record Access Rights section, select the Enabled check box to enable
record access or clear the check to disable it.

Place the cursor in another field and click Database > Save.

By default the record access is disabled (the check box is cleared).

Configure the dictionary

The basic configuration of the dictionary is done in the Dictionary section in the Owner mod-

ule.

Enable or disable the dictionary

—_—

Click Operation > Owner.

On the Owner Settings tab, select the In use check box field in the Dictionary sec-
tion to enable the dictionary or clear the check box to disable the dictionary.

Dictionary is enabled - the check box is selected.

All keywords and synonyms must preexist in the dictionary. When you register
keywords on, for example, cases in WorkZone Client or Captia Web Client, the
words are validated against the dictionary. If they do not exist in the dictionary (or the
keywords are disabled), they are rejected.

Dictionary is disabled - the check box is cleared.
In WorkZone Client and Captia Web Client, the users can both register keywords at
will and register keywords from the dictionary. There is no validation.

A message displays saying: "You must restart before this change has any
effect.”

Place the cursor in another cell and click Database > Save.

Restart WorkZone Client or Captia Web Client and WorkZone Configuration Man-
agement to activate the changed configuration.
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llegal characters

In lllegal characters field, you can register characters that are not allowed in keywords in
the dictionary. If you try to enter illegal characters, they will be rejected, that is the word will
not be accepted.

Minimum length

The number registered in Minimum length field defines the minimum length of an accepted
keyword. If you enter a keyword with fewer characters, it will be rejected.

Configure group language

In the Group Language section you can select the default user interface language of
WorkZone Client and Captia Web Client. When the users log on to clients, all labels, drop-
down lists, classification scheme, and so on, in the user interface are displayed in the
selected language.

The field contains a drop-down box. You must select the culture code of the default lan-
guage.

Configure default language

1. Click Operation > Owner.

2. Inthe Group Language section, select the culture code for the default lan-
guage from the list.

3. Place the cursor in another field and click Database > Save.

4. Restart the program to activate the configuration.

See also Language mode and Group Language.

Configure date pattern

You can configure the date pattern for each culture implemented in WorkZone Client and
Captia Web Client. The configuration is set up in the module Owner and is globally effect-
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ive but you can deviate from this configuration. In the User module you can define an indi-
vidual date pattern for each user and thereby deviating from the global configuration.

You enter the date patterns on the Culture settings tab in the Owner module.

1. Click Operation > Owner.
Click the Culture Settings tab. The cultures installed are displayed.

Click in the Date Pattern cell.

> W N

Enter the date pattern for the culture, for example, the Danish date pattern da-DK:
dd-MM-yyyy HH:mm:ss

5. Place the cursor in another field and click Database > Save.

When a culture specific date format is to be specified, the following subset of the .NET way of
specifying the format is used:

Format specifier Description

dd The day of the month. Single-digit days will be preceded by a zero.

HH The hourin a 24-hour clock. Single-digit hours will be preceded by a zero.
Lt The minute. Single-digit minutes will be preceded by a zero.

MM The numeric month. Single-digit months will be preceded by a zero.

ss The second. Single-digit seconds will be preceded by a zero.

yy The year in two digits.

Yyyy The year in four digits.

The following separators are valid for separating the parts of the date format:

Separator Description

o A space.

A period.

- A hyphen.

A colon.

/ A slash.
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Configure draft versioning

In the Draft Versioning section, you can enable/disable version control of drafts. Ver-
sioning applies to documents with the state UA (Draft) or UP (Personal draft). By default
draft versioning is enabled and a maximum of 100 old versions are kept for any document.
Note that new documents are not automatically put under version control unless you spe-

cify it.

Enable and configure draft versioning

1. Click Operation > Owner and go to the Draft Versioning section.
2. To enable draft versioning, select the Enable draft versioning check box.

3. Ifyou have enabled draft versioning, you can choose to:

« Keep all versions - Keeps all versions of the drafts.

« Keep number of versions as set in 'Version limit' - If you select this
option, specify a limit in the Version limit field. The system keeps the
number of drafts specified in the Version limit field. If the limitis
exceeded, the oldest versions are deleted automatically.

If you change the version limit, it takes effect next time a document is changed.

4. Selectthe Apply draft versioning automatically to new drafts check box to
apply automatically version control to new drafts.

5. Place the cursor in another field and click Database > Save to save the con-
figuration.

6. Resetthe IIS on all web servers to activate the configuration.

Apply versioning control to cases in a class

You can apply versioning control to cases in a specific class, see Classification Scheme -
Apply draft versioning. This means that documents created on these cases have ver-
sioning control applied automatically.
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Case number format

About case number formats

Cases are identified by a number - the case number. The case number can be constructed in
different ways, for instance:

« 2009-00001, i.e. year-sequence number,

o 2009-1312/175-0001, i.e. year-class/subnumber-sequence number.

Global configuration

Configuration of the case number is done in the Owner module in the Case Number Format
field. You must enter a global mask for the case nhumber in a special format - for instance

aaaa.gggg (/uuuu) -LLLL.

In this mask, the letters used mean the following:

« aisthe year, i.e. aaaa is automatically converted into a four digit year - 2013.

« gisthe class, i.e. gggg means that the maximum length of the class is four char-
acters.

o Uis the subnumber, i.e. uuuu, the maximum length of the subnumber is four char-
acters (/if it applies to the class).

o Lisasequence number,i.e. LLLL, a four digit number, e.g. 0034 (the capital L sig-
nifies that the sequence number i fixed, always 4 digits preceded by zeros when the
number is lower than 4 digits, e.g. LLLL = 0034).

This is an example of a case number mask. The case nhumber mask you enter applies glob-
ally, i.e. to the entire WorkZone system.

Local configuration
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You can deviate from the global configuration by configuring the case number format for
individual classes. This is done in the Classification Scheme module.

In the Classification Scheme module, you might for instance have a class reserved for per-
sonnel files. You could, for example, configure this class to be a CPR-number and in this
way, deviate from the global case number format, for example a mask such as cccc-
cccc/LLLL = 180562-5903/0034.

See also Mask.

Manual case number

It is also possible to number cases manually. If necessary, it is possible to set up classes to
prompt for a manually entered case number at case creation. This is configured in the Clas-
sification Scheme, see Free Case Number.

The sequence number of the case humber

When you create a new case, the case is automatically allocated a sequence number. If
the global case humber mask does not include g = class or u = subnumber, you must enter
a hash (#) symbol in the case number mask, for example #aaaa-LLLLLL. The sequence
number is automatically generated when you use the hash symbol (#).

When you add the hash symbol (#) in front of the sequence number, the sequence number
is automatically reset when the year changes and a new one is created.

parallel case creation

To ensure scalability of parallel creation of cases, case numbers are not created in con-
secutive order without holes. In rare situations a case number may be skipped, for example
when attempts to create a case with invalid data fail due to the transaction being rolled
back. In this case, a log that lists skipped case numbers is created. The log is placed in the
file_numbering_error table and is also available through the register named file_num-
bering_error (OData: FileNumberingErrors). Consult the log if you suspect that a case has
been lost. The log shows if the case was never created.
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Create case number format

Here you can read how to create or edit the case number format of the company.

How to format a global case number

1. Click Operation > Owner.
Click in the Case Number Format field.

Enter or edit the case number mask.

W N

Click Database > Save.

See also About case number mask components.

About the case number mask

In the Case Number Format section, you must enter a case number mask. The global case
number mask defines the way that the case number is formatted at case creation.

The case number format entered here applies globally for all cases created, except for
classes with individual case humber masks, see Mask.

The components of the case humber

The global case number mask can be constructed of a number of different components, which
are described below.

Information Description

Number of The case number can contain up to 30 characters including punctuation marks
characters and blank spaces.

Meta data In the table below is listed the components of which the case number can con-
sist. Components permitted are meta data and a sequence number. Fur-
thermore, you can see which characters you must enter to include the different
components in the case humber mask:
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Information Description

Character Description

a

Year - you can enter 2 or 4 characters:

« 4 characters, a 4 digit year is used,

« 2 characters, the last 2 digits of the year are used.

Class - from the classification scheme - contained in the Clas-
sification Scheme module. For example, enter gggg if the class
consists of up to 4 digits.

Responsible organizational unit - contact codes belonging to
contact type A.

For example, enter sssss if the contact codes of responsible
organizational units consists of up to 5 digits.

Case type - domain items belonging to domain type case type in
Custom domain module.

For example, enter ttt if the class type can consistof up to 3
digits.

Subnumber - subnumbers belonging to the Subnumbers mod-
ule.

For example, enter uuuu if the subnumbers consists of up to 4
digits.

Lorl

Sequence number - a capital L signifies that the format of the
sequence number is fixed - always the same number of digits
and that the digits will be preceded by zeros when the number is
lower than the allocated Ls.

A lower case | signifies that the format for the sequence of the
sequence number is variable.

See Sequence number format.

CPR-number - which is the Danish personal identification num-
ber.
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Character Description

It is a ten-digit number with the format DDMMYY-SSSS, where
DDMMYY is the date of birth and SSSS is a sequence number.
The first digit of the sequence number encodes the century of
birth (so that centenarians are distinguished from infants), and
the last digit of the sequence number is odd for males and even
for females.

This case number format is normally used locally for the class in
the classification scheme used for registering personnel files for
individual employees.

y 4 Used for case number masks for fictitious CPR numbers.

This case number format is normally used locally for the class in
the classification scheme used for registering dossiers for indi-
vidual persons - persons without an officially generated CPR-
number. The format is zzzzzz-zzzz.

This feature requires that the case details page is customized.

Sequence
number
format

You can define whether the sequence number is to be created with a fixed or a
variable format.

Fixed format

Upper-case signifies a fixed format of the sequence number. The sequence
number of the case humber is designed to have a fixed humber of digits.

If the sequence number, for instance, is defined as 4 capital letters such as
LLLL. The sequence number of the first case created is 0001.

If, for example, the case number mask is defined as: aaaa-gggg-LLLL. Then
the case number for a specific case could be 2009-1380-0004.

Variable format

Lower-case letters signify a variable format. The sequence number of a case
number is designed to have only the necessary number of digits.
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Information Description

Number of
characters

Punctuation
marks

Conditional
information

If the sequence number, for instance, is defined as 4 lower-case letters such
as llll. The sequence number of the first case created is 1.

If for example the case number mask is defined as: aaaa-gggg-llll. The case
number for the same case would be 2009-1380-4.

The number of characters in the global case number mask depends on how
many digits (or characters) each part of the case number is made up of.

The upper limit for the whole case number is 30 characters. Note that punc-
tuation marks and blank spaces are included.

The following punctuation marks can be used to separate the different parts of
the case number:

- - hyphen
/ -slash

. - full stop

Brackets around part of the case number mask signifies that this particular part
is only included, when the requirements described below are met:

« Asubnumber is required by the class selected for the case.
Mandatory subnumbers can be defined for specific classes in
the classification scheme. For instance, the case number mask
designed as aaaa-gggg(/uuuu)-LLLL will, for instance, gen-
erates the following case numbers:

« If subnumbers are mandatory for class 3720, the case number
will be formatted like this: 2009-3720/AAA-0001.

« If subnumbers are not defined for class 2650, the case num-
ber will be formatted like this: 2009-2650-0001.

« The value specified in the mask is case metadata, and must be
entered before the case number can be created. Case
metadata is case type and responsible organisational unit.
This case number mask (#tttttt-) for instance, will generate
the following case numbers:
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Information Description

Information
controlling
the
sequence
number

« If case type ABC is entered on the case, the case number will
be ABC-1380-0001.

« Ifno case type is entered, the case number will be 1380-0001.

Mandatory requirements for the classification scheme

In the classification scheme, the check box in the cell Fixed SubNumber must
be selected, and a value selected in the cell Sub-number type. The value
selected defines what domain of sub numbers is attached to the class.

To make a separate part of the case number influence how the sequence num-
ber is generated, you must use the hash (#) symbol in the case number mask.
The hash (#) symbol can be applied in two different ways, with two different

results:

« Disable default numbering method

If you place a hash (#) symbol in front of default case number
information, i.e. class and sub number, the default numbering will
be disabled. This means that class and sub number have no influ-
ence on the sequence number, which will be generated as a global
sequence number. This mask, for example #gggg-#uuuu-LLLLLL,
generates the following case numbers: 3270-AAA-000001, 3270-
BBBB-000002, 3270-AAA-000003, etc.

- Enable special numbering method

You can place a hash (#) symbol in front of responsible organ-
isational unit and case type. This will cause the generation of the
sequence number to take this part of the case number into account.
For instance, gggg-uuu-#tttt-LLL - the case mask includes case
type with a hash (#) symbol. The creation of the sequence humber
is controlled by the class, the subnumber and the case type selec-
ted.

Default sequence number
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Information Description

By default, primarily the class and secondarily the sub number control how the
sequence number is generated. If the case nhumber mask only contains class
information, e.g. gggg-LLLL, each class will have its own series of sequence
numbers.

If the case number mask contains both class and sub number, for example ggg-
g/uuuu-LLLL, each combination of class and subnumber will have its own
series of sequence numbers.

Fixed inform- You can include fixed information in the case number mask. Fixed information
ation can be inserted into the case number mask in the following ways:

« Characters in square brackets [] are inserted directly into the case
number.
If the case number mask, for instance, is designed as [AMA]-gggg-
LLLL, the case number is created like this AMA-1312-0001.

« Characters entered like this !<characters> are inserted directly into
the case number.
If the case number mask, for example, is designed as gggg-1<AMA>-
LLLL, the case number will be created like this 1312-AMA-0001.

About case humber mask components

Below is a description of the different components of the case numbers.

Case number length

The case number can be up to 30 characters long. All components are taken into account
even separators.

Case number components

Below are the default components of the case number mask:
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Information  Description

g Case class - the classification scheme.
u Subnumber - supplementary to the classification scheme.
Lorl Sequence number entered as an L or .

See Sequence number below.

a Year - 2 or 4 digits, i.e. aa or aaa.
s Organizational unit.

t Case type.

Cor Z CPR number - 6-4 characters.

I<character> I<character> is notinterpreted.

[] Characters in [] are not interpreted.

() Characters in ( )brackets are only included if required by the class - see _
Fixed Subnumber.

Characters in brackets see Conditional information below.

Sequence number

Fixed Upper case L's, for example LLLL, means that the sequence number has a fixed length.
length The first case created gets sequence number 0001.

Variable Lower case I's, for example llll, means that the sequence number has a variable length.
length The first case created gets sequence number 1.

Separators

You can use the following characters as separators between groups of information:
- = hyphen,
/ = slash, and

. = period.
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Conditional information

Brackets means that the information inside the brackets is included in the case number
when one of the following conditions is fulfilled:

« When the information is transferred from the classification scheme.

« When the information exists in the case details page.

The Users Module

In the Users module you can manage information concerning the user with regard to secur-
ity, date formats, culture and entity permissions.

Users are created and maintained in AD (Active Directory). They are transferred to the
WorkZone Content Server database with the WorkZone replication program via a sched-
uled task. In WorkZone Configuration Management, you can adjust the privileges of the
individual users concerning the maintenance of data in Captia Web Client.

Prerequisites for managing Users
The prerequisite for gaining access to the Users module is the access code USERADM.

Click Operations > Users to open the module.

Users meta data

Cell Description

Name The unique ID of the user.
Full Name The full name of the current user.
Number The current user's user-number. This number is, for example, used in the

Use Log module. Each row of information is started with the user number.
This way you can find out who has done what in the database.
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Cell Description

SID The Microsoft Security Identification. The SID is a unique alphanumeric
row of digits identifying each operating system and each user in the net-
work.

Security The security code allocated the current user (the code is a number

between 1 and 9.) The security code defines the database authorization
of the user. It represents what the user is allowed to do in each registerin
the WorkZone Content Server database, for example, whether the user is
allowed to search, update, create or delete cases.

The authority granted the security codes are defined in the Register secur-
ity module. In this module, you define the rights granted each security
code level with regard to each register and table.

In Active Directory (AD), there are 9 distribution groups corresponding to
each of the security codes. In AD, the users must be members of at least
one of these distribution groups to be able to work in WorkZone programs.

Date Format If the cell is empty, the date format used is the format configured in the
Owner module on the Culture settings tab.

In this cell you can enter a date format pattern. It determines the way dates

are displayed in Captia Web Client for the current user, for example da-
MM-yyyy HH:mm:ss

See also Date patterns.

Culture The cell shows what language the users has chosen as default language
in Captia Web Client.

Configuration Displays when the current user has initiated an update in the user's con-
figuration in user_configuration.

This happens when the user adjusts the set up in the Captia Web Client
interface, for example when the user configures menus, lists etc.

Universal Select Ja from the drop-down list to assign universal access to the user.
access Universal access means that the user has unlimited access to all cases
and documents. The user is not subject to access code control.

Only users with the access codes MEDARBADM and STIJIERNEADM
have the rights to assign universal access to users.
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Restriction of user permission

There are three panels where you can specify certain aspects of the permissions of the indi-
vidual user. These are the Case Permissions, the Organizational Permissions, and the
Contact Permissions. As long as these panels are notfilled in, the users is not limited in
these areas. As soon as you fill in something in one of the panels, the user's rights are
restricted to the area defined in the panel.

If, for example, in the Organizational Permissions you enter a specific organizational unit
and the permission record, the current user is exclusively restricted to creating and main-
taining documents with the specified unit as responsible unit.

Case permission

Case Class The function of the panel:

. Ifthe panel empty, the user is permitted to create and update cases
and their documents no matter the case class (naturally in accord-
ance with the user's security code and access codes).

« If one or more rows of data are entered the user is restricted to cre-
ating and maintaining cases and documents belonging to the case
classes registered here.

In this cell you can select:

« oOne case class per row,
e as many rows as needed
« a specific class, for example, 3230, Sand and rubble, or
» avalue indicating a hierarchy entity, for example 32 (all classes
beginning with 32).
Permission Select the value from the drop-down box belonging to the cell.

The value entered in this cell defines the scope of the permissions. Is the
user granted permission to:

« Case -only cases,
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« Record - only documents or

« Case/Record - both cases and documents.

Organizational permission

This panel functions like the "Case Permissions" panel.

Organizational As long as the panel is empty, the user is subject to no restrictions. As soon
Unit as you enter an organizational unit and permissions, the users freedom of
action concerning creating and maintaining entities is severely limited.

The cell contains a drop-down box. Select an organizational unit to which

the user's authority is to be restricted.

Permission Select the restriction you want to impose on the users from the list box. The
user is allowed to create and maintain

o Case -only cases,
« Record - only documents or

« Case/Record - both cases and documents.

Contact permission

In this panel, you are able to limit in which contact types the user is allowed to create and
maintain contacts.

By default, "Editing allowed" is preselected for all users with a security code permitting cre-
ation and maintenance of contacts.

Contact The cell contains a drop-down box with contact types. Select the contact types
type for which the user is allowed to create and maintain contacts.

Permission The cell contains a drop-down box. Select the value relevant for the contact

type

« Editing allowed (= Redigering tilladt).
« Editing prohibited (= Redigering ikke tilladt).
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Access codes

Access In this panel, the user's Access Code Profile is displayed - a list of all the access
Code codes the current user is a member of in Active Directory.

The list of access codes is for display only. They cannot be edited. If additional
access is needed, the users Access Code profile is updated by creating a mem-
bership in AD. Changes are then transferred between AD and the WorkZone
database at regular intervals.

The Preference Profiles Module

Preference Profiles are employed by users in Captia Web Client. Restricting Profiles are
not by default employed. Restricting profiles are only in effect with specific customization.

In the Preference Profiles module you can manage information regarding the configuration
of profiles. Profiles are defined and created by your organization. A profile is a mask fil-
tering out unnecessary values. The profile mirrors, for instance, a specific job function or
work area.

Users can work with or without a profile in Captia Web Client. The purpose of profiles is
that working on the basis of a profile, the user only see the data she needs to see. This
means that when the user opens a list or a pop-up window, only values relevant for the
work of the current user are displayed.

For example, the drop-down list in the Document group or Case handler fields only display
the values used by the current user. If the user needs to see and perhaps to register other
values, then the user can click Show all in the list. Then, the user can select another value.

Prerequisites for managing Preference Profiles

The prerequisite for gaining access to the Preference profiles module is the access code
PROFILADM.

Before working in WorkZone Configuration Management, deselect any active profile in
Captia Web Client.

Click Operation > Preference Profiles to open the module.
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The Preference Profile meta data

In the table below is an overview of all the information describing a profile.

Cell Description

Code The code is the unique ID of the profile. You must enter a code for the pro-
file when you create it. The maximum length is 11 characters.

When you have saved the profile the cell is no longer open for editing.

Name Enter a short and precise description of the profile in this cell. Use max. 60
characters.

When you have saved the profile, the cell is no longer open for editing.

Default Case  Default case handler in Captia Web Client

Handler Select the default case handler from the list in the field.
The profile automatically inserts a default case handler when the user cre-
ates a new case in Captia Web Client.
Default Select the default responsible organizational unit from the list.
gzsponsible The profile automatically inserts a default responsible organizational unit

when the user creates a new case in Captia Web Client.

Access Code  You can exclude users from using a profile. This is done by means of an
access code. If an access code is entered into the cell, only users with the
same access code can select the profile.

Start Date Initiation date. If this is not entered the profile cannot be enabled.
End Date Termination date. The profile is disabled from this date.

Tabs with basic In the right panel - with the heading "Profile: <Code>" - are a number of
data tabs. Each tab contains a set of basic data, for instance, Custom Domains.

In this panel, you attach basic data to the profile. The profile is a kind of bas-
ket holding basic data. When the user chooses to work according to a spe-
cific profile, the user only sees the basic data specified by the profile.

When the user chooses to work without a profile, all basic data is displayed
in, for example, the drop-down boxes opened by the user.

157



WorkZone Configuration Management 2021.2

Cell Description

Custom Label Select the custom labels that the users employing the profile need to see.

Custom Select the values of custom domains that the users employing the profile
Domains need to see.

Classification Select the classes which the users need to see.
Scheme

Facet-based Select the facets that the users need to see.
Classification
Scheme

Subnumbers Select the classes that the users need to see.

Employees Select the employes that the users need to see - in the Case handler field
in Captia Web Client.

Organisational Select the employes which the users need to see - in the Responsible unit
Units field in Captia Web Client.

Working with preference profiles

In the Preference Profiles module you can:

« Create new profiles.
. Edit already existing profiles.

« Disable profiles no longer in use.

Prerequisites for administering profiles

In order to maintain profiles you must have the administrator access code - PROFILADM.

You cannot work in the module with a profile enabled for your user in Captia Web Client. If
you open WorkZone Configuration Management with a profile enabled, the following mes-
sage will be displayed: "You have and active profile: <profilename>. This may cause unex-
pected behavior in WorkZone Configuration Management.
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Working with profiles

Create a profile  First create the profile in WorkZone Configuration Management.

« Give the profile an ID and a name. The name is a short and pre-
cise description containing enough information for the users to
understand the scope of the profile.

« Select the data necessary and sufficient for the profile to fulfill its
purpose.

« Enter a start date to enable the profile.

Select profile In Captia Web Client the profile is now available for the users. When the
user clicks the link to the profiles, a dialog is opened, where the user can
select either a specific profile or the default profile without any restrictions.

The profile in When the user is employing a profile i Captia Web Client, the number of

use values available in drop-down lists is limited. However, the value Show all
is available. The user can click Show all to see all values. All values are
available for use, i.e. can be registered on, for example, the case currently
displayed.

Create preference profiles

First you must create the profile and save and then attach data to it.

Create a profile

1. Click Operation > Preference Profiles.
2. Click twice in the empty cell of the Code column.

3. Enter a short code, which will be the ID of the profile. Maximum 11 characters
long.

4. Click the Name cell and enter a description of the profile here. Try to include pur-
pose and scope of the profile in this description.

159



WorkZone Configuration Management 2021.2

5. Fillin the Default Case Handler and Default Responsible OU cells if required.

6. Fill in the Start Date cell to enable the profile.

7. Place the cursor in another cell and click Database > Save. When you have
saved the profile, the Code and Name fields are locked and cannot be edited
again.

create the contents of a profile

1. Click the left most cell of the profile you want to work with. The data you can
attach to the profile is available in the right panel.

2. Click the tabs containing information to be included in the profile. You have
two options concerning each category of information:

« All values are to be displayed:
Select the check box at the highest level.

Selected values are to be displayed:
Click your way down the hierarchy to the values which should be included.
Click the check boxes of value to be included.

w

. When you have selected the values, click Database > Save.

Edit preference profiles

You can edit an existing profile. The left panel contains information that identifies the pro-
file. You can edit all cells except the Code and Name cells, which are locked. In the right
panel, you can edit the meta data attached to the profile.

Edit a profile

1. Click Operation > Preference Profiles.

2. Click the profile you want to edit.
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3. Click the left most cell of the profile in the Code column. The right panel is now
populated with meta data ready for editing.

4. Make the corrections as needed.

5. Place the cursor in another cell and click Database >Save to save the changes.

Delete or disable preference profiles

You can disable or delete profiles that out of date and no longer in use.

Disable a profile

1. Click Operation > Preference Profiles.
Click the profile you want to edit.
Click the cell End Date and select a date.

Click the date when the profile is to be disabled, for example today's date.

a & LD

Place the cursor in another cell and click Database > Save to save the changes.

delete a profile

1. Click Operation > Preference Profiles.
Click the profile you want to edit.
Click the left most cell of the profile you want to delete.

Click Edit > Delete row.

a & LD

Place the cursor in another cell and click Database >Save to save the changes.

About restricting profiles

Use - customization
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This function is not used in a standard Captia Web Client installation. Restricting Profiles
are intended for organizations with special demands. To implement the use of this module
Captia Web Client must be customized.

Purpose

The purpose of the module called Restricting Profiles is to control the use of basic data.
By means of restricting profiles you can control what basic data the users can see, select
and register in Captia Web Client.

The users can not select a profile themselves. In Captia Web Client, they by default work
according to the profile assigned to them by the organization.

Prerequisites for managing Restricting Profiles

The prerequisite for gaining access to the Restricting Profiles module is the access code
PROFILADM.

Click Operation > Restricting Profiles to open the module.

User interface

The interface of the Restricting Profiles module is identical to that of the Preference Pro-
files module.

Working with the Restricting profiles module

Use the help topic concerning Preference Profiles module as it also apply to the Restrict-
ing Profiles module.

See also Preference Profiles.
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The Processes Module

The Processes module is used to configure WorkZone Process processes. The packages

that you have installed are shown in this module. You can specify the order, access, and start

and end date of the processes.

Process A unique identifier of the process.

ID
Guid
Name

Version

Type

Order

Access
Code

Start
End

Access

The Globally Unique Identifier (GUID) of the process.
The name of the process.

The process version number.

The type of process. Possible types are:

o MAIN - Phase processes.

o SUB - Processes that can run both as standalone processes and sub-
processes under a main process.

o« CASEACT - Case activities package.
« SERVICE - Service workflows.

« SUBSVC - Processes that are started by service workflows.

The CASEACT, SERVICE, and SUBSVC process types are not visible in the Pro-
cesses overview.

The order of the processes, which defines the display order of the processes in the
Process menu in WorkZone Client and WorkZone for Office.

You cannot specify this setting.

The process start date. As of this date the process will be available.
The process end date. As of this date the process will no longer be available.
Configure who can access the processes in the current environment.

o ACTOR - Only the current user.

« DELEGATE - The user who has access rights to WorkZone Process can

163



WorkZone Configuration Management 2021.2

delegate access rights to another user.

o ALL - Access is not limited to a specific user.

By default this setting is not specified. The value of the Access setting in the is
used.

Process specific settings

You can enter settings for each of the processes. Select a process and specify settings for
the selected process in the lower part of the screen.
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Manage process versions and access to processes

In the lower left part of the screen, you can see installed versions of a process, specify start
and end date, and who should have access to the process from the Process menu in
WorkZone Client.

Process A unique identifier of the process.
Id

Workflow A unique identifier of the workflow.
Id
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Type The name of the process.
name

Version  The process version.
Start date The process start date. As of this date the process will be available.
End date The process end date. As of this date the process will no longer be available.

Access Specify who should be able to start a process from the Process menu in

code WorkZone Client and WorkZone for Office. You can enter users or organ-
izational units. If you do not enter a value, the selected process will be avail-
able to all users in the organization.

Profile Select this check box to enable a log profile for process. See Reduce log
enabled information in the workflow log using a log profile.

Configure process specific settings

Some of the processes have specific settings that you can configure to suit an organization’s
specific way of working. Select a process and specify the settings for the selected process in
the lower right corner.

For more information about process specific settings, see the WorkZone Process Admin-
istrator's Guide, for example the topics:

o Configure SmartPost

o Configure extended submission

o Configure a ministerial process

o Configure the history document

The Service Workflows Module

The Service Workflow module is used to configure service workflows in WorkZone Process.
You can set up three types of service workflows:

« Mailbox Monitor

o F2 Requisition Handler
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« e-Boks Message Handler

« Monitor Process

To create and configure a service flow, you need to create a new row for each of the work-
flows and fill in the settings.

Name A unique identifier of the service.
Description A description of the service.
Process The type of process.
Enabled Click this check box to enable that the service is started and monitored
by the Process Service Agent.
Alive check _ L . .
. The interval in minutes between the agent checking that the service is
interval _
. running.
(minutes)

The interval in minutes before a new process is started and the old pro-
Restart interval cess is completed. This is to prevent the workflow log from piling up log-
ging information.

See Service workflows in the WorkZone Process Administrator Guide for information about

specific settings for each of the workflow types.

The Process Settings module

The Process settings module is used to configure WorkZone Process.

CreateProcessHistoryDocuement Setting

The settings below apply to the process history document.

Key Default setting  Description

DocumentState ARK You can define a document state
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Description

for history documents generated
by a specific process. Click Oper-
ations > Processes, and selecta
process to configure process spe-
cific settings.

If the document state is neither
specified for each process nor

here, the ARK (Archived) state will
be used as the default state.

Overview Settings

The settings below apply to the Processes overview.

Key

CaseHandlerShownShortNames

Default setting

TRUE

Description

Specify if you want to display the
casehandler's initials or full name
in the Processes overview.

TRUE - Initials
FALSE - Full name

CaseHandlerUnitShownShortNames TRUE

Specify if you want to display the
short name or the full name of the
casehandler's unit in the Pro-
cesses overview.

TRUE - Initials
FALSE - Full name

MaxODataPages

Specify the default maximum
amount of data to display on a
page in the Processes overview.
See Customize maximum data to

display on a page in the
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Key

Default setting

Description

WorkZone Process Admin-
istrator's Guide for information
about how the amount of data is
calculated.

OwnerShownShortNames

TRUE

Specify if you want to display the
process owner's initials or full
name in the Process overview.

TRUE - Initials
FALSE - Full name

PendingShownShortNames

TRUE

Specify if you want to display the
pending actor's initials or full
name in the Process overview.

TRUE - Initials
FALSE - Full name

PendingUnitShownShortNames

TRUE

Specify if you want to display the
short name or the full name of the
pending actor's unitin the Pro-
cess overview.

TRUE - Initials
FALSE - Full name

Workflow host settings

The settings below apply to the workflow host.

Key

Access

Default setting Description
Defines who can access
processes on the current
DELEGATE

environment.

The default value is
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Description

DELEGATE. See Con-
figure default access set-

tings in the WorkZone
Process Administrator's
Guide.

AllowNewlnstancesInAD

FALSE

Defines whether to recycle
names in WorkZone Pro-
cess using Active Dir-
ectory Replication.

The default value is
FALSE, which disables
recycling of names. See
Configure the use of new

name instances in the

WorkZone Process Admin-
istrator's Guide.

WatchDelay

30

Controls the amount of
time passed since the
workflow should have
been started. The setting
has a default value of 30
minutes.

See Configure workflow

failover in the WorkZone
Process Administrator's
Guide.

Watchlinterval

Controls intervals between
checks. If a web serveris
unavailable, workflows are
not reactivated. In order to
avoid this, all workflow
hosts periodically check
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Key Default setting

Description

for workflows that are over-
due. The setting has a
default value of 5 minutes.
See Configure workflow

failover in the WorkZone
Process Administrator's
Guide.

WORKZONE Settings

Key Default setting

Default location of
PartyldentifierSources WorkZone CPR
and CVR data.

Description

Specifies where the
SmartPostsending pro-
cess looks up sender
information such as CVR
or CPR numbers.

Change the XML element
in this setting if the loc-
ation of the CPR and CVR
data has been cus-
tomized.

See Configure SmartPost

PartyldentifierSources in

the WorkZone Process
Developer's Guide.

Default location of
ContactAddressKeySources WorkZone CPR
and CVR data.

Specifies where the
SmartPost receiver pro-
cess looks up sender
addresses based on the
CVR and CPR numbers
provided by e-Boks. For
example, for the purpose
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Key Default setting Description

of linking the received doc-
uments to the addresses
of the senders.

Change the XML element
in this setting if the loc-
ation of the CPR and CVR
data has been cus-
tomized.

See Configure SmartPost

ContactAddressSources

in the WorkZone Process
Developer's Guide.

The Process Dispatchers Module

The Process Dispatchers module is used to configure dispatchers used by the SmartPost pro-
cess in WorkZone Process. You can set up three types of dispatchers:

« E-Boks
« Straalfors

o Local print

Depending on the type of dispatcher, you can fill in the following settings.

E-Boks

The settings below apply to the EBoks dispatcher.

Default set-

Name , Description
ting

The URL for the e-Boks service.

Enter one of the URLs depending on whether the con-
URL figuration is made for test or production.

Testsystem: https://demo-rest.e-bok-
s.dk/V1l.svc
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Default set-

Name .
ting

Description

Production system: https://rest.e-bok-
s.dk/vl.svc

SenderSystemid

The sender system identifier, which is retrieved during
the configuration of the system in the e-Boks admin-
istration portal.

ReceiverSystemid

The receiver system identifier, which is retrieved dur-
ing the configuration of the system in the e-Boks admin-
istration portal.

CertificateThumbPrint

Enter the thumbprint that identifies the e-Boks cer-
tificate.

SecurityProtocol TIs12

Denotes the security protocol to be used when com-
municating with e-Boks.

e-Boks provides the security protocol to be used.

7864320
MaxDocumentSize (7.5 mega-
bytes)

The maximum number of bytes that an e-Boks mes-
sage can contain. Messages that exceed this limit will
not be sent to e-Boks. The default value is 7864320
(7.5 megabytes). 0 indicates that no limit is enforced.
The size is reduced by 25% compared to the maximum
size communicated by e-Boks. Due to encoding, the
maximum allowed size must be reduced by 25%.

ResponseThreshold 1800

Defines the maximum time that SmartPostexpects that
it takes e-Boks to process a message. This value is
used to calculate the deadline (supervised by the dead-
line monitor). Specify the threshold in seconds. The
default value is 1800 seconds (30 minutes).

The default value is most often used. In situations
where the communication with e-Boks is slow, you can
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Default set- -
Description

ting

increase it. In test scenarios, you can reduce the
threshold, which reduces the time before a smartmail
with information about an exceeded deadline is sent.

Straalfors

The settings below apply to the Straalfors dispatcher type.

Name Default setting Description

The URL for the Stralfors Connect service.
Depending on whether the configuration is
made for test or production, enter one of the

two URLs.

Url .
Test: hitps://itest-

print.sconnect.dk/fiernprint/1.0.0

Production: https://-
prodprint.sconnect.dk/fjernprint/1.0.0

The system identifier, which is provided
when configuring the system in the Stralfors
SenderSystemID administration portal. Either Stralfors or the
person, who configures the portal for
Straalfors, must provide this identifier

Enter the thumbprint that identifies the

CertificateThumbprint
P Stralfors certificate.
The security protocol to be used when com-
municating with Stralfors. Stralfors determ-
ines which security protocol to use.

If you run Microsoft Windows Server 2012
R2, you can setitto TIs12 (TLS 1.2).

If you run Microsoft Windows Server 2008
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Name Default setting Description

R2, itis possible to set this to TIs12 (TLS
1.2), but it requires an additional con-
figuration. See the Microsoft article
TLS/SSL Settings for more information.

The setting is case sensitive and must be
written as TIs.

The maximum number of bytes that a mes-
sage for remote print can contain. Mes-
sages that exceed this limit will not be sent
_ 50000000 (50 for remote print. The default value is
MaxDocumentSize megabytes) 50000000 (50 Mb).

Unless otherwise communicated, it is
recommended to keep the values provided
at the installation.

Defines the maximum time that SmartPost
expects that it takes to send a message to
Stralfors. This value is used to calculate the
deadline (supervised by the deadline mon-
itor). The value is an integer, which (if pos-
itive) specifies the threshold in seconds. If
the value is zero or negative, SmartPost
uses a more advanced algorithm to determ-
ine the deadline, which depends on the

StraalforsResponseThreshold -1 weekday, the type of letter, and the time of
the day. If no value is specified, the
advanced algorithm is used.

Normally, the default setting is used.

If the communication with Stralfors is very
slow, you can specify a high value. In test
scenarios, you can set the threshold to a
low value (but not zero), which means that
the deadline will be quickly exceeded .
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Name Default setting Description

The name of the company that is used in
the postal address. The postal address is
used when Stralfors produces the letters.

SenderName
The value should be taken from the address
on which the authority will receive postal let-
ters and returned mails.

Local print

The settings below apply to the LocalPrint dispatcher type.

Default o
Name . Description
setting

Defines the maximum time that SmartPost expects
that it takes for local print to process a message.
This value is used to calculate the deadline (super-
vised by the deadline monitor). Specify the
threshold in number of seconds. The default value
LeEE PimIREEporEel IEsiele et is 1800 seconds (30 minutes). If it happens to be
the end of a business day, the deadline auto-
matically changes to the next business day taking

into account weekends and holidays.

The default value is most often used.

SenderName Not used.

The E-boks Materials Module

The e-Boks Materials module is used to set up e-Boks materials that are used in the
SmartPost process. An e-Boks material is a configurable item in e-Boks, which describes
what to be communicated to the end user.

You need to create e-Boks materials in e-Boks first and get the e-Boks IDs. See Configure e-
Boks materials in the WorkZone Process Administrator's Guide.

Name The name of the material.
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E-Boks ID The identifier of the material that the organization has created in the e-Boks
Administration Portal.

Replyable Select this check box to indicate whether the material is replyable. You
selection must correspond to the e-Boks material setup in the e-Boks
Administration Portal. If the organization has configured the e-Boks mater-
ial as replyable in the e-Boks Administration Portal, you need to select this
check box. The material determines whether the user can reply to a mes-
sage.

Order The order in which the materials will be shown in the E-boks material field
in the Send SmartPost dialog box.

You can set up which material to show by default in the DefaultMateriallD
setting. Click Operations > Processes, and then select the SmartPost pro-
cess. The SmartPost Settings are shown in the lower right corner.

Localized names

Text The name of the material that is shown in the Send SmartPost dialog
box.

Culture The display language.

Source The current language code (i.e. default language).

The Remote Print Types Module

In the Remote Print Type module, you can set up remote print types, which are used by the
SmartPost package in WorkZone Process. Each remote print type defines how Stralfors,
the remote print service provider, handles and prints SmartPost messages. The remote
print types are displayed in the Remote print type field in the Send SmartPost dialog box
in WorkZone Client. See also Configure remote print types in the WorkZone Process
Administrator's Guide.

You can set up which remote print type to be displayed by default in the DefaultRe-
motePrintypellD setting under Operations > Settings. See .
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Cell Description

An identifier of the remote print type. The ID is generated automatically.
ID You need this ID to specify which remote print type to use as default. See
setting in the process settings.

Enter a descriptive name for the remote print type. The name will be shown

Name . _ .

on the Remote print type list in the SmartPost dialog box.
Postage cat- _

Specify the postage category.
egory

Specifies how Stralfors handles letters that are returned to Stralfors in case
Returned Letter . .
Handii PostNord has not been able to deliver the letter. If you select true, Stralfors
andlin
g destroys the letter. If you select false, Stralfors performs no action.

Urgency Level Specify the level of urgency.

Simple/Duplex Specify whether to print the letter single-sided or double-sided.
Print Color Specify black/white or color print.

Envelope Type Specify the size of the envelope.

The order in whichthe remote print types will be shown in the Remote print

Order
type field in the Send SmartPost dialog box.

Enter an access code if different authorities want to use different remote
print types.

Access Code

The Dispatch Sequences module

The Dispatch Sequencesmodule is used to create and configure dispatch sequences in
theSmartPostprocess. A dispatch sequence is a prioritized set of dispatchers that
theSmartPostuser can selectin theSend SmartPost dialog box. See also Configure dispatch

sequences in the WorkZone Process Administrator's Guide.

ID The identifier of the dispatch sequence.
Name The name of the dispatch sequence.
Order The order in which the dispatch sequences will be shown in the Dispatch

sequence field in the Send SmartPost dialog box.
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You can select which dispatch sequence to display by defaultin
theDefaultDispatcherSequenceld setting under Operations > SmartPost
Settings.

Access code Enter an access code if other authorities want different dispatch
sequences.

Localized names

Text The name of the dispatch sequence that is displayed in the Send
SmartPost dialog box.

Culture The display language.
Source The current language code (i.e. default language).
Dispatch type order

Dispatch Order The prioritized order of the dispatchers that defines the dispatch
sequence.

Dispatcher The dispatcher.

The Document format Module

The Document format module manages Captia Web Client's integration with other sys-
tems' file formats, for example word processing programs. In this module, you can view and
maintain data regarding document types in the register document_formats.

The Document format module is the platform for configuring which types of documents the
WorkZone system should accept and which types the end user should be able to edit.

Be aware that despite the system's ability to store close to all known formats, itis not neces-
sarily advisable - and your organization may simply not be allowed to. Often organization
have to comply with a given set of rules and regulations regarding the transfer of doc-
uments to a central archive - and they may only accept certain formats.

For more information, see the web site of the Danish State Archives.
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The prerequisite for gaining access to the Document format module is the access code
DATAADM.

Click Operation > Document format to open the module.

Document format meta data

By default, all current document formats are pre-configured in the Document Format module.

Cell Description

Document Each created document type must refer to a unique document ID. Itis up to you
ID to decide the value of the ID.

Document Type a short and precise description of the document type.
Descrip-
tion

Extension Enter the extension of the document type, for example, doc for Microsoft Word

documents.
Mime Enter the MIME type of the document type, for example, application/Microsoft
Type Word for Word documents.

Program Prog ID - Program ID

ID Enter Windows program identification, for example, Word.Document.8 for

Microsoft Word documents.

OCR pro- You can select different OCR processing types for all document formats.

cessing Depending on the type of document you create, select a relevant OCR pro-

cessing type.

For example, for Word.Document.8, select the R, Text extraction OCR pro-

cessing type.

N, No processing Used for audio/video files.

O, OCR recognition Used for image files (TIF, PNG, JPG,
GIF, and so on).

R, Text extraction Used for text files (DOCX, TXT, and so

on).
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Cell Description

Default ref-
erences

T, Text extraction or OCR recognition Used for PDF files.

Mapping of defaults concerning the references between Extension, MIME Type,
and ProgID depends on the point of origin and what is needed.

Depending on the type of document format you create, select the check boxes
corresponding to the defaults that fit your purpose. Note that for each relation
between extensions, MIME types, or program IDs, you can only select one check

box.

Default reference Description

Default Extension to Mime Type Files with the specified extension must
use the specified MIME type.

Default Extension to Program ID Files with the specified extension must
use the specified program ID.

Default Mime Type to Extension Files with the specified MIME Type
must use the specified extension.

Default Mime Type to Program ID Files with the specified MIME Type
must use the specified program ID.

Default Program ID to Extension Files with the specified program ID
must use the specified extension.

Default Program ID to Mime Type Files with the specified program ID

must use the specified MIME type.

Some document types have several extensions, for example HTML files that
have both the extensions HTM and HTML. This results in an entry for each of the
extensions. In the example below, there is one entry corresponding to the HTML
extension and two entries per HTM extension as they refer to two different Pro-
gram IDs. The example shows the relations between extension, program ID, and
MIME type and how the default references are selected.

" DocumeniDessiplion  Elension - Mima T, W Frogram 1D g Mensnts Tipe Typel

E Exter Mime g
Mine Type  Progiem D toExenzion  Progiam D Io Evtenen. Mime Type. o

DOCOSE | Hypeitet Markup Language HTM TEXT/HTML him I, Test musaction
DOCOSE  Hyositerd Makuo Language HTM TEAT/HIML il . Tenl extachon
DOCOSE | Hypeitedt M \arkup Language HTML TEXT/HTML ik B, Tast esraction

The Default Extension to Mime Type and Default Extension to Program ID
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Cell Description

check boxes are selected for both the HTM and HTML extensions. Note that the
check boxes are only selected for one of the HTM extensions.

The mime type is identical and the Default Mime Type to Extension and Default
Mime Type to Program ID check boxes are only selected for one of the occur-
rences of the mime type.

The example also shows that HTML files have two different program IDs: htm
and htmlfile. The Default Program ID to Extension and Default Program ID
Mime Type check boxes are selected for each of the program IDs. Note that
there are two entries for the htmilfile program ID but the check boxes are only
selected for one of the occurrences.

Archive Select this check box to allow a given document type to be stored in Captia Web
Format Client electronic archive.

Editing Select this check box to allow editing of this type of document.
Possible

Program Id
Regarding the information in the column Program ID, this must be identical with their equi-
valent entries in Windows' registration database - the registry.

Therefore you must always check the Program ID against its entry in the registration data-
base. You can use the Windows registry editor, Regedit, to check the entry.

Get the program ID information

The file extension .doc. is used as an example below:

1. Click Start > Run to open the Regedit program.
The Run dialog opens.

Enter regedit in the input box named Open.
Click OK. The program Registry Editor is opened.
Click the plus button at HKEY_CLASSES_ROOT.

o kD

Click the extension .doc entry.
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6. Inthe right hand side pane, the standard value for the extension .doc is dis-
played - in this example Word.Document.8. This is the value supposed to be
registered in the cell of column Program ID.

7. Copy the standard value in the column Data in this example Word.Docu-
ment.8.

8. Insert the value into the cell of column Program ID in the Document Format
module. Now the two entries match.

9. Place the cursorin another cell and click Database > Save.

Regedit is a registry editor. In this context, you use it to look up key information in the
Registry - Windows' registration database - to make sure it matches the Program ID entry.

Be careful not to change or delete any entries since this could have serious consequences
for your computer's future performance. The registry contains information about all installed
programs and how the computer runs.

Therefore, make sure that you follow the steps carefully. For added protection, back up the
registry. Then you can restore the registry if a problem occurs.

For more information about how to back up and restore the registry, view the article 322756
"How to back up and restore the registry in Windows" in the Microsoft Knowledge Base,
see http://support.microsoft.com/kb/322756/.

Create document formats

By default all current document formats are preregistered and pre-configured. In case your
organization lacks some document formats, you can register formats yourself.

Create a new document format

Example

Create a document format for Word.Document.8.
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1. Click Operations > Document Format.

2. Press Ctrl + Down Arrow> to place the cursor in the empty bottom line. Click in
the bottom row cell of the Document ID column. The cell becomes active and a tri-
angle and asterisk - P * - are displayed in the left most cell.

3. Click once in the cell to activate it.
Enter the unique ID of the entry.

4. Write a short description of the type in Document Description. For example:

Document ID WORDOS

Document Description Microsoft Word Document

Extension doc

MIME Type APPLICATION/MSWORD
Program ID Word.Document . 8
OCR processing R, Text extraction

Default references Select all check boxes.

Archive Format Select the check box.

Editing possible Select the check box.

5. Place the cursor in another cell and click Database > Save to save the document
type.
6. You have now successfully created a new entry.

Repeat the steps 2-7 to create additional entries.

Edit document format

You can edit any current document formats.

edit a document format
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1. Click Operations > Document Format.

2. Click the cell of the column you want to edit. The cell becomes active. Make
your changes.

3. You can edit the cells of the following columns:

o« Document Description

« Extension

o MIME Type

o Program ID
« OCR processing

« Defaultrelations

o Archive Format

o Editing possible

4. Place the cursorin another cell and click Database > Save to save your
changes.

The Record Access Module

The Record Access module manages access to records. Record Access is used for defin-
ing default values for record access. The purpose of the Record Access module is:

« Based on the role of the contacts attached to documents, you can define which
parties by default are granted record access.

« Based on the document group registered on the document, you can define which
documents by default are open for record access.

Roles

The roles are custom labels for contacts attached to documents. The roles must preexist in
the Custom Label module, domain AP, Document contacts.

In the Record Access module, you can exclusively register default access for contacts
attached to documents. You can make this function work for contacts attached to cases as
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well. To accomplish this you must create identical roles both for contacts attached to doc-
uments and for contacts attached to cases.

If the role "Complainant" by default is to grant record access for contacts attached to doc-
uments as well as for contacts attached to cases, you must create the role "Complainant” both
as a label belonging to label type AP and as a label belonging to SP.

Document groups

The document groups employed must be registered in module Custom Domain as a value in
domain type AG.

Prerequisites for managing Record Access

The prerequisite for gaining access to the Record Access module is the access code
PROFILADM.

Click Operation > Record Access to open the module.

Record access meta data

In the table below describes the record access meta data:

Cell Description

Custom The contents of the cells in this column displays the values registered for label
Label type AP in Custom Label module.

Access The cells in this column contain check boxes. When a box is selected, the access
Right rightis granted for the role selected, that is contacts with the selected role.

Record The content of the cells in this column displays the values registered for domain
Group type AG in the Custom Domain module.

Access The cells in this column contain check boxes. When a box is selected, the access
Right right is granted for the selected document group, that is documents with the selec-
ted document group.
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Create record access

You can define defaults for record access based on contact roles and/or document types.

grant default record access to roles

Example

An organization receives and handles complaints. The parties are registered on the cases
and documents by the roles they play such as Complainant, Defendant, and so on. By
default parties with these two roles must be granted record access.

1. Click Operation > Record Access.

2. Find the role you want to grant default record access in the Custom Label
column.

3. Selectthe check box in the Access Right column in the same row.

4. Click Database > Save. The custom label is granted default records access.
Repeat the steps 2 to 4 to grant access to more roles.

grant default record access to document groups

Example

An organization wants default record access to be given to documents with document
group "Complaint" and "Decision".

1. Click Operation > Record Access.

2. Find the Record Group (i.e. document types) you want to grant default records
access in the Record group column.

3. Selectthe check box in the Access Right column in the same row.

4. Click Database > Save. The record group is granted default records access.
Repeat the steps 2 to 4 to grant access to more roles.
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Disable record access

You can disable the default record access grants for both roles (Custom Label) and document

groups (Record Group). The procedure for disabling the grants are the same for both roles

and document groups.

disable default record access

oW N

Click Operation > Record Access.
Find the item for which you want to disable default record access.
Clear the check box.

Click Database > Save. Default records access has now been disabled for this
item. Repeat the steps 2 to 4 to disable more items.

The External Sources Module

The module External Sources manages integrations between Captia Web Client and

external systems, for instance, a service that delivers external data from an external source

such as a civil registration system - in Denmark such as the CPR register.

To ensure an integration the following conditions must be met:

The integration must be set up at the same time as the WorkZone Content Server
database is installed. Then basic data concerning the integration is automatically
entered into the database. Among other things this means that relevant configuration
information is displayed in the column Name and Description of the External
Sources module.

The organizations that want to use Captia Web Client with an integration, for
example CPR, must have an agreement with the provider of the service. The provider
then supplies information regarding software and configuration. The name of the soft-
ware and the parameters of the configuration must then be registered in the External
Sources module.

Prerequisites for managing External sources
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The prerequisite for gaining access to the External sources module is the access code
DATAADM.

Click Operation > External Sources to open the module.

External sources - save parameters

In External Sources module you must register the name of the program that provides the
service of the integration and the parameters required for the configuration of the integ-
ration.

configure a CPR service

1. Click Operations > External Sources.

2. Selectthe relevant row. In this example, itis the row with CPR in the Name
column and Personer (individuals from the CPR register) in the Description
column.

3. Fillin the cell in the Program ID column - in this example this should be:
sjCPRDRIVER.person

4. Fillin the cell in the column Parameters - in this example this should be: 1p=

5. Click in any adjacent cell followed by a click on Database > Save.

The Service Channels Module

The Service Channels module manages services such as mail import, file import and
server scanning.

Click Operation > Service Channels to open the Service Channels module.

About service channels

Prerequisites for managing Service channels
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The prerequisite for gaining access to the Service Channels module is the access code
DATAADM.

Purpose of the Service Channels module

The purpose of the Service Channels module is to be a general tool for monitoring and import-
ing of data for Captia Web Client.

Example

If, for example, all incoming letters are scanned into a special folder, the Service Channels
module transfers the scanned letters to Captia Web Client.

As an integrated part of the scanning process, you can use separator sheets. They can con-
tain information about the letters being scanned. The Service Channels' service will try to inter-
pret and process this information, attaching it to the letters as meta data.

When the Captia Web Client users open the Scanned today fixed list, the items displayed are
the result of the Service Channels module.

NT-service

Connected to the Service Channels is an NT-service named Scanjour.Services.Service. It
can be configured to support a number of tasks. Its own task is to support regular planned exe-
cution of a number of tasks for one or more service channels.

Channels

A channel has a number of plug-ins. They are constructed to allow the channel to perform spe-
cific tasks such as monitoring the appearance of:

« hew items, i.e. files in a folder,
« new mails in a mail account, or

o new items in a register in a database.
Plug ins

The number of plug-ins, which a channel needs, to perform its task may vary between 1 to 4.
Each plug-in performs a well defined task which can be used by other channels as well.
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The NT-service can be installed several times with its own unique ID number. Con-
figuration of the channel is done in WorkZone Configuration Management. By stating the
service ID for each channel, itis possible to make one service execute all channels or only
one channel.

You can have the following plug ins:

« A watch-plugin monitoring and examining new items.

« A data provider plugin that can process and format new data in such a way, that
they can be used in the plug ins mentioned below.

« A metadata provider plugin that is able to deliver the necessary metadata (in the
correct format) based on data coming into the system.

« A data consumer plugin that can handle transference of data to the database.
A channel can have one or more plug-ins - only the Watch-plugin is mandatory. The result
of the work of one plug-in is delivered to the next plug-in as raw material. Each plug-in

must control whether the input received is valid - if it is not, it must deliver an error mes-
sage.

The NT-service calls the plug ins defined for a channel in the following sequence:

1. watch,

2. data provider,

3. metadata provider,
4. data consumer.

The following options depends on your configuration:

« The service ID for the service to execute the channel.

« How often the service is to watch for data - how many minutes should elapse
between each check.

« Ifthe channel should be enabled or disabled.
Service channel meta data

Meta data for the columns in the upper right panel are described in the table below. Meta
data displayed in the columns of the other panels depends on which channel is selected
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for display in the upper right panel. This meta data is explained in the following configuration
examples:

« Configure file import

o Configure mail import

o Configure Serverscan

Meta data - upper right panel

Field Description

Channel Each channel must have a unique number. The number identifying the chan-
Number nel is up to you as long as itis unique.

Service Several Channels can belong to the same service and have the same service
Number number. It is up to you to decide the number identifying each service.

Description Enter a short and precise description of the channel.

Scan Inter- Period of time between each surveillance scan in minutes.
val
(minutes)

Enabled A selected check box indicates that the service channel is enabled.
Watch Class This cell contains a drop-down box with the following options:

o Scanjour.Services.DirectoryWatch

« Scanjour.Services.MailPop3Watch

Data Pro- This cell contains a drop-down box. Here you can select, for example Scan-
vider Class jour.Services.MailDataProvider

Metadata This cell contains a drop-down box. Here you can select, for example:

Provider
Class « Scanjour.Services.MailMetaDataProvider or

« Scanjour.Services.FileMetaDataProvider

Data Con-  This cell contains a drop-down box. Here you select, for example:
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Field Description

sumer Class Scanjour.Services.XdiDataConsumer

Error Path  Enter the error path, for example: C: \ServiceError\Channell

Last Scan  Time stamp displaying when the last scan was executed - automatically

updated by the system.

Server Server name is automatically inserted by the system.

Meta data - lower right panel

Field

Description

Service Number

The same as the number displayed in the Service Number column
in the upper right panel.

Queue

Select the queue which the Service Channel must use. In the
drop-down box, you have the following options: Blank, 1, 2, 3, 4 or
5.

Technical information, see - Service queue - technical note.

Service Name

The Service Name is made up of 4 parts:

The name of the service

e« The service number
« The name of the WorkZone database

The queue number

Status Status can be Starting, Started, Stopping or Stopped.
If necessary, click the Update button to update status information.
Logon as The drop-down box of this field contains two options: Local Sys-

tem and User.

Buttons - lower right panel
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Button Function

Update Updates the content of the Status field. Here you can see if the service, for
instance, has started or stopped.

Install Installs the service in the operating system.

When you have installed the service, it can be displayed in the list of services
with Control Panel » Administrative Tools » Services.

You can start or stop a service from the Control Panel. However, you can neither
install nor uninstall a service from the Control Panel.

Start Starts the service in the operating system.

Instead you can choose to start the service by means of Control Panel » Admin-
istrative Tools » Services.

Stop Stops the service in the operating system.

Instead you can choose to stop the service by means of Control Panel » Admin-
istrative Tools » Services.

Uninstall Uninstalls the service in the operating system.

When you uninstall a service, it is automatically removed for the list of services
normally displayed with Control Panel » Administrative Tools » Services.

You can start or stop a service from the Control Panel. However, you can neither
install nor uninstall a service from the Control Panel.

Mode of operation

Mode Description

1. Plug ins First you must import the Plug in Assemblies. They are
contained in type DLL files. There are two Plug in Assem-
blies which are part of the default program:

« Scanjour.Services.Plugins.dll
A plugin performs a specific task. The following types of

plug ins can be contained in a plugin assembly:

« A watch-plugin monitoring and examining for
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Mode Description

2. Channels

3. Services

new items.

« A data provider plugin that can process and
format new data in such a way, that they can be
used in the plug ins mentioned below.

« A metadata provider plugin that is able to
deliver the necessary meta data (in the correct
format) based on data coming into the system.

« A data consumer plugin that can handle trans-
ference of data to the database.

Import of Plug in Assemblies - see Import plug-in Assem-

blies.

When you have imported the plug-in assemblies you
must configure the channels. A channel must have some
plug ins. They enable the channel to perform a specific
task, for instance, monitoring instances of new files in a
folder - for example, today's scanned letters.

To configuring the channels you must:

« (give a short description of the task of channel,
for example, Serverscan.

« enter what plug-ins the channel must employ.

« enter the path to the folder where error mes-
sages must be delivered.

A channel can have one or more plug ins - only the
Watch plugin is mandatory. The result of the work of a
plug-in is delivered to the next plug-in as raw material.
Each plug-in must check that the input received is valid. If
not, it must deliver an error message.

Configuration of channels - see Configure service chan-

nels.

When you have finished configuring all the channels, you
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Mode Description

must install and start the services that the channels are
using.

When you have installed a service, you can find itin the
list of services of the operating system - Control Panel >
Administrative Tools > Services.

You must enter whether the service should log on as

« Local System - for example, Configure file
import, or

« User.

You can specify whether the service is to use a Queue or
not. If the service operates channels loading large
amounts of mails or documents, choosing a specific
queue can be an advantage.

If no queue is selected, you may risk that free text index-
ing of documents, cases, document meta data registered
by the current Captia Web Client users is blocked.

About the interface

The Service Channels module consists of 4 panels.

File Edit Databare Bariz Data Cateqarier Se<urity Operation Optionr Help

EE 4HEBE 58S

Flugin Arremblicr CGhannel deFinitionr For Scanjour Servicor

1 3

ooooo

Servize Hum.: Q““““: | Fluginrettingr For channel

Servize Hame:

] — »

Service askionr
Logon ar:
4

Ficady db01 Urer e Del 1 1

Panel 1 The panel is a sheet. Each row can contain one et plug-in assembly. Plug-in
assemblies are DLL files that must be imported one by one. When they have been
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imported, they are displayed as separate rows in this panel.

Panel 2 The panel displays information about the service that operates the channel, which
is in focus in panel 3.

Panel 3 Channel definitions for Scanjour Services. The panel contains fields and buttons
for setting up the channels.

Panel 4 Plugin settings for channel n. The content of the panel depends on which chan-
nel is in focus in panel 3.

Import plug-in assemblies
In order to be able to create and configure service channels, you must import the necessary
plug- in assemblies.

The default plug in-assembly is called Scanjour.Services.Plugins.dll. Itcon-
tains a number of different plug ins such as:

« Scanjour.services.DirectoryWatch

« Scanjour.services.MailPop3Watch

« Scanjour.services.MailDataProvider

« Scanjour.services.MailMetaDataProvider
« Scanjour.services.FileMetaDataProvider

« Scanjour.services.XdiDataConsumer

import

1. Click Operation > Service Channels.

Click File > Import. The Open dialog is displayed.

Find the files. By default they are located in the KMD program folder.
Click the DLL you want to import.

a » DN

Click Open . The file is imported.
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Use the same procedure to import the other DLLs.

Configure service channels

This section describes how to configure different service channels.

Configure file import

Configuration of file import without eDeliverynote.

Prerequisite

The prerequisite for this procedure is that the relevant plug-in assemblies have already been
imported.

All path descriptions are merely suggestions. They can be altered in the actual configuration.

Itis possible to import one or more files from a folder. For that purpose use the following con-
figuration:

configure file import

1. Click Operation > Service Channels. The Service Channels module displays.

2. Click in the first data cell in an empty row in the upper right panel - Channel defin-
itions for ScanJour Services and enter the following values:

Channel Number 5

Service Number 2 - here is used the same service as for Serverscan.
Description Simple File Import

Scan Intervals 5

Enabled Click in the check box to enable the current channel.
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Column Enter this value

Watch Class Select Scanjour.Services.DirectoryWatch in the drop-down box.
MetaDataProvider Select Scanjour.Services.FileMetaDataProvider in the drop-down
Class box.

Data Consumer Class Select Scanjour.Services.XdiDataConsumer in the drop-down box.

Error Path Enter this path C:\ServiceError\Channel 5

3. Place the cursorin another cell and click Database > Save.

4. Click the left most cell of the row you just saved. Now the bottom right panel is
activated. Information concerning plug-in parameters can be registered here in
the panel named Plugin settings for channel 5.

5. Enter the following values:

Column Enter this value

DirectoryWatch monitored <path> - for example C:\Filelmport
folder

DirectoryWatch Folder *.imp
mask

FileMetaDataProvider <path> - forexample C: \Program
Metadata XML template  Files\KMD\WorkZone\Pro-
gram\XdiData\SjFesdPacket.xml

FileMetaDataProvider (If wanted - sjKomm compatible)
Organizational Unit

FileMetaDataProvider (If wanted - sjKomm compatible)
Dokumenttype

FileMetaDataProvider (If wanted - sjKomm compatible)
Dokumentgruppe

FileMetaDataProvider
Access code

XdiDataConsumer XML  <path> - for example, C: \Program
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Column Enter this value

Scheme folder Files\KMD\WorkZone\Program\XdiData

6. Place the cursorin another cell and click Database* Save.
The information has been saved.

Installing and starting the service

In the lower left panel, you can now install and start the service. The service must be started
as Local System.

Configure mail import

The prerequisite for this procedure is that the relevant plugin assemblies have already been
imported.

All path descriptions are merely suggestions. They can be altered in the actual configuration.

Itis possible to import mails. For that purpose use the following configuration:

1. Click Operation > Service Channels. The Service Channels module is dis-
played.

2. Click in the first data cell in an empty row in the upper right panel - Channel defin-
itions for ScanJour Services and enter the following data:

Column Enter this value

Channel Number 4

Service Number 2 - here is used the same service as for Serverscan.

Description Simple Mail Import

Scan Intervals 5

Enabled Click in the check box to enable the current channel.

Watch Class Select Scanjour.Services.MailPop3Watch in the drop-down box.
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Column Enter this value

DataProvider Select Scanjour.Services.MailDataProvider in the drop-down box.
Class

MetaDataProvider Select Scanjour.Services.MailMetaDataProvider in the drop-down box.
Class

Data Consumer  Select Scanjour.Services.Plugins in the drop-down box.
Assembly

Data Consumer  Select Scanjour.Services.XdiDataConsumer in the drop-down box.
Class

Error Path Enter the following path: C:\ServiceError\Channel 4

3. Place the cursorin another cell and click Database* Save.
The information has been saved.
4. Click the left most cell of the row you just saved.
Now the bottom right panel is activated. Information concerning plugin para-

meters can be registered here - the panel named Plugin settings for channel
4.

5. Enter the following values:

Column Enter this value

MailPop3Watch Mail <servername> -e.g.postman.KMD.dk
server Name

MailPop3Watch 110 - default pop3 port
Server port

MailPop3Watch user <user> - mail account to watch
name

MailPop3Watch user <password>
password

MailPop3Watch Mail <path> - forexample, C:\ServerMail
folder

MailDataProvider <path> - for example, C: \ServerMail\Mail
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Column Enter this value

Mail folder

MailMetaDataPro- <path> - forexample C: \Program Files\KMD
vider Metadata XML \WorkZone\IIS\WorkZone\Ap-

template p\Captia\SjFesdPacket.xml
MailMetaDataPro- (If wanted - sjKomm compatible)

vider organizational

unit

MailMetaDataPro- (If wanted - sjKomm compatible)

vider document type

MailMetaDataPro- (If wanted - sjKomm compatible)
vider document group

MailMetaDataPro-
vider access code

XDIDataConsumer  <path> - forexample, C: \Program
XML scheme folder Files\KMD\WorkZone\Program\XDIData

6. Place the cursorin another cell and click Database > Save.

Install and start the service

In the lower left panel you can now install and start the service. The service must be started as
Local System.

Configure Serverscan

The prerequisite for this description is that the relevant plug-in assemblies have already been
imported.

All path descriptions are suggestions. You can change them in the actual configuration.
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1. Click Operation > Service Channels. The Service Channels module displays.

2. Click in the first data cell in an empty row in the upper right panel - Channel
definitions for ScanJour Services and enter the following values:

Column Enter this value

Channel Number 2

Service Number 2

Description Serverscan

Scan Intervals 1

Enabled Click in the check box to enable the current channel.

Watch Class Select Scanjour.Services.DirectoryWatch in the drop-down box.

Data Consumer Select Scanjour.Services.XdiDataConsumer in the drop-down box.
Class

Error Path Enter the following path: C:\ServiceError\Channel 2

3. Place the cursorin another cell and click Database > Save.
The information has been saved.

4. Click the left most cell of the row you just saved - the cell to the left of Channel
Number. Now the bottom right panel is activated. You can register information

about plugin parameters here - the panel is named Plugin settings for channel
2.

5. Enter the following values:

Column Enter this value
DirectoryWatch monitored C:\XDIPORT
folder

Direct oryWatch Folder mask *.xdi

XdiDataConsumer XMLs- C:\Program Files (x86)\KMD\WorkZone\Pro-
cheme folder gram\XDIData
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6. Place the cursorin another cell and click Database > Save.

Installing and starting the service

In the lower left panel you can now install and start the service. The service must be started as
Local System.

Service queue - technical note

The WorkZone database has a register service_queue which is used to control the tasks the
agents perform.

The following agents may existin a Captia Web Client installation:

Agent Description

AgentFIX Responsible for the free text indexing of documents and records.
AgentOCR Responsible for producing a textual version of tiff documents.
AgentSUB Responsible for publishing documents.

Scanjour.Service Responsible for scanning documents, importing files and mails into the
WorkZone system.

When a document is imported into Captia Web Client, a job is either queued for the OCR
agent to produce an OCR version of the document or a job is queued for the FIX agent
requesting the document to be indexed. When cases and records are created in the database,
a job to index these is also queued for the FIX agent.

When the Scanjour.Service is used to import documents or mails, these types of jobs are also
queued for the agents. To avoid that the scanned documents block the agents' work, initiated
by interactive users of Captia Web Client, the database implements a number of tables used
by the service_queue. The actual table used depends on the user. In the system 5 users are
special because they see a table in a different schema:

User Schema and table

Normal users sjsysadm.service_queue
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sjserviceagentuser sjsysadm.service_queue
sjserviceagentuser1 sjserviceagentuseri.service_queue
sjserviceagentuser2 sjserviceagentuser2.service_queue
sjserviceagentuser3 sjserviceagentuser3.service_queue
sjserviceagentuser4 sjserviceagentuser4.service_queue

sjserviceagentuser5 sjserviceagentuser5.service_queue

Itis possible to start the agents (except AgentSUB) under a special user, the /queue=n
(n>=1, n<=5) controls which of the 5 special users above is used, when the agent calls
SOM. If no queue is specified, the sjserviceagentuser will be used as default.

The documents inserted into the database will result in new jobs for the OCR or FIX agent -
these jobs will end up in sjserviceagentuserl.service_queue. This queue requires that FIX
and OCR using queue=1 (and running under sjserviceagentuser1) are installed and run-
ning, because these agents will be the only ones able to see the table sjser-
viceagentuserl.service_queue.

Other scanners or mail importers using Scanjour.Service may be set up to use other
queues which will prevent them from blocking the work of each other (and the interactive
Captia Web Client users work as well).

204



Online Help

The Options Module

The Options module manages a number of possibilities for configuring WorkZone Con-
figuration Management with regard to, for example, language, warnings, and so on.

Prerequisites for managing Options

The prerequisite for gaining access to the Options module is the access code DATAADM.

Click Options and then select an options sub module, for example Languages.

Select userinterface language ... 205
Configure gridVieWS ... L 206
CoNfigUIre WarNiNG S . oo 207
Configure display of custom labels ... . 208
Configure display of custom domain ... ... 209

Select user interface language

The purpose of the Language module is to configure the user interface according to language.
You can choose to configure the following two options:

« Select language mode - select one of the following:

« Show all - Multi language mode. Data in all implemented languages is dis-
played.

« Show current - Single language mode. Only data in the language selected
as current language is displayed.

« Select current language - in this field you must select the culture code of the lan-
guage to be the default language of the WorkZone Configuration Management user
interface.
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select language mode

1. Click Options > Language.

2. Inthe Select language mode field, select the relevant language mode - Show
all or Show current from the list.

3. Click OK. If a module is open, it is automatically closed. The language mode
selected now has been chosen for the WorkZone Configuration Management
user interface as a whole.

How to select current language

1. Click Options > Language.

2. Inthe Select current language field, select the culture code of the language to
be default language.

3. Click OK.

See also Language mode.

Configure gridviews

The purpose of the Gridviews Options is a way to limit the number of displayed items and
thereby increase performance and reduce waiting.

When you, for example, search the use log you may risk that the system finds an excessive
amount of items. It takes long time to fetch and load this amount of items into the module.
To avoid this, you can set up how many items should be fetched at a time. After examining
the first set of items, you can go to the next set, and so on.

The grid view is by default set to 2000. In the Number of records in gridview field in the
GridViewOption dialog box, the default value is 2000___, that is two thousand succeeded
by two underscore characters, in all 6 characters.
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The field must always contain 6 characters. If you, for example, want to set the number to 350
it must be entered as 350____, that is three hundred and fifty followed by three underscore
characters.

Configure the gridview

1. Click Options > Gridviews.

2. The contents of the Number of records in gridview field is by default 2000__. If
you want to change the value to 350, it must be entered as 350___.

3. Click OK.

Configure warnings

The purpose of the Warnings sub module is to configure the extend of warnings and the level
of sensitivity. Here you can set up the following warnings:

Warn about a search when the number of rows exceeds a certain number

Warn about resetting the IIS when the register security is changed.

Warn about disabling the register protection.

Sound an acoustic alarm on error.

Open the Warnings form

1. Click Options > Warnings.

2. Click OK to save settings and close the dialog.

Warning about number of search results exceeds a certain number

If the check box is selected, you set up the system to warn you when the number of rows
retrieved exceeds a reasonable number. You define how many is a reasonable number. If a
warning should be given at, for instance, 500 it must be entered like this: 500___ = five hun-
dred followed by three underscores. The field must always contain 6 characters.
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Example

You want to see post codes of Germany. This means that several thousand post codes
must be retrieved. By default the system will issue a warning, when the number of rows
exceed 1000. A warning is issued:

"The selection returned 1255 rows. It may take a long time to load the rows. Do you really
want to load the rows?".

To avoid waiting use the Gridviews sub module to divide the data into manageable sec-
tions - see Options - Gridviews.

Warning about resetting the IIS when the register security is changed

When changes have been made to the configuration of register security in Register Secur-
ity module, the IIS Admin service on the server must be restarted. If the check box is selec-
ted, a warning is issued in this situation. The check box is selected by default.

Warning about disabling the register protection

In special situations users must log on to the WorkZone Configuration Management with
register security disabled.

If the check box is selected, a warning is issued in this situation. The check box is selected
by default.

Sounding an acoustic alarm on error

An acoustic alarm can be started when an error occurs. If the check box is selected, an
acoustic warning is issued when errors occur. The check box is selected by default.

Configure display of custom labels

The purpose of the Custom Label Options form is that you can choose what the module
displays.

The configuration you select here only applies to the WorkZone Configuration Man-
agement.
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The Custom Label module must be active to be able to select Custom Label under Options.

Change configuration

—_—

Click Basic Data > Custom Label.

N

Click Options > Custom Label to open the Custom Label Options form.

w

Select an option:

« Show All - All values are displayed.

Show Active - Only values without an end date are displayed.

4. Click OK.

Configure display of custom domain

The purpose of the Custom Domain Options form is that you can chose what the module dis-
plays.

The configuration you choose here only applies to the WorkZone Configuration Management.

The Custom Domain module must be active before you can select the Custom Domain under
Options.

Change configuration

—_—

Click Basic Data > Custom Domain.

N

Click Options > Custom Domain to open the Custom Domain Options form.

w

Select an option:

Show All - All values are displayed.

Show Active - Only values without an end date are displayed.

4. Click the OK.
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Technical notes

Some topics contain links to technical notes. They are only supplied where necessary. The
target audience for this type of information is technicians.

o Service Channels, queue

Service queue - technical note

The WorkZone database has a register service_queue which is used to control the tasks
the agents perform.

The following agents may exist in a Captia Web Client installation:

Agent Description

AgentFIX Responsible for the free text indexing of documents and records.
AgentOCR Responsible for producing a textual version of tiff documents.
AgentSUB Responsible for publishing documents.

Scanjour.Service Responsible for scanning documents, importing files and mails into
the WorkZone system.

When a document is imported into Captia Web Client, a job is either queued for the OCR
agent to produce an OCR version of the document or a job is queued for the FIX agent
requesting the document to be indexed. When cases and records are created in the data-
base, a job to index these is also queued for the FIX agent.

When the Scanjour.Service is used to import documents or mails, these types of jobs are
also queued for the agents. To avoid that the scanned documents block the agents' work,
initiated by interactive users of Captia Web Client, the database implements a number of
tables used by the service_queue. The actual table used depends on the user. In the sys-
tem 5 users are special because they see a table in a different schema:

User Schema and table

Normal users sjsysadm.service_queue
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sjserviceagentuser sjsysadm.service_queue
sjserviceagentuser1 sjserviceagentuserl.service_queue
sjserviceagentuser2 sjserviceagentuser2.service_queue
sjserviceagentuser3 sjserviceagentuser3.service_queue
sjserviceagentuser4 sjserviceagentuser4.service_queue

sjserviceagentuser5 sjserviceagentuser5.service_queue

Itis possible to start the agents (except AgentSUB) under a special user, the /queue=n
(n>=1, n<=5) controls which of the 5 special users above is used, when the agent calls SOM.
If no queue is specified, the sjserviceagentuser will be used as default.

The documents inserted into the database will result in new jobs for the OCR or FIX agent -
these jobs will end up in sjserviceagentuserl.service_queue. This queue requires that FIX
and OCR using queue=1 (and running under sjserviceagentuser1) are installed and running,
because these agents will be the only ones able to see the table sjser-
viceagentuserl.service_queue.

Other scanners or mail importers using Scanjour.Service may be set up to use other queues
which will prevent them from blocking the work of each other (and the interactive Captia Web
Client users work as well).
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Terms and conditions

Intellectual property rights

This document is the property of KMD. The data contained herein, in whole or in part, may
not be duplicated, used or disclosed outside the recipient for any purpose other than to con-
duct business and technical evaluation provided that this is approved by KMD according to
the agreement between KMD and the recipient. This restriction does not limit the recip-
ient’s right to use information contained in the data if it is obtained from another source
without restriction set out in the agreement between KMD and the recipient or by law.

Disclaimer

This document is intended for informational purposes only. Any information herein is
believed to be reliable. However, KMD assumes no responsibility for the accuracy of the
information. KMD reserves the right to change the document and the products described
without notice. KMD and the authors disclaim any and all liabilities.

Copyright © KMD A/S 2021. All rights reserved.
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